Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Webcam not recognized by 11.4, worked fine with 11.3

  1. #1
    Join Date
    Sep 2008
    Location
    Montevideo, Uruguay
    Posts
    80

    Question Webcam not recognized by 11.4, worked fine with 11.3

    I have a Z_Star webcam, which used to work perfectly well with OpenSUSE 11.3. At some time after updating to 11.4 (Tumbleweed, in fact) the device wasn't recognized any longer. Skype and Kopete both show that I have no available webcam device. The lsusb command (see below) shows the camera is there. What am I missing?

    Code:
    > lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 054c:01bd Sony Corp. MRW62E Multi-Card Reader/Writer
    Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 004 Device 003: ID 046d:c317 Logitech, Inc. Wave Corded Keyboard
    Bus 001 Device 019: ID 0ac8:307b Z-Star Microelectronics Corp. USB 1.1 Webcam

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    If you are using Tumbleweed, expect issues.
    But it is there.
    Try installing wxcam from packman
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2008
    Location
    Montevideo, Uruguay
    Posts
    80

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by caf4926 View Post
    If you are using Tumbleweed, expect issues.
    But it is there.
    Try installing wxcam from packman
    Hi! Thanks for the idea; I already had wxcam installed, but reinstalled it anyway. It didn't change a thing.

    I know this webcam worked with gspca, specifically gspca_zc3xx.ko -- how can I bring it back to life?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Install the stable release
    Don't use what amounts to a bit of a testing ground OS.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Sep 2008
    Location
    Montevideo, Uruguay
    Posts
    80

    Question Re: Webcam not recognized by 11.4, worked fine with 11.3

    A few questions...
    • What is the correct way to load the module for the webcam? I tried modprobe but that didn't make a difference.
    • Is there any file (blacklist? other?) that can be blocking the module or not allowing the webcam to be recognized?
    • Are there any boot time parameters that can affect the webcam?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by fkereki View Post
    I know this webcam worked with gspca, specifically gspca_zc3xx.ko -- how can I bring it back to life?
    Its not in the gspca compatibility list: http://mxhaard.free.fr/spca5xx.html

    Did you try any of the LD_PRELOAD commands: HCL:Web cameras - openSUSE

    Does the gspca driver show up as a loaded module when you type:
    Code:
    lsmod

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by fkereki View Post
    I know this webcam worked with gspca, specifically gspca_zc3xx.ko -- how can I bring it back to life?
    Its not in the gspca compatibility list: http://mxhaard.free.fr/spca5xx.html

    Did you try any of the LD_PRELOAD commands: HCL:Web cameras - openSUSE

    Does the gspca driver show up as a loaded module when you type:
    Code:
    lsmod

  8. #8
    Join Date
    Sep 2008
    Location
    Montevideo, Uruguay
    Posts
    80

    Question Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by oldcpu View Post
    Its not in the gspca compatibility list: http://mxhaard.free.fr/spca5xx.html
    Right... but it was working before, so the point is moot, I guess.

    Quote Originally Posted by oldcpu View Post
    Did you try any of the LD_PRELOAD commands: HCL:Web cameras - openSUSE
    Yes, I'm using that with Skype... but no luck.

    Quote Originally Posted by oldcpu View Post
    Does the gspca driver show up as a loaded module when you type:
    Code:
    lsmod
    The gspca driver shows up fine:
    Code:
    # lsmod | grep gs
    gspca_zc3xx            50961  0 
    gspca_main             31979  1 gspca_zc3xx
    videodev               79207  1 gspca_main

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by fkereki View Post
    The gspca driver shows up fine:
    Code:
    # lsmod | grep gs
    gspca_zc3xx            50961  0 
    gspca_main             31979  1 gspca_zc3xx
    videodev               79207  1 gspca_main
    Then maybe the problem is you are missing a configuration file. What is your criteria for saying it is not recognized by 11.4 ?? Just not working in Skype ? Thats not a good criteria or its a bad thread title.

    To quote my previous post:
    Quote Originally Posted by oldcpu View Post
    Did you try any of the LD_PRELOAD commands: HCL:Web cameras - openSUSE
    .. and ?

  10. #10
    Join Date
    Sep 2008
    Location
    Montevideo, Uruguay
    Posts
    80

    Default Re: Webcam not recognized by 11.4, worked fine with 11.3

    Quote Originally Posted by oldcpu View Post
    Then maybe the problem is you are missing a configuration file. What is your criteria for saying it is not recognized by 11.4 ?? Just not working in Skype ? Thats not a good criteria or its a bad thread title.

    To quote my previous post:

    .. and ?
    Two answers:
    1. There is no video device whatsoever in /dev -- that's why I say the device isn't recognized by 11.4. Since there's no video device, Skype, Kopete, Cheese, etc., do not show video.
    2. I am using the preload command for Skype -- it worked fine in 11.3 but fails now, which I assume has to do with having no /dev video device.


    What configuration files would you be referring to?

    Thanks for your time!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •