Results 1 to 2 of 2

Thread: OpenSUSE mit GRUB 2 von Ubuntu verwenden

  1. #1

    Default OpenSUSE mit GRUB 2 von Ubuntu verwenden

    Hallo alle zusammen,

    ich habe mir vorgestern einmal OpenSUSE installiert, hatte aber dann sofort das Problem,
    dass GRUB nicht installieren wollte, was gar nicht so schlimm ist, da ich schon ein Ubuntu auf der
    Festplatte habe, mit dem schon ein GRUB installiert ist. Also hab ich nach der Installation nach Ubuntu gebootet und ein

    Code:
    sudo update-grub
    ausgefhrt. Danach rebootete ich wieder, aber diesmal nach OpenSUSE. Jetzt das Problem:

    OpenSUSE wird bei mir auf einem 1680x1050 Bildschirm mit maximal 800x600 (selbst im Textmodus) angezeigt.

    Ich vermute, dass das was mit GRUB zu tun hat. Ich habe von Ubuntu aus ein GRUB 2 installiert.
    Im wiki steht was von

    Code:
    vga=794
    in der grub.cfg. Diese Datei kommt von GRUB 1. Deshalb bin ich mir nicht sicher, ob es so gut ist,
    wenn ich das jetzt einfach bertrage.

    Bevor ich jetzt was an der GRUB config datei ndere (und damit vielleicht meinen Computer Schrotte ) mchte ich gerne eure Ideen zu meinem Problem hren.

    Danke fr jede Hilfe,
    Tux15

  2. #2

    Default Re: OpenSUSE mit GRUB 2 von Ubuntu verwenden

    Anders als menu.lst sollte man grub.cfg nich editieren. Es wird nach jedem update-grub wieder neu geschrieben. Feste Eintraege kann man in /etc/grub.d/40_custom schreiben. Die werden nach update-grub an grub.cfg angehaengt. Du kannst dennoch vga=774 am Ende der Zeile, die mit "linux" startet in dem menuentry fuer openSUSE hinzufuegen. Es wird nichts kaputt machen, wird aber beim nachsten update-grub verschwinden. Du solltest diese Option in openSUSE Legacy Grub (installiere den in openSUSE Root Partition, nicht in MBR!) fuer den openSUSE Kernel hinzufuegen. Dann wird sie auch jedesmal bei update-grub gefunden. Ob die Option wirkt ist aber nicht gesagt. Wenn KMS unter openSUSE laueft wird die vga Option (nach einige Sekunden) wirkungslos. Es haengt vom verwendeten Grafiktreiber davon ab. Manche erforden KMS (Kernel mode setting). Andere ertragen es nicht. Eigentlich ist die vga Option veraltet - wird aber unter Umstaenden noch beruecksichtigt.

    * Wenn es mit openSUSE partout gar nicht klappt mit dieser Option (passiert manchmal auch bei aelteren nvidias), kannst Du sie unter Ubuntu wieder loeschen.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •