Results 1 to 8 of 8

Thread: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

  1. #1

    Default SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    Hey there, my first post here, just installed SUSE 11.4
    I did read the stickies and some other posts, so here's the output of my problem:

    In short - my adapter is working, authenticated on the selected AP, I can ping the AP, but I have no access to the outside world.

    Here's the commandline output:

    xaoc@FOREST:~> dmesg
    ...
    [ 795.517345] wlan0: authenticate with 00:01:38:e2:39:8c (try 1)
    [ 795.533595] wlan0: authenticated
    [ 795.638329] wlan0: associate with 00:01:38:e2:39:8c (try 1)
    [ 795.640960] wlan0: RX AssocResp from 00:01:38:e2:39:8c (capab=0x431 status=0 aid=3)
    [ 795.640964] wlan0: associated
    [ 795.646606] cfg80211: Calling CRDA for country: ES
    [ 795.651485] cfg80211: Regulatory domain changed to country: ES
    [ 795.651488] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 795.651491] (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 795.651493] (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 795.651496] (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 795.651498] (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)


    xaoc@FOREST:~> /usr/sbin/iwlist scan
    ...
    wlan0 Scan completed :
    Cell 01 - Address: 00:01:38:E2:39:8C
    Channel:6
    Frequency:2.437 GHz (Channel 6)
    Quality=69/70 Signal level=-41 dBm
    Encryption key:on
    ESSID:"WLAN_1E"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
    36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=00000065982911b9
    Extra: Last beacon: 3728ms ago
    IE: Unknown: 0007574C414E5F3145
    IE: Unknown: 010482848B96
    IE: Unknown: 030106
    IE: Unknown: 0706455320010D14
    IE: Unknown: 2A0100
    IE: Unknown: 32080C1218243048606C
    IE: Unknown: DD050010910400
    Cell 02 - Address: E0:91:53:3F:B0:F7
    Channel:1
    Frequency:2.412 GHz (Channel 1)
    Quality=43/70 Signal level=-67 dBm
    Encryption key:on
    ESSID:"WLAN_F3"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
    36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=00000063f2a861f2
    Extra: Last beacon: 5410ms ago
    IE: Unknown: 0007574C414E5F4633
    IE: Unknown: 010482848B96
    IE: Unknown: 030101
    IE: Unknown: 0706455320010D14
    IE: Unknown: 2A0100
    IE: Unknown: 32080C1218243048606C
    IE: Unknown: DD050010910400
    IE: Unknown: 050400010000
    Cell 03 - Address: 00:1C:26:07:3C:54
    Channel:1
    Frequency:2.412 GHz (Channel 1)
    Quality=52/70 Signal level=-58 dBm
    Encryption key:on
    ESSID:"Blabla1"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
    Mode:Master
    Extra:tsf=0000000575efe18b
    Extra: Last beacon: 5408ms ago
    IE: Unknown: 000C4C697665626F782D31344130
    IE: Unknown: 010882848B962430486C
    IE: Unknown: 030101
    IE: Unknown: 050401030000
    IE: Unknown: 2A0104
    IE: Unknown: 2F0104
    IE: Unknown: 32040C121860
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
    Cell 04 - Address: 4C:ED:DE:10:D1:D2
    Channel:6
    Frequency:2.437 GHz (Channel 6)
    Quality=40/70 Signal level=-70 dBm
    Encryption key:on
    ESSID:"Blabla2"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s
    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=000000253ef9217f
    Extra: Last beacon: 5091ms ago
    IE: Unknown: 000A4A617A7A74656C5F4344
    IE: Unknown: 010882848B960C121824
    IE: Unknown: 030106
    IE: Unknown: 050400010000
    IE: Unknown: 2A0104
    IE: Unknown: 32043048606C
    IE: Unknown: 2D1A0C181EFFFF000000000000000000000000000000000000000000
    IE: Unknown: 3D1606001300000000000000000000000000000000000000
    IE: WPA Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
    IE: Unknown: DD1E00904C330C181EFFFF000000000000000000000000000000000000000000
    IE: Unknown: DD1A00904C3406001300000000000000000000000000000000000000
    IE: Unknown: DD0600E04C020160
    Cell 05 - Address: 00:24:D2:C3:7E:8A
    Channel:11
    Frequency:2.462 GHz (Channel 11)
    Quality=59/70 Signal level=-51 dBm
    Encryption key:on
    ESSID:"Blabla3"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
    Mode:Master
    Extra:tsf=0000013e58374009
    Extra: Last beacon: 4372ms ago
    IE: Unknown: 000C566F6461666F6E6537453839
    IE: Unknown: 010882848B962430486C
    IE: Unknown: 03010B
    IE: Unknown: 050400010000
    IE: Unknown: 2A0104
    IE: Unknown: 2F0104
    IE: Unknown: 32040C121860
    IE: Unknown: DD0E0050F204104A0001101044000102
    IE: Unknown: DD090010180201F4000000
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

    xaoc@FOREST:~> /usr/sbin/iwconfig
    ...
    wlan0 IEEE 802.11bg ESSID:"WLAN_1E"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:01:38:E2:39:8C
    Bit Rate=1 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=69/70 Signal level=-41 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    xaoc@FOREST:~> /sbin/ifconfig
    ...
    wlan0 Link encap:Ethernet HWaddr 00:26:B6:70:B0:15
    inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:98 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:36985 (36.1 Kb) TX bytes:1376 (1.3 Kb)

    xaoc@FOREST:~> ping -c 5 192.168.1.1
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
    64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=16.0 ms
    64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=2.97 ms
    64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=2.25 ms
    64 bytes from 192.168.1.1: icmp_req=4 ttl=128 time=2.44 ms
    64 bytes from 192.168.1.1: icmp_req=5 ttl=128 time=2.11 ms

    --- 192.168.1.1 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 4004ms
    rtt min/avg/max/mdev = 2.118/5.169/16.063/5.454 ms
    xaoc@FOREST:~> ping -c 5 66.70.73.150
    connect: Network is unreachable

    What might be wrong and where should I look for help?
    btw forgot to mention, using same AP and password under Windows grants me internet access

  2. #2

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    Are there name servers listed in /etc/resolv.conf ?
    Can you ping those servers?


    If you set your connection up manually you'll also have to define those. If you're using dhcp you should obviously get them automatically.

    Can you ping external websites like google.com or yahoo.com?

  3. #3

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    contents of /etc/resolv.conf are:

    search FOREST local.lan
    nameserver 80.58.61.250
    nameserver 80.58.61.254

    cannot ping external IPs or hostnames, can only ping the AP
    btw I am using KDE and NetworkManager is off, using YaST

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    On 03/24/2011 06:36 PM, xaocka wrote:
    >
    > contents of /etc/resolv.conf are:
    >
    > search FOREST local.lan
    > nameserver
    > nameserver 80.58.61.254
    >
    > cannot ping external IPs or hostnames, can only ping the AP
    > btw I am using KDE and NetworkManager is off, using YaST


    I assume those are valid. The nslookup name for the first is
    250.Red-80-58-61.staticIP.rima-tde.net, so if your ISP is rima-tde.net, then
    they are probably OK. In addition, a bad resolv.conf would not prevent your
    being able to ping a valid IP. I think you have a routing problem. If you look
    at the output of the '/sbin/route -n' command, you should see at least

    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
    192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
    My prediction is that you have the second line, but not the first. The second
    line knows how to route things to the 192.168.1.X network, but not to any
    external network.

    To add the additional line to the routing tables, use

    Code:
    sudo /sbin/route add default gw 192.168.1.1
    This will provide the default routing to get to the rest of the world. Doing
    this once might not be permanent. If not, add the part beginning with
    /sbin/route to /etc/init.d/after.local.

  5. #5

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    Thanks a lot! That was really the problem and your solution worked perfect!

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    On 03/25/2011 09:36 AM, xaocka wrote:
    >
    > Thanks a lot! That was really the problem and your solution worked
    > perfect!


    Glad to hear. You made the diagnosis easy by presenting exactly the info that
    was needed.

  7. #7
    Join Date
    Apr 2011
    Location
    PA, USA
    Posts
    13

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    You guys Rock...I am setting up a new machine on 11.4 and my /etc/resolv.conf was all commented out with only one line in it that said "search site"
    I changed to nameserver 192.168.1.1 and all is working.
    Is this file dynamically changed by network manager?
    Thanks,
    Pete

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: SUSE 11.4 Realtek 8187B WEP WiFi - no access to Internet

    On 04/28/2011 10:36 PM, psuboy wrote:
    >
    > You guys Rock...I am setting up a new machine on 11.4 and my
    > /etc/resolv.conf was all commented out with only one line in it that
    > said "search site"
    > I changed to nameserver 192.168.1.1 and all is working.
    > Is this file dynamically changed by network manager?


    Yes, as long as it has not been modified by you; however, it sometimes gets
    confused. If you have the file /etc/resolv.conf.netconfig, then resolv.conf was
    not updated because it was thought that yours could not be overwritten.

    If you 'sudo cp /etc/resolv.conf.netconfig /etc/resolv.conf', then it should be OK.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •