Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: CPU stuck at lowest possible CPU frequency

  1. #1

    Default CPU stuck at lowest possible CPU frequency

    I'm running openSUSE 11.4 on a Dell Latitude E6500. 11.3 ran just fine, but 11.4 had been quite sluggish. I did some investigation, and found that the CPU is stuck at 800 MHz (should scale up to 2.67 GHz). The CPU is an Intel C2D T9550. I have made sure that the BIOS has Speedstep enabled, but annoyingly keep getting this:
    Code:
    Perhaps:/etc/init.d # cpufreq-info 
    cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
    Report errors and bugs to http://bugs.opensuse.org, please.
    analyzing CPU 0:
      driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 0 1
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 10.0 us.
      hardware limits: 800 MHz - 2.67 GHz
      available frequency steps: 2.67 GHz, 2.67 GHz, 2.13 GHz, 1.60 GHz, 800 MHz
      available cpufreq governors: conservative, userspace, powersave, ondemand, performance
      current policy: frequency should be within 800 MHz and 800 MHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 800 MHz (asserted by call to hardware).
      cpufreq stats: 2.67 GHz:0.00%, 2.67 GHz:0.00%, 2.13 GHz:0.00%, 1.60 GHz:0.00%, 800 MHz:100.00%
    analyzing CPU 1:
      driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 0 1
      CPUs which need to have their frequency coordinated by software: 1
      maximum transition latency: 10.0 us.
      hardware limits: 800 MHz - 2.67 GHz
      available frequency steps: 2.67 GHz, 2.67 GHz, 2.13 GHz, 1.60 GHz, 800 MHz
      available cpufreq governors: conservative, userspace, powersave, ondemand, performance
      current policy: frequency should be within 800 MHz and 800 MHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 800 MHz (asserted by call to hardware).
      cpufreq stats: 2.67 GHz:0.00%, 2.67 GHz:0.00%, 2.13 GHz:0.00%, 1.60 GHz:0.00%, 800 MHz:100.00%
    Unlike in openSUSE 11.3/KDE 4.6, I cannot change the governor from the KDE power management application.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: CPU stuck at lowest possible CPU frequency

    Does the cpu not step up if you say run glxgears at full screen for 10 mins
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: CPU stuck at lowest possible CPU frequency

    I have an Intel C2D T6670. My cpu-freq-info looks similar with different ranges, but does not include the comment: (asserted by call to hardware), or the line:
    Code:
    cpufreq stats: 2.67 GHz:0.00%, 2.67 GHz:0.00%, 2.13 GHz:0.00%, 1.60 GHz:0.00%, 800 MHz:100.00%
    From my cpufreq-info, for example:
    Code:
    current policy: frequency should be within 1.20 GHz and 2.20 GHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 1.20 GHz.

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: CPU stuck at lowest possible CPU frequency

    Have you tried it without "speedstep" set in your BIOS?

  5. #5

    Default Re: CPU stuck at lowest possible CPU frequency

    About an hour ago, I ran glxgears, the processor went up to full speed (verified with cpufreq-info and cat /proc/cpuinfo), and would scale up/down just fine on all other applications. I put the laptop to sleep, resumed, and the CPU is back to the lowest frequency (glxgears is running, I'm getting about 14 FPS).

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: CPU stuck at lowest possible CPU frequency

    Quote Originally Posted by consused View Post
    Have you tried it without "speedstep" set in your BIOS?
    BTW, just checked that "speedstep" is set to "enabled" in my BIOS. I only mentioned trying that in case of some mismatch between BIOS and 11.4, since there are only two values, but it's up to you.

    The kernel module loaded here is acpi_cpufreq (checked via lsmod).

    After checking if it is still working with another OS, and your BIOS is up to date, I suspect you may need to raise a bug report for the stuck frequency as an 11.4 regression.

  7. #7

    Default Re: CPU stuck at lowest possible CPU frequency

    Quote Originally Posted by consused View Post
    BTW, just checked that "speedstep" is set to "enabled" in my BIOS. I only mentioned trying that in case of some mismatch between BIOS and 11.4, since there are only two values, but it's up to you.

    The kernel module loaded here is acpi_cpufreq (checked via lsmod).

    After checking if it is still working with another OS, and your BIOS is up to date, I suspect you may need to raise a bug report for the stuck frequency as an 11.4 regression.
    With Speedstep disabled, acpi_cpufreq doesn't load, and the CPU runs at full-speed all the time, which is fine for now. With Speedstep disabled, acpi_cpufreq did load, but I did have that problem. I'll try reinstalling 11.4, and test a few OSs. Thanks.

  8. #8

    Default Re: CPU stuck at lowest possible CPU frequency

    All right, I've reinstalled 11.4, CPU is scaling properly again. I am getting this error, though.
    Code:
    Message from syslogd@Perhaps at Mar 24 20:21:40 ...
     kernel:[ 3888.545747] Uhhuh. NMI received for unknown reason 30 on CPU 0.
    
    Message from syslogd@Perhaps at Mar 24 20:21:40 ...
     kernel:[ 3888.545759] Do you have a strange power saving mode enabled?
    
    Message from syslogd@Perhaps at Mar 24 20:21:40 ...
     kernel:[ 3888.545765] Dazed and confused, but trying to continue
    11.4 really doesn't like my computer . Thanks for the help, guys.

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: CPU stuck at lowest possible CPU frequency

    There is one more cpu configuration that is part of YaST. DO the following:

    YaST / Software / Software Management / Search on Power and Install yast2-powermanagement and exit YaST. Then Goto

    YaST / System / Power Management and Just Press Finish. The first time this is run, the service pm-profiler must be started and you may even get an error message. So, now try this one more time:

    YaST / System / Power Management and select one of the three profiles. For the fastest CPU speed I use Low Latency Computing. On a laptop you would use Power Saving. There is also Balance Low Latency Computing and Default is what ever your PC was doing before you loaded this YaST utility.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  10. #10

    Default Re: CPU stuck at lowest possible CPU frequency

    This is for future reference, I've found the reason why the CPU gets stuck at 800 MHz. Apparently, according to this ubuntu forums post the problem lies with the power adapter. My laptop uses a 90W adapter, but the original was damaged, and I had been using a 65W adapter. With the (lower wattage than required) adapter plugged in, BIOS limits the CPU to 800 MHz (regardless of charge level), but on battery the CPU can go up to full speed. Presumably, 11.3 had been ignoring the BIOS limits, because I don't remember having performance problems, but do remember that, when using the laptop with the adapter plugged in, the battery hardly charged at all.

    tl;dr Make sure you're using the right type of power adapter.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •