Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Cannot startx unless Superuser

  1. #1
    Join Date
    Feb 2010
    Location
    NH-USA
    Posts
    240

    Default Cannot startx unless Superuser

    So I have a box and a laptop

    The box is 64 bit and the laptop 32

    I download 11.4 for the first time and do a dualboot, clean install

    Please note that I have setup many dualboot systems sucessfully, and this is NOT the problem. I can confidently say that.

    The 64 bit wouldn't let me startx unless I was su.

    ...thought maybe is was a bad download or something. Downloaded the 32bit for the laptop, logged in, same problem w/ the same output.

    Please note I always boot to runlevel three.

    this is an example of what I get:

    Login: ****
    Paswword: ***
    startx


    xauth: file /home/****//.serverauth.1881 does not exist



    Fatal Server Error:
    Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"


    Please consult the X.org Foundation support
    at Novell Login
    for help

    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error


    ------------------------------------------------------------------------

    xinit failed. /usr/bin/Xorg is not setiud, maybe that's the reason?
    if so either use display manager (strongly recommended) or adjust /etc/permissions.local

    Questions :

    1. Is it becasue I'm booting into runlevel three and something changed in between 11.3 and 11.4?

    2. Do I need to manually move "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old" ?

    3. /usr/bin/Xorg is not setiud could this be the problem, I'm not really sure I know what this even is....

    4. Do I need to chmod my permissions?



    Please also understand that I've been playing with Linux (primarily opensuse, by the way) for about 13 months now, so I know I have a lot to learn still. I know I can fix this w/ a bit of guidance,


    thanks in advance - Cheers

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Cannot startx unless Superuser

    subcook69420, I actually had the same problem with openSUSE 11.4 M6, which had a bad DVD posted online. I managed to make the DVD, but ran into this issue. Searching on-line I did find a solution, but the actual problem was a BAD dvd. I don't remember what I did any more, but I would ask if you double checked to make sure the m5d checksum is correct? Basically, you can get a bad download or you can make a bad DVD or CD burn which can corrupt some important files. I did not get this error when using the final release of openSUSE 11.4.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Cannot startx unless Superuser

    Hi
    It's not an error, it's by design for 11.4
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Cannot startx unless Superuser

    Hi
    Forgot to add the link...
    How to start x properly?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Cannot startx unless Superuser

    I had this myself and I can't quite remember the exact steps that fixed it, or even be a 100% sure which was the actual thing cos I did a few things, but it went something like this:

    xauth: file /home/****//.serverauth.1881 does not exist

    I thought that being it looking for a previous session file, not much I could do about that (that I know of, someone else may enlighten us), so I ignored it

    Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"

    Either Xorg.log doesn't exist or there's a permissions problem, or there's an existing Xorg.0.log.old that for some reason can't be over-written

    So I dropped out of kdm and into a console login as root, copied both files to Xorg.blah.disabled, checked the copies were created, then removed the originals with rm -f Xorg.blah for each one

    I then did vi /var/log/Xorg.0.log as root (I seem to remember this being because it couldn't find the log file when attempting to restart x, the vi command makes a new empty log file)

    At some point there was an error about the .Xauthority file in the user's home directory, so I made a .disabled copy of this and removed the original, much the as with the Xorg.0.log file

    So, vi .Xauthority as the user in the user's home directory and restarted x


    There were several x restarts along the way whilst doing this and I had to rename one of the files back from the.disabled version to the original, I think it may have been the .Xauthority (it's a hidden file so you won't see it in your file manager without enabling show hidden files)

    Sorry I can't be more specific about which step actually solved it, but without reproducing the problem I can't do it again and pay more attention, now I fixed it I have no idea how to break it again

    But if you copy the original files to something like .disabled first as I did before removing them, you can always copy them back so even if it doesn't work you can go back to where you were at any point, nothing ventured, nothin gained, and as long as you back up the files you're tinkering with first, nothing lost

    I have noticed a couple of permissions quirks in 11.4 myself, aside from this x one most noticeably with virtualbox, I've had to reset permissions on the VirtualBox binary 3 times cos it somehow got reset so that to no-one not even root could execute it after a restart, one for a bug report maybe?

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Cannot startx unless Superuser

    So to get to the jist of all of this, we can not longer run startx as a normal user, but must be a root user. The reason for this is that the file /use/bin/Xorg no longer has the setuid bit set. Based on the message pointed to, you could derive this from the information:

    Code:
    <bmwiedemann1> malcolmlewis: maybe you can just re-add the suid bit. /etc/permissions.local has a line for Xorg
    <bmwiedemann1> # setuid bit on Xorg is only needed if no display manager, ie startx  is used. Beware of CVE-2010-2240
    If you find the file /etc/permissions.local, this is what it says:

    Code:
    #
    # /etc/permissions.local
    #
    # This file is used by SuSEconfig and chkstat to check or set the modes
    # and ownerships of files and directories in the installation.
    #
    # In particular, this file will not be touched during an upgrade of the
    # SuSE Linux installation. It is designed to be a placeholder for local
    # additions by the administrator of the system to reflect filemodes
    # of locally installed packages or to override file permissions as
    # shipped with the distribution.
    #
    # Format:
    # <file> <owner>:<group> <permission>
    #
    # Please see the file /etc/permissions for general usage hints of the
    # /etc/permissions* files.
    # Keep in mind that this file (/etc/permissions.local) is being used by
    # default by SuSEconfig, the shell script that is used by yast and yast2
    # after package installation and configuration changes to make the changes
    # effective for the respective packages (eg generating the "real"
    # configuration files).
    # Always check if there are no conflicts between your "local" changes here
    # and the settings in the other permissions files by calling
    # "SuSEconfig" as root!
    # Please remember that logfiles might be modified by the logfile
    # rotation facilities (e.g. logrotate) so settings entered here might
    # be overridden.
    # This file needs to end with a newline.
    #
    
    #
    # suexec is only secure if the document root doesn't contain files
    # writeable by wwwrun. Make sure you have a safe server setup
    # before setting the setuid bit! See also
    # https://bugzilla.novell.com/show_bug.cgi?id=263789
    # http://httpd.apache.org/docs/trunk/suexec.html
    #
    #/usr/sbin/suexec2            root:root       4755
    
    # setuid bit on Xorg is only needed if no display manager, ie startx
    # is used. Beware of CVE-2010-2240.
    #
    /usr/bin/Xorg                 root:root       4711
    I took the # off of the last line and I presume if you run the command "/usr/bin/Xorg root:root 4711" that this sets the setuid bit on the Xorg file. I guess on each reboot, this file would set that same bit. I decided to just do this manually, and sure enough, startx now works for me.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Cannot startx unless Superuser

    Quote Originally Posted by jdmcdaniel3 View Post
    I took the # off of the last line and I presume if you run the command "/usr/bin/Xorg root:root 4711" that this sets the setuid bit on the Xorg file. I guess on each reboot, this file would set that same bit. I decided to just do this manually, and sure enough, startx now works for me.
    Hi
    Yes, but as the note says...beware CVE - CVE-2010-2240 (under review)
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Cannot startx unless Superuser

    Hi
    Yes, but as the note says...beware CVE - CVE-2010-2240 (under review)
    Yes malcolmlewis I did read through it and thank you for pointing it out. It does not seem to mention kernels 2.6.37 or 2.6.38 and I wonder if that will make any difference in this in the future? I had found this before and used it to fix my previous openSUSE milestone 6 installation, but this happened due to X not starting in the first place, but for other reasons. I guess that I did not realize it was for the final release as I have had no occasion to run startx since then. That in its self is kind of funny as I did used to use startx a lot when loading the nVIDIA video driver. I would do a init 3, load the driver as root and then log out, back in as me and run startx. Now, I most often am reloading the video driver after doing a kernel update, which I do right after a complete restart. It is kind of funny what drives your habits on your local PC. In any event, thanks for the information malcolmlewi.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Cannot startx unless Superuser

    Hi
    When I do an nvidia update I have always used init 5 && exit which will take you back to the login screen or your desktop if it's set to auto login
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Talking Re: Cannot startx unless Superuser

    Hi
    When I do an nvidia update I have always used init 5 && exit which will take you back to the login screen or your desktop if it's set to auto login
    I must give that a try though I don't understand what it does at present and it is just about bed time here once again and my mind is slowing down ..... stating to shutdown on me tonight .... too complicated.... error .... error ...

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •