Results 1 to 8 of 8

Thread: Phonon VLC/Xine/Gstreamer woes

  1. #1
    Join Date
    Mar 2011
    Location
    Cape Town
    Posts
    6

    Question Phonon VLC/Xine/Gstreamer woes

    Hey Guys,

    So after hours spent pacing through threads and sites, and enough tinkering to bring back Tinkerbell, I'm finally at a loss - which leads me to beg you for your awesome guidance.

    Symptoms:
    - I don't appear to be able to play audio from multiple applications (for example if I'm playing something through Amarok, Chrome doesn't produce any audio).
    - I have terrible background noise when no application is actively streaming audio.
    - The sound seems to be exacerbated when I move my mouse (almost like static crackle).
    - Since preferring the VLC for the Phonon backend, Amarok crashes at startup (yes, I'm aware of the Nvidia bug, which I don't hastily buy into anyway). When I prefer the Xine backend, Amarok launches successfully.

    I've also tried various other tricks proposed, such as only using Packman's packages for all my VLC libs.

    I've totally uninstalled the Gstreamer backend as it seemed to be my worse option in that I could not seek through tracks in Amarok.

    I know that OldCPU mentioned that the background noise/static could be caused by bad grounding, but I don't have the same issues in Window$, so I'm leaving that for the last option.

    Without posting all the things I've tried, does anything come to mind?

    Thanks in advance guys. I know you have tonnes of these types of questions.

    Cheers, Juan

    P.S. My system at present:
    openSUSE 11.4 32bit, onboard Intel 82801G HDA, Nvidia GTX 275 (using the latest Nvidia driver from the repo)

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Phonon VLC/Xine/Gstreamer woes

    I've seen minor cases of static with PCs using a 32-bit openSUSE and the proprietary nVidia driver (on a PC which died just over a month ago and I can no longer test with it).

    I've had such problems on a 64-bit PC.

    One side of me speculates that this is yet another case of 32-bit no longer keeping pace with 64-bit. Is your hardware 64-bit ? IMHO now is a good time to switch to 64-bit if you have the option. I can't say that will solve your problem - but that is just my observation ... I have seen static on 32-bit and never on 64-bit.

    As for tons of questions on static ... actually, there are not that many. Often just lowering the volume gets rid of the static. If the static is obsessively bad then its likely a bug in the automatic configuration of either alsa, or of some application associated with the sound.

    Also for static, I have found that if I go into each applications configuration/preferences and carefully select the 'output audio mode' (called different between applications) I can reduce and in cases even eliminate such static (on a 32-bit pc ... I've never had the problem on a 64-bit). Typically the alsa oss emulation works reasonably well in my experience.

    In the case of the xine backend, you need to install xine-ui in order to tune that, and you need to run xine backend with the xine controlled permissions 'master of the known universe'.

    Reference multiple applications sharing the sound device, pulse audio should handle this assuming you have not disabled pulse audio. When tuning pulse audio, I find it helps to install the application 'pavucontrol' (which one must install extra, but its in the OSS repos) and then when one is playing audio from an application (or more) run 'pavucontrol' and tune the audio.

    If you can not eliminate the static, then write a bug report on openSUSE-11.4 component sound. There is guidance here: openSUSE:Submitting bug reports - openSUSE and you can use your openSUSE username and password when logging on to buzilla. Attach to your bug report as a file the output file /tmp/alsa-info.txt of running the command:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    and describe the problem symptoms in the bug report. The SuSE-GmbH sound packager (who is also an alsa sound developer) will not read a forum thread, so there is no point in referencing this thread in the bug report. Then monitor the bug report and after a week or two you should start seeing suggestions/recommendations in the bug report.

  3. #3
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: Phonon VLC/Xine/Gstreamer woes

    Hi,

    I have found that the Phonon Xine backend works better in KDE than the GStreamer one. I would also recommend using the Packman versions of the Xine-related packages.

    You can leave GStreamer installed but increase the preference of Xine in the Phonon Backend settings.

    The fact you get static on your speakers could be that an unused input source is set to a high volume and Phonon/KMix are doing their job and mixing it for you.

    I would suggest installing pavucontrol (which you will then find under Applications|Multimedia|Volume Control|Volume Control) and select the Input Devices Tab muting any inputs not relevant to what you are doing.

    Run your audio applications, one at a time, and adjust settings on the Playback Tab of pavucontrol. You should be able to achieve something as a result of doing this.

    This is my first stab at your problem. We can explore other options from there.

    Regards,
    Neil Darlow
    Registered Linux user #122512. Desktop Linux user for 17 years.
    Asus Eee 900: 900MHz Celeron, 1GB RAM, 12GB SSD, 915GM, openSUSE-current+Tumbleweed
    Home-built Desktop: Athlon II X2 3.3GHz, 4GB RAM, 1TB SATA, GeForce G210, openSUSE-12.1-x86_64, KDE-4.7.2

  4. #4
    Join Date
    Mar 2011
    Location
    Cape Town
    Posts
    6

    Cool Re: Phonon VLC/Xine/Gstreamer woes

    Firstly, oldcpu and neildarlow, thank you very much for your responses. It's your input in these forums that contribute to openSUSE in a way that can never be praised enough.

    @oldcpu:

    Re 64-bit: I've always held off on 64-bit due to poor support from application & driver developers, but I think you're right; now seems to be a prime time to switch. I'm seeing more and more 64-bit versions of applications these days and it just makes for a great all round experience. I'll take the plunge as soon as I can back up my data.

    Re the static: It's the strangest thing. It seems to be triggered only when certain applications are active, which I suppose leads me to believe that pulse is having a hard time mixing the streams correctly - albeit a very uneducated guess.

    Installed the xine-ui, thanks for that!

    I've reported certain bugs for Amarok crashes and will monitor the static and if no remedy is found, will definitely submit the bug.

    @neildarlow:

    Definitely agree regarding Xine with KDE. I am more biased towards the VLC backend though due to the limitations with Xine that I've read about.

    @everyone

    My current solution for all of this is to strace Amarok while using the VLC backend. All applications output audio this way and things are happy in the universe.

    If I don't strace Amarok, it [Amarok] crashes everytime while using the VLC backend. The same does not happen when using Xine backend.

    A few strange things I've noticed:
    - Currently I'm not seeing any stream volume in pavucontrol.
    - When using the Xine backend I only saw the Amarok stream (in pavucontrol) and not any of my active browsers.
    - I check the following mixers for volume settings: kmix, pavucontrol and alsamixer. Their levels all seem to be different, which is bizarre.

    Anyway, thanks again for your suggestions and help. If anything comes up regarding the static, please be sure to let me know. If I find a definite solution, I'll post it back here.

    A last question: do you think the Nvidia driver (latest) could have something to do with the Amarok crashes when using the VLC backend? Also, might the static be related as well? I notice absolutely no static when only a browser window is in view.

    Cheers, Juan

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Phonon VLC/Xine/Gstreamer woes

    Quote Originally Posted by juanfurmie View Post
    A last question: do you think the Nvidia driver (latest) could have something to do with the Amarok crashes when using the VLC backend? Also, might the static be related as well? I notice absolutely no static when only a browser window is in view.
    The 32-bit nvidia proprietary 260.19.44 driver is known to be associated with application crashes where strace is necessary to avoid. The beta 270.30 purportedly solves this problem for many users.

    The 64-bit openSUSE users with nVidia hardware do not have this problem.

  6. #6
    Join Date
    Mar 2011
    Location
    Cape Town
    Posts
    6

    Default Re: Phonon VLC/Xine/Gstreamer woes

    Quote Originally Posted by oldcpu View Post
    The beta 270.30 purportedly solves this problem for many users.
    Yeah, I read that in the various bug trackers a few minutes ago. The more I think about it, the more it seems like it's all related to the current 260 Nvidia driver.

    Another reason to move to 64-bit.

    Thanks oldcpu!

  7. #7
    Join Date
    Mar 2011
    Location
    Cape Town
    Posts
    6

    Wink Re: Phonon VLC/Xine/Gstreamer woes

    Quote Originally Posted by juanfurmie View Post
    Yeah, I read that in the various bug trackers a few minutes ago. The more I think about it, the more it seems like it's all related to the current 260 Nvidia driver.
    Status update: updated to the Nvidia driver to the 270.30 beta which finally ended my Amarok crashes - thank goodness!

    Booting in though, revealed the static was still there

    I managed to get rid of the static by doing the following:

    1. Update all phonon packages.
    2. Switching to the Xine backend for Phonon.
    3. Deleting my sound card in Yast, then reconfiguring from scratch.
    4. Restarting X

    Boom! Crystal clear audio. No static noise. All applications produce audio concurrently and in an orderly fashion.

    This all being said, I'm definitely setting this weekend aside to upgrade to 64-bit.

    Just to confirm: the static noise returns when I switch the Phonon backends around. It also causes the applications to steal the rights to the sound card - talk about not playing well with others!

    If anyone needs help with a similar issue, drop me a line.

    Cheers, J

  8. #8
    Join Date
    Mar 2011
    Location
    Cape Town
    Posts
    6

    Default Re: Phonon VLC/Xine/Gstreamer woes

    Status update:

    After the above post I rebooted, just for my sound crackling/distortion to have returned. I check all levels again, backends, everything, but couldn't solve the problem again.

    So yesterday I took the plunge and installed 64-bit.

    Unfortunately, on boot, the crackling was still there (cue screaming), and because the Gstreamer backend was default for Phonon, I couldn't seek through tracks in Amarok. So in other words, SNAFU.

    After mashing through a million threads and attempts at a solution, I figured this must have something to do with PulseAudio as no other solutions were working.

    Hence, I had enough and completely removed PulseAudio.

    Reboot.

    Boom! Working. All cracking/distortion/static gone. All streams can play concurrently. Kmix behaves normally and can properly control volume for available streams.

    Just in case I was imagining things, I logged out and simulated a few normal scenarios, but without fail, each time I arrive back in X, all volumes are normal, all sound is perfect.

    I have seen many rants about PulseAudio, but I'm not going to chime in. It really appears to only go wrong in a few scenarios. In my case, I think it had something to do with the onboard Intel soundcard. Simply put, if you run into these issues, try to disable PulseAudio, reboot and see if your problems are gone. They very likely will be.

    Hopefully PulseAudio will be more stable in the future and these smaller bugs will be ironed out.

    Cheers, Juan

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •