Results 1 to 6 of 6

Thread: soft lockup: CPU# stuck, opensuse 11.4

  1. #1

    Default soft lockup: CPU# stuck, opensuse 11.4

    Hello,

    This looks very similar to what is described in this thread

    11.4 Boot Freeze

    That is there is a

    BUG: soft lockup - CPU#0 stuck

    message and the boot hangs.

    The modprobe/migration codes are not identical with the linked thread. I'm stuck with CPU#0 at [modprobe:138] and #1 stuck at [migration1:8]. Generally after 61 or 63s.

    This is a zypper dup from latest 11.3.

    The machine boots with acpi=off, luckily. But I'd like to have it all working.

    The forum says I can't post attachments; hwinfo output seems a bit copious to quote inline. But I'd be happy to provide any additional info obviously.

    Basic HW is Core2 E8400, Intel G41 chipset. Cheap ASRock MB.

    TIA,

    -Emery
    Last edited by hightechintl; 23-Mar-2011 at 08:16. Reason: added basic hw

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,284

    Default Re: soft lockup: CPU# stuck, opensuse 11.4

    It may be helpful to tell use what hardware this occurs on.

  3. #3

    Default Re: soft lockup: CPU# stuck, opensuse 11.4

    Quote Originally Posted by gogalthorp View Post
    It may be helpful to tell use what hardware this occurs on.
    It's a white box. Core2 E8400 3 GHz, ASRock G41M-S MB (Intel G41 + ICH7 Chipsets). 2 Gig of Ram. That's it. There's a Sata disk of some sort and a usb keyboard/mouse.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,284

    Default Re: soft lockup: CPU# stuck, opensuse 11.4

    You might check for BIOS updates for that board.

    Also since this is a desktop acpi is not as important as on a laptop.

  5. #5

    Default Re: soft lockup: CPU# stuck, opensuse 11.4

    Quote Originally Posted by gogalthorp View Post
    You might check for BIOS updates for that board.

    Also since this is a desktop acpi is not as important as on a laptop.
    OK I went through the exercise and updated the BIOS. No change.

    This computer doesn't really ever get turned off (except weekends!) so ACPI does have a purpose. I'd like to have everything working correctly at 11.4 level. For 11.3 I had to run in safe mode to avoid panics. (Turning acpi off helped but did not eliminate that problem).

    I'm guessing this is the same as Bug 679178.

  6. #6
    Join Date
    Mar 2011
    Location
    India
    Posts
    14

    Smile Re: soft lockup: CPU# stuck, opensuse 11.4

    Dear Friends,

    I have a Samsung R528 Laptop. I had exactly the same problem after upgrading to 11.4. This problem might possibly related to KMS feature of the kernel
    The problem was solved after adding the boot option ACPI_OSI="Linux"
    Please refer to the following ubuntu forum Link for more details
    [SOLVED] How to set NOMODESET and other kernel boot options in grub2 - Ubuntu Forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •