Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: YAST Date and Time

  1. #1
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default YAST Date and Time

    Hello, im here to ask for some assistance on YAST.

    When trying to change the date and time through YAST, and clicking on accept, i get an error message saying "cannot save configuration".

    This is on openSUSE 11.3 x86_64


    Thanks !

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST Date and Time

    On 03/23/2011 03:06 PM, assas1n wrote:
    >
    > i get an error message saying "cannot save configuration".
    >


    sure sounds like a permissions problem...

    are you having any other problems with YaST, or you system in general?

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: YAST Date and Time

    None at all.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,442

    Default Re: YAST Date and Time

    Until you get to the bottom of the problem in YaST you should be able to set the correct date and time by setting the BIOS clock to UTC and setting openSUSE to read the hardware clock.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST Date and Time

    On 03/23/2011 07:36 PM, assas1n wrote:
    >
    > None at all.
    >


    very strange...i just used YaST to move my time settings around and
    they saved just as i expected them to..

    so, what desktop environment and version are you using...

    do you normally use YaST for all your administrative duties, or do you
    sometimes directly/manually edit configuration files? what method
    would you normally use to do that?

    and, please show us the initial command line input and then the output
    of entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the terminal window back to this thread using the
    instructions here: http://goo.gl/i3wnr

    now i wonder if it had been that way since initial install, but you
    just now found the problem because you never tried to adjust the clock
    in YaST before??

    very strange.

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  6. #6
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: YAST Date and Time

    Code:
    1  | kde                     | kde                     | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/ |         
    2  | kernel                  | kernel                  | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/openSUSE_11.3/   |         
    3  | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | No       | No         |   99      | yast2  | cd:///?devices=/dev/sr1                                                   |         
    4  | packman                 | packman                 | Si       | Si         |   99      | rpm-md | http://packman.unixheads.com/suse/11.3/                                   |         
    5  | repo-debug              | openSUSE-11.3-Debug     | No       | No         |   99      | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/            |         
    6  | repo-non-oss            | openSUSE-11.3-Non-Oss   | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/              |         
    7  | repo-oss                | openSUSE-11.3-Oss       | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                  |         
    8  | repo-update             | openSUSE-11.3-Update    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/update/11.3/                                 |         
    9  | xfce                    | xfce                    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/X11:/xfce/openSUSE_11.3/        |         
    10 | xorg_1                  | xorg                    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.3/        |
    This happend on KDE, using the version from the repository listed above.
    99% of the time i configure through YAST, and almost never manually editing conf files. Every other aspect of YAST works fine. For example, just installed and configured a new printer through YAST!

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST Date and Time

    On 03/23/2011 11:06 PM, assas1n wrote:
    > 99% of the time i configure through YAST, and almost never manually
    > editing conf files. Every other aspect of YAST works fine. For example,
    > just installed and configured a new printer through YAST!


    admittedly i am stabbing in the dark (that is, i don't really _know_
    why you are having this problem...every thing i put into this note
    might be a waste of time OR may put you/us on a path to find the problem)

    open an X terminal (konsole, xterm, etc) type in and then enter
    Code:
    yast
    do you get an error message?
    if no, return here without going more..
    and copy past the terminal into this thread...

    if yes, then continue, type and enter

    Code:
    su -
    (don't forget the - )
    and then type in your root pass when asked for

    type and enter
    Code:
    yast
    NOT yast2

    you should now see the 'old style' yast, in it you nav with arrow keys
    and/or tab...so, arrow down to "system" on left and then tab to the
    right screen and arrow down to "Date and Time" and press enter to get
    into that section...make the changes here you wanted to make in the
    GUI version of yast...you can do that by nav from changable area
    (region, time zone, set to utc, change date time) with the Tab key and
    select within each area with enter or tab away from area..

    when you have all as you wish nav with tab to accept then to ok and
    then to quit to leave.....if it does not give the same "cannot save
    configuration" then i have no idea why, except may you figured out how
    to run yast in the GUI without invoking root privileges...

    if that works ok i have one other idea..

    oh, and unless you have reason (or maybe i should say: *if* it were my
    machine) i'd disable and stop automatically refreshing your repos
    numbered: 1, 2, 3, 9 and 10....leaving only 4, 6, 7 and 8 as active..

    and, of those the only one which should ever need refreshing is 4 and
    8 so you can stop refreshing 6 & 7.....and, i bet your software
    management will suddenly initialize faster..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: YAST Date and Time

    Did what u said from console and got this message:

    "Cannot update Dynamic configuration policy"

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST Date and Time

    On 03/24/2011 03:06 PM, assas1n wrote:

    >
    > "Cannot update Dynamic configuration policy"


    ok, looks like you need to add your details to this bug:

    https://bugzilla.novell.com/show_bug.cgi?id=588951

    please do so as the more who do the more likely it will get fixed...
    thank you.

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  10. #10
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: YAST Date and Time

    Ok, details added, thanks for the help !

    Hope it gets solved soon, almost got late to classes because of the erroneous time

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •