Results 1 to 6 of 6

Thread: static libusb

  1. #1

    Default static libusb

    hi guys, Im' new to this forum and pretty new for opensuse...I'm starting to use this distribution to evaluate it for programming.

    I can't solve a strange problem that in other distro is not present

    I'm trying to compile a program that require static libusb and this is the error:


    static libusb 1.0 not found (not in /usr/local/lib/ or /usr/lib/)


    It try to use these files that I'm not able to install in opensuse:

    /usr/lib/libusb.a
    /usr/lib/libusbpp.a

    where I'm wrong?is there a zypper pack that install them?

    thanks a lot

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: static libusb

    You may need to install the libusb-compat and libusb-compat-devel packages first.

    Code:
    zypper in libsusb-compat
    Last edited by deano_ferrari; 23-Mar-2011 at 01:58.

  3. #3

    Default Re: static libusb

    already done ((( but that files are non in it

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: static libusb

    Try libusb-devel

    Via openSUSE software search:

    http://software.opensuse.org/search?...ude_debug=true

  5. #5

    Default Re: static libusb

    I have opensuse 11.4...maybe is for these reason?maybe something is changed starting on this version?

  6. #6

    Default Re: static libusb

    yes...confirm...no more libusb 0.x ...we have to use libusb-compat now...have to change way to compile my program

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •