Results 1 to 5 of 5

Thread: OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

  1. #1

    Default OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

    I have not been able to get OpenOffice Writer to work at all.

    It runs perfectly, all buttons are clickable, does not crash, etc. However, I cannot type!

    In fact, I don't seem to be able to use the keyboard in OpenOffice at all. Short-cuts (e.g. ctrl-s) are completely non-responsive. Strangely, switching to Chinese in SCIM works (but the language bar fails to show itself), and typing a Chinese character causes the correct character to flash for a split second on the page before disappearing.

    Calling up the load/save dialogue (by mouse) works, but the dialogue leaves a trail of itself while being moved around the screen. These disappear when the dialogue is closed.

    Firefox is experiencing the opposite: keyboard works perfectly, but cannot call out SCIM by any means.

    (googling)
    /googling

    It seems that both are common problems associated with multilingual input.

    Did anyone manage to fix this somehow (without abandoning LibreOffice and downgrading Firefox)?

    Both are 11.4-exclusive problems for me. OpenOffice was flawless and Firefox worked well with SCIM most of the time back in 11.3.

  2. #2

    Default Re: OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

    Additional problem (comparatively minor one):

    The SCIM taskbar icon is bugged. Switching between languages should cause the icon to change, but it seems to overlap the existing icon with a new icon instead. The result is that after switching between 4 or 5 languages, we have a ball of indiscernible mess in the taskbar.

    As I am a literary/linguistic professional, I think I am going to have to give up on OpenSuse for now until better multilingual support presents itself...

  3. #3
    Join Date
    Dec 2008
    Location
    Malaysia
    Posts
    235

    Default Re: OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

    Quote Originally Posted by cometbah View Post
    I have not been able to get OpenOffice Writer to work at all.

    It runs perfectly, all buttons are clickable, does not crash, etc. However, I cannot type!

    In fact, I don't seem to be able to use the keyboard in OpenOffice at all. Short-cuts (e.g. ctrl-s) are completely non-responsive. Strangely, switching to Chinese in SCIM works (but the language bar fails to show itself), and typing a Chinese character causes the correct character to flash for a split second on the page before disappearing.

    Calling up the load/save dialogue (by mouse) works, but the dialogue leaves a trail of itself while being moved around the screen. These disappear when the dialogue is closed.

    Firefox is experiencing the opposite: keyboard works perfectly, but cannot call out SCIM by any means.

    (googling)
    /googling

    It seems that both are common problems associated with multilingual input.

    Did anyone manage to fix this somehow (without abandoning LibreOffice and downgrading Firefox)?

    Both are 11.4-exclusive problems for me. OpenOffice was flawless and Firefox worked well with SCIM most of the time back in 11.3.
    I got same problem here. I've uninstalled everything related SCIM,and installed ibus. In my case,SCIM work everywhere exclude LibreOffice,so do ibus,but,at least I can key in text in LibreOffice now & save the text to any doc format I prefer.
    * ibus icon show perfectly on taskbar,without any overlap issue.
    Dell Latitude D620~Intel Core2Duo T2300 1.66GHz~Intel 945GM~DDR2 667 2GB~openSUSE 12.1 KDE x86.

  4. #4

    Default Re: OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

    Exactly the same problems.

    As to firefox - didn't even notice that. Indeed, that's the problem.

    As to LibreOffice, it's fixed now in new stable versions of LO. You just have to update it. Here is the reference:
    No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    As to IBus - it won't help to get input in LO working - I checked it personally. This happens because of some LO internal error and replacing SCIM with Ibus shows exactly the same problem. If interested, please, see the referred topic above (I posted a quick guide how to reproduce that bug with IBus on LiveUSB).
    Maybe, Ibus will help to solve the problem with firefox (and I bet it worked OK, when I tried it)

    P.S.
    Personally, at the moment, I don't see Ibus as a proper replacement for SCIM. However I tried, I couldn't manage to get it working with Russian as my default system language. As long as standard KDE language switching utility works, Ibus refuses to work properly (at all, I mean, which is not a problem for SCIM and never used to be, since my first OpenSuse 10.0 with KDE3). I see the great potential and hope that some day I will be able to use a better integrated and promising IBus instead of "undead" SCIM. But not today, unfortunately.

  5. #5

    Default Re: OpenOffice (Libreoffice?) is not Usable + unable to use SCIM in Firefox

    Nice to hear that it's working now =)

    I have personally went back to 11.3, heh... Not nearly technically proficient enough to venture that far out, I suppose =S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •