Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: The sound of silence

  1. #1

    Default The sound of silence

    Hi,

    I am impressed with 11.4 and am happy that for the first time ever I don't need to install a kernel patch to support my on-board nVidia graphics.

    However, the on-board sound no longer works now. I don't know how to set it up in phonon. My device number 0 in phonon is MCP72XE/MCP72P/MCP78U/MCP78S high definition audio, and I assume this is my nVidia on-board sound card. The driver information states snd-hda-intel.

    How can I check what is wrong with it? It did work fine on 11.2 right up to the 11.4 installation. I do get system sounds (like the start-up and shut-down sounds), but nothing from any application, e.g., firefox playing a video.
    Based on the advice from another thread I tried:
    speaker-test -c2 -l5 -twav

    This does not produce any sound, but gives the following information:
    speaker-test 1.0.24.2

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 96 to 1048576
    Period size range from 32 to 349526
    Using max buffer size 1048576
    Periods = 4
    was set period_size = 262144
    was set buffer_size = 1048576
    0 - Front Left
    1 - Front Right
    Time per period = 3.782305
    0 - Front Left
    1 - Front Right
    Time per period = 3.797094
    0 - Front Left
    1 - Front Right
    Time per period = 3.783621
    0 - Front Left
    1 - Front Right
    Time per period = 3.777057
    0 - Front Left
    1 - Front Right
    Time per period = 3.785093

    As always, any advice will be greatly appreciated.

    Thanks,

    Abe

  2. #2
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: The sound of silence

    Hello Abe,

    I think here is a good troubleshooting guide here SDB:Audio troubleshooting - openSUSE you can try some tips from there, I think there is also a guide about how to post your problem so this way you can post more useful information about your system setup. Sorry, but I cant help you... newbie here

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: The sound of silence

    You can open up a terminal session and run the following command:

    Code:
    cat /proc/asound/cards
    On my computer here is the result as I also have an nVIDIA card with sound:

    Code:
    Command: cat /proc/asound/cards                                                                                                                               
                                                                                                                                                                  
     0 [XFi            ]: SB-XFi - Creative X-Fi                                                                                                                  
                          Creative X-Fi 20K2 SB0880                                                                                                               
     1 [NVidia         ]: HDA-Intel - HDA NVidia                                                                                                                  
                          HDA NVidia at 0xf8080000 irq 17
    Your primary sound card needs to be zero "0" and not 1. You can go to:
    Code:
    YaST / Hardware / Sound
    If your primary sound card is not zero then select it with your mouse and then pick the "Other" button on the bottom right and elect to "Set as the Primary Card". and see if this helps. I have a script file called start that can help with many other sound tests you can find here:

    S.T.A.R.T. - SuSE Terminal Audio Reporting Tool

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: The sound of silence

    When I saw the thread title I thought it's about Simon & Garfunkel.

    It's hard to tell what might be causing the problem.
    Maybe you need to post more info to catch the attention of the forum sound gurus.
    Things maybe of help diagnose are
    1. Post a screenshot of phonon-device preference
    2. The output of the command aplay -l
    3. How many soundcard is attached to your machine.

    As you probably know 11.4 is using pulse audio so you might need pavucontrol to be installed and not rely 100% with kmix.

    Good luck
    People who do not break things first will never learn to create anything

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: The sound of silence

    I struggled a bit with the milestone, RC and GM versions of 11.4 wrt sound, especially in KDE, because with pulse audio enabled by default, the change in behaviour is significant for many different types of hardware.

    I found what helped me was to install the application 'pavucontrol' and then run 'pavucontrol' and use that to select and tune one's audio.

  6. #6

    Default Re: The sound of silence

    First, I would like to apologise for giving the wrong impression with the title of my post. That Simon and Garfunkel song is great and far more serious than my current sound problems :-)


    Many thanks for the advice. I will look at the audio troubleshooting guide soon. In the mean time here are the requested outputs:
    First, cat /proc/asound/cards gives:

    0 [NVidia ]: HDA-Intel - HDA NVidia
    HDA NVidia at 0xfe020000 irq 22
    1 [CMI8738 ]: CMI8738 - C-Media CMI8738
    C-Media CMI8738 (model 37) at 0xcc00, irq 18
    2 [U0x46d0x9a4 ]: USB-Audio - USB Device 0x46d:0x9a4
    USB Device 0x46d:0x9a4 at usb-0000:00:04.1-2, high speed

    Device 0 is the on board nVidia sound.
    Device 1 is another sound card that I am not using currently.
    I guess device 2 is my webcam, but I am not sure.

    Second, I cannot include the phonon screenshot for some reason, but the order of devices is copied below:

    0 MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
    1 CMI8738/C3DX PCI Audio Device

    Third, the output from aplay -l is:

    **** List of PLAYBACK Hardware Devices ****
    card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: CMI8738 [C-Media CMI8738], device 0: CMI8738 [C-Media PCI DAC/ADC]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: CMI8738 [C-Media CMI8738], device 1: CMI8738 [C-Media PCI 2nd DAC]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: CMI8738 [C-Media CMI8738], device 2: CMI8738 [C-Media PCI IEC958]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


    Finally, I installed pavucontrol but when I run it and choose the output devices tab It goes into a long wait and eventually times out. I get no indication of what is actually happening.

    Thanks,

    Abe

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: The sound of silence

    naimab, did you miss my suggestion to make your primary sound card zero? Once again, navigate in YaST to:

    YaST / Hardware / Sound

    If your primary sound card is not zero then select it with your mouse and then pick the "Other" button on the bottom right and elect to "Set as the Primary Card".

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8

    Default Re: The sound of silence

    Hi.

    Don't apologize. I'm just kidding about Simon & Garfunkel.
    To be honest if not for the title it probably didn't caught my attention.
    I am not a sound guru also, I just recommended the things I think will be a little
    useful for your problem.

    Do as jdmcdaniel3 told you to do. and test your sound again.

    If you are using the analog then it should be the
    Code:
    card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
      Subdevices: 0/1
    Subdevice #0: subdevice #0
    If your using digital it should be the
    Code:
    card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    and with hdmi
    Code:
    card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    You said you are not using the pci sound card so we can disregard that.
    Maybe you can delete it in yast-system-sound.

    Having the soundcard 0 to be the default in yast and still doesn't work, check if it is in mute mood. If still doesn't work. as superuser try uncomment line 44 of /etc/pulse/default.pa
    Code:
    load-module module-alsa-sink and add  device=hw:0,0(this is your default sound card)
    to look like this
    Code:
    load-module module-alsa-sink device=hw:0,0
    You need to reboot your machine after this and it's better to reboot than re-starting pulseaudio.

    This place is a good start for pulseaudio in kde4.
    KDE
    Read it thoroughly and you'll find it very useful.
    People who do not break things first will never learn to create anything

  9. #9

    Default Re: The sound of silence

    I am sorry jdmcdaniel3, but I don't understand: my outputs do show that the nVidia card is device zero. What am I missing here?

    Abe

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: The sound of silence

    If you don't have success elsewhere, then I can take a 'kick' at trying to figure what is wrong. But to do that need a massive amount of information.

    I confess I'm not smart/experienced enough to fully understand the use/benefit of a lot of the diagnostic commands that you have already run per the request of other users, and instead I use other sources to obtain the information that I find helpful when trying to understand a user's sound problem. I documented what I need in the multimedia stickie: Welcome to multimedia sub-area

    and to make this easier I will quote the relevant section for you:
    please post ... providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.

    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ....
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here
    ... anyway, as noted, if you have no success elsewhere, and it comes to the point where you don't mind working your way through the above to provide more information, just post with the information and I'll do my best to take a look at it.

    Note I'm going on vacation in about 4 days, and I likely won't be replying to posts after that time (until my vacation is over).

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •