Results 1 to 3 of 3

Thread: Reading Repository Error

  1. #1

    Default Reading Repository Error

    Hi,
    Every repository I enter into suse, either through zypper or yast, I get the following error:

    Retrieving repository 'Riak' metadata [\]
    Download (curl) error for 'http://download.opensuse.org/repositories/home:/ghaskins:/erlang/SLE_11_SP1/repodata/repomd.xml':
    Error code: Unrecognized error
    Error message: Empty reply from server

    Abort, retry, ignore? [a/r/i/?] (a): a
    Download (curl) error for 'http://download.opensuse.org/repositories/home:/ghaskins:/erlang/SLE_11_SP1/content':
    Error code: Unrecognized error
    Error message: Empty reply from server

    Abort, retry, ignore? [a/r/i/?] (a): a
    Retrieving repository 'Riak' metadata [error]
    Repository 'Riak' is invalid.
    Download (curl) error for 'http://download.opensuse.org/repositories/home:/ghaskins:/erlang/SLE_11_SP1/content':
    Error code: Unrecognized error
    Error message: Empty reply from server

    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'Riak' because of the above error.
    Could not refresh the repositories because of errors.

    Here is the repository listing:
    # | Alias | Name | Enabled | Refresh
    --+-----------+-------------+---------+--------
    1 | Riak | Riak | Yes | No


    I'm running suse 11.1 as a VM. I've tried many different repositories and mirrors. I've also placed the URI in a web browser to validate, and they work.

    Any help is much appreciated, thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Reading Repository Error

    On 03/22/2011 04:36 PM, knuckleheads wrote:
    >
    > Every repository I enter into suse, either through zypper or yast, I
    > get the following error:
    >
    > /SLE_11_SP1/


    openSUSE 11.1 is no longer supported, it reached end of life in
    January of this year, see http://en.opensuse.org/Lifetime

    on the other hand SLE_11 continues to be supported by Novell, but the
    repos for SUSE Linux Enterprise Server/Desktop can not be used with
    openSUSE 11.1

    suggest you move up to openSUSE 11.3 or 11.4, *or* switch to SLE_11

    oh, and if you ARE using SLE_11 then maybe you have to provide a
    password to enter the repo after the 60 day trial period is over (but,
    i really don't know much about SLE_)

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: Reading Repository Error

    Hi
    Are you using openSUSE or SLE? please post the output from;
    Code:
    cat /etc/SuSE-release
    If you using SLE, then you need to be using the Novell forums NOVELL FORUMS else if it openSUSE 11.1 then as pointed out by DenverD, this is now unsupported, you might want to look at openSUSE:Evergreen - openSUSE

    You should use YaST and remove the repository you added, then only use the URL and repo to add, for example;
    Code:
    http://download.opensuse.org/repositories/home:/ghaskins:/erlang/SLE_11_SP1/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •