Results 1 to 5 of 5

Thread: Phonon doesn't accept standard capture device

  1. #1

    Question Phonon doesn't accept standard capture device

    I have two sound devices, an internal audio device on my motherboard and an external USB devices, which came with my headset.
    After upgrading to 11.4, the microphone on my headset ceased to work with my softphone.
    As it turned out, the softphone used the standard input device, which was defined in the Phonon tab in the KDE System Settings.
    Unfortunately, when I put the USB Device on top of the default input stack, it doesn't stay there.
    When I apply the changes and leave the Phonon tab or even enable "Show advanced devices " the stack always resets to its initial order.
    I was unable to find any kind of config file where Phonon saves this settings.
    Does anyone know a solution?
    Thanks,
    Jonas

  2. #2

    Default Re: Phonon doesn't accept standard capture device

    Workaround:
    Set the internal audio device from "Analog stereo Duplex " to "Analog stereo output" in the second tab of the Phonon menu. This deactivates the internal microphone input.
    I would really appreciate if someone could help me with this problem, at least could someone please give me a hint in which file Phonon saves this settings?
    Thanks,
    Jonas

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Phonon doesn't accept standard capture device

    In my case I installed the application 'pavucontrol' and then ran 'pavucontrol' and I found that it gave me better control over both my input and output audio devices on openSUSE-11.4.

  4. #4

    Default Re: Phonon doesn't accept standard capture device

    So far, I didn't find a workaround for my problem - tested on two different computers with AMD/ATI based sound cards. These seem to have two input devices, one called "Internal Audio Analog Stereo", the other "HDA ATI HD (ALC269VB Analog)" or similar (details in parenthesis differ). Only that one is what's wanted. pavucontrol doesn't show the second one at all, so is no workaround.

    I'll try the following:

    Manually loading an alsa source in /etc/pulse/default.pa ("load-module module-alsa-source device=hw:1,0").

  5. #5

    Default Re: Phonon doesn't accept standard capture device

    Ok, adding

    load-module module-alsa-source device=hw:1,0

    (the second capture device) did the trick - there's now a microphone device in the phonon audio input settings, but this is used, and works.

    This is still not at all acceptable for beginners, and obviously audio settings should be saved, but a workaround even for ATI based sound at least is possible.

    BTW: I had to compile the patched Alsa driver from Realtek to get sound working at all - the default kernel module for Intel-like HDA doesn't work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •