Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: New to Linux, Just installed 11.4 only boots into FailSafe mode

  1. #1

    Default New to Linux, Just installed 11.4 only boots into FailSafe mode

    Im new to Linux. Pretty much hate windows, my mac took a **** on me little bit ago and because of my dislike for steve jobs, wont go that route again. So after research decided to go with OpenSuse 11.4 distro.

    Installation had no problems but when I try to boot into the normal mode it just gets stuck on the screen that has a loading bar. The loading bar never makes any progress. After having waited for 15min I shut down and booted from failsafe mode. That worked fine twice only and then it prompts me in the command screen for login and password. After I input both it tells me to enjoy but Im still stuck at prompt screen, never loads GUI.

    Im now booting windows on my acer Aspire 5633wlmi. It has a Intel Core 2 duo t5500 processor which I understand is 64 bit. So the version of Linux I downloaded was the 64 bit one.

    Please help!! I cant stand using windows!!!

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    What graphics device?

    Boot with failsafe and open a terminal and post result of

    /sbin/lspci -nnk
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    Quote Originally Posted by TaiwanTom View Post
    Installation had no problems but when I try to boot into the normal mode it just gets stuck on the screen that has a loading bar. The loading bar never makes any progress. After having waited for 15min I shut down and booted from failsafe mode. That worked fine twice only and then it prompts me in the command screen for login and password. After I input both it tells me to enjoy but Im still stuck at prompt screen, never loads GUI.

    Im now booting windows on my acer Aspire 5633wlmi. It has a Intel Core 2 duo t5500 processor which I understand is 64 bit. So the version of Linux I downloaded was the 64 bit one.
    As caf4926 suggested, we need to know your graphics hardware to better understand the problem, as many boot problems are associated with the graphic drivers.

    I note from tux mobile a user posted the Acer Aspire 5633 that they own has the 256MB NVIDIA GeForce Go 7300 graphics.
    Code:
    01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
    hence it is possible yours has the same.

    They noted they managed to get graphics working with the Frame Buffer driver and also using the proprietary nVidia driver.

    When you boot to "safesettings" / "failsafe" you are forcing openSUSE to use the Frame Buffer driver (referred to as FBDEV). To load the proprietary driver requires a bit more not so friendly work, but users on this thread can guide you in doing that.

    The fact that a nominal boot failed, suggests to me that the default and newer "nouveau" open source graphic driver failed to work on your hardware. What is not clear to me is if the older "nv" open source graphic driver works.

    You could try booting with the boot code "nomodeset". (simply type 'nomodeset' (no quotes)) at the very first grub boot splash menu that comes up (where you can choose the various boot modes). 'nomodeset' (no quotes) will appear in the options line. Then do a regular boot and see if that works. Using 'nomodeset' is supposed to force openSUSE to try to boot with the 'nv' graphic driver (when nVidia hardware is detected).

    There is some basic graphic practical theory for openSUSE here: openSUSE Graphic Card Practical Theory Guide for Users (so that you can better understand what we are saying). I hope that helps.

    So please stick around and some one on this thread will be able to help you further.

  4. #4
    Join Date
    Mar 2011
    Location
    University of Cologne
    Posts
    3

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    I think this is a more common problem with the new 11.4 version. I saw the failure of the X system on several computers of rather different architecture.

    In most cases the boot process ends after runlevel 5 has been reached, but before
    als scripts in /etc/init.d/rc5.d have been executed.

    What you can do:
    - boot in failsafe mode
    - If the graphical login screen does not come up,
    log in as root.
    - ls /etc/init.d/rc5.d/S* | sed "s/$/ start/
    s?^?/etc/init.d/rc5.d/?" >level5
    chmod 744 level5
    ./level5

    The command sequence fills the file level5 with lines
    of the kind
    /etc/init.d/rc5.d/S08nfs start

  5. #5

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    Thanks for the prompt replies everyone. I ran the command that caf4926 recommended and oldcpu was right. The graphics device is indeed

    01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

    Was able to boot with code 'nomodeset' and use the nv driver. It still is a little glitchy screen flashes sometimes, and resizing windows scrambles text sometimes.

    I would like to do the 'not so friendly' loading of the proprietary driver if someone could hold my hand through that. In the meantime I will do the research oldcpu suggested.

    Deiters- Will running the command you mentioned only allow me to boot into failsafe mode?

    Thanks in advanced!!

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    SDB:NVIDIA the hard way - openSUSE
    Make sure you have the required software!!

    You need to download the driver from nvidia and place in your /home/username
    Then, where you typed nomodeset, this time add the number 3, so it will be:
    nomodeset 3

    At the prompt, login with your username and password
    then type: su
    after hitting enter you will be asked for the root password
    hit enter a couple of times

    Now type this: (Once you have typed NVIDIA, hit the TAB key)

    sh NVIDIA
    {TAB}
    the nvidia installer name should auto complete

    Answer yes to everything. Use the TAB key to switch focus as required
    That's it

    Or
    You could try
    nVidia Driver via Repo in 11.3 & 11.4 - Guide
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    caf4926-
    Thanks again for the prompt reply.
    I downloaded proprietary driver, put it in my user home folder. I understand the installation steps, but I have a few questions regarding the steps following installation.

    When disabling KMS the instructions you gave me tell me to:

    Add nomodeset to the boot options in /boot/grub/menu.lst

    Also remove it from the initrd. Edit /etc/sysconfig/kernel and set NO-KMS-IN-INITRD = yes . Then run:

    # mkinitrd

    The boot options is the first screen where I can choose to boot into windows, opensuse normal or opensuse failsafe right? Adding nomodeset to /boot/grub/menu.lst: how do i do this?

    Where do I execute these commands: Edit /etc/sysconfig/kernel and set NO-KMS-IN-INITRD = yes . Then run


    For blacklisting nouveau, do I just type the code into the console?

    I apologise for my ignorance, I truly am a newbie.
    Thanks

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    You shouldn't need to blacklist
    the other guide I gave you should show you how to do the nomodeset to menu.lst
    and the no-kms setting in sysconfig
    nVidia Driver via Repo in 11.3 & 11.4 - Guide
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    Im sorry if you have to be very blunt with me but could you please walk me through this task: Edit /boot/grub/menu.lst and add nomodeset to the boot arguments in the default boot.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: New to Linux, Just installed 11.4 only boots into FailSafe mode

    If you open Yast > system > bootloader
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    Then with it highlighting the default boot, as shown > edit
    Then add in nomodeset as shown here: ImageBam - Fast, Free Image Hosting and Photo Sharing
    OK to finish

    That's it
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •