Results 1 to 2 of 2

Thread: Fixing GRUB boot loader after Re-installing Windows XP

  1. #1
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default Fixing GRUB boot loader after Re-installing Windows XP

    This is a problem when Windows is running some malware that cannot be removed, which happens all the time. The problem is all the new hardware or specialized hardware will not work on Linux so Windows is the only choice. I would think the latest versions of Linux would have this problem worked out by now. I installed 11.3 one week ago, only to find that the repair option in the install menu no longer exists so don't bother uses this link to reload the GRUB HowTo Boot into openSUSE when it won't Boot from the Grub Code on the Hard Drive. I also tried this link Re-Install Grub Quickly with Parted Magic which does not work either. On step 2 typing grub returns the error message "grub command not found". You can use GRUB if you boot the install DVD and select Rescue Boot. However when you type find /boot/grub/menu.lst the error message "file not found" is returned.

    I did the following to restore my GRUB boot record. Boot the install DVD and select the update option during installation. Change all the repositories to enable except the NVIDIA repository, it is not responding at this time. When the system comes up go into Yast and open the boot loader. It should have your original boot menu in memory. Change the default to another option and re-write the MBR. This will write a new MBR using the original data updated with your new default. Re-boot and then change your default back. I am just a NewBe so this may not be exactly correct but I hope it saves someone like me some time fixing a MBR re-writing by the Windows installer.
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Fixing GRUB boot loader after Re-installing Windows XP

    The reason this didn't work
    Re-Install Grub Quickly with Parted Magic

    Is you didn't get Parted magic as directed
    Get this version
    http://dl.dropbox.com/u/10573557/pmagic-4.5.iso
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •