Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Cannot restart after install VirtualBox

  1. #1

    Default Cannot restart after install VirtualBox

    Tried 3 reinstallation and finally noticed what is causing the problem -

    1. Install openSUSE 11.4 AMD64 KDE
    2. Add VirtualBox repsitory
    (Index of /virtualbox/rpm/opensuse/11.4/)
    3. Install Virtualbbox (zypper in VirtualBox-4.0)
    4. Test out and confirm that VirtualBox is working

    5a. Leave -> Shut down.
    5b. Start computer by pressing power computer, openSUSE will present kdm, user can login and use as per normal.

    6a. Leave -> Restart
    6b. Computer will restart but kdm wil not be presented. You will be in terminal mode.
    6c. login as normal user and startx will NOT work.
    6d. login as root and startx will bring up KDE


    Any idea?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot restart after install VirtualBox

    sigh...... please don't login as root

    Look at the boot menu
    Does it appear to you to have more options than before?

    I'm wondering if you inadvertently installed another kernel and it is booting that by default, which may not have a graphics driver.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Cannot restart after install VirtualBox

    Quote Originally Posted by caf4926 View Post
    sigh...... please don't login as root
    LOL .. good advice. Just wanted to confirm that things is okay ... without connecting to network.

    Quote Originally Posted by caf4926 View Post
    Look at the boot menu
    Does it appear to you to have more options than before?
    Menu looks normal, only the normal entry for openSUSE.
    Grub2 is actually provided by Debian (dual boot) and a update-grub did not pick up anything new.

    Quote Originally Posted by caf4926 View Post
    I'm wondering if you inadvertently installed another kernel and it is booting that by default, which may not have a graphics driver.
    Possible, a pointer on how to verify if I did make that mistake will be great.

    Anyway, uname -r returns
    2.6.37.1-1.2-desktop
    and ls -l of /boot returns
    boot -> .
    boot.readme
    config-2.6.37.1-1.2-desktop
    grub
    initrd -> initrd-2.6.37.1-1.2-desktop
    initrd-2.6.37.1-1.2-desktop
    memtest.bin
    message
    symtypes-2.6.37.1-1.2-desktop.gz
    symvers-2.6.37.1-1.2-desktop.gz
    System.map-2.6.37.1-1.2-desktop
    vmlinux-2.6.37.1-1.2-desktop.gz
    vmlinuz -> vmlinuz-2.6.37.1-1.2-desktop
    vmlinuz-2.6.37.1-1.2-desktop
    Appreciate your help.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot restart after install VirtualBox

    So you are using Grub2 for booting?

    Virtual box install doesn't normally present an issue like this and really only if it does as I have suggested. But it doesn't appear to have done that.

    During the boot process, I take it you can see the verbose text rather than splash? Does it present any useful info when you do the restart method as opposed to shutdown.
    If you get a splash, press Esc to see verbose
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Cannot restart after install VirtualBox

    Yup, grub2 from Debian install.

    you are correct on the verbose text but not an expert like you, so can't really make out much from there... sigh..

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot restart after install VirtualBox

    Just check and do this in debian

    sudo update-grub
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Cannot restart after install VirtualBox

    Did that in post#3 ,
    update-grub .. Menu looks normal .. only the normal entry .. did not pick up anything new..

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot restart after install VirtualBox

    Uninstall Virtual box and all it's crud

    Check what you have installed in

    /var/log/zypp/history
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Cannot restart after install VirtualBox

    Quote Originally Posted by caf4926 View Post
    Uninstall Virtual box and all it's crud
    Done as you've suggested and disable oracle's repo after that. Still have the same problem.


    Quote Originally Posted by caf4926 View Post
    Check what you have installed in /var/log/zypp/history
    That's quite a lot of logs in there, cut out those relating to VirtualBox as below, hope you can help to spot something interesting.
    # 2011-03-22 11:55:13 VirtualBox-4.0-4.0.4_70112_openSUSE114-1.x86_64.rpm installed ok
    # Additional rpm output:
    #
    # Creating group 'vboxusers'. VM users must be member of that group!
    #
    # No precompiled module for this kernel found -- trying to build one. Messages
    # emitted during module compilation will be logged to /var/log/vbox-install.log.
    #
    # Stopping VirtualBox kernel modules..done
    # Uninstalling old VirtualBox DKMS kernel modules..done
    # Trying to register the VirtualBox kernel modules using DKMS..failed
    # (Failed, trying without DKMS)
    # Recompiling VirtualBox kernel modules..done
    # Starting VirtualBox kernel modules..failed
    # (modprobe vboxnetflt failed. Please use 'dmesg' to find out why)
    #
    2011-03-22 11:55:13|install|VirtualBox-4.0|4.0.4_70112_openSUSE114-1|x86_64|root@weekend.site|VirtualBox|880b7e06852f7ec592effc35b4c7effc0fb10c27
    # 2011-03-22 11:57:49 dkms-2.1.1.2-0.pm.1.1.noarch.rpm installed ok
    # Additional rpm output:
    # insserv: FATAL: service syslog is missed in the runlevels 4 to use service vboxdrv
    # insserv: exiting now!
    # /sbin/insserv failed, exit code 1
    #
    2011-03-22 11:57:49|install|dkms|2.1.1.2-0.pm.1.1|noarch|root@weekend.site|packman|b90ac8ddf72dc3b241041d8f183aa15af4b054f3
    2011-03-22 12:05:24|remove |VirtualBox-4.0|4.0.4_70112_openSUSE114-1|x86_64|root@weekend.site
    # 2011-03-22 12:10:06 VirtualBox-4.0-4.0.4_70112_openSUSE114-1.x86_64.rpm installed ok
    # Additional rpm output:
    #
    # Creating group 'vboxusers'. VM users must be member of that group!
    #
    # No precompiled module for this kernel found -- trying to build one. Messages
    # emitted during module compilation will be logged to /var/log/vbox-install.log.
    #
    # Stopping VirtualBox kernel modules..done
    # Uninstalling old VirtualBox DKMS kernel modules..done
    # Trying to register the VirtualBox kernel modules using DKMS..done
    # Starting VirtualBox kernel modules..done
    #
    2011-03-22 12:10:06|install|VirtualBox-4.0|4.0.4_70112_openSUSE114-1|x86_64|root@weekend.site|VirtualBox|880b7e06852f7ec592effc35b4c7effc0fb10c27
    2011-03-22 12:14:14|remove |VirtualBox-4.0|4.0.4_70112_openSUSE114-1|x86_64|root@weekend

  10. #10

    Default Re: Cannot restart after install VirtualBox

    what's your menu.lst file look like?

    danrche@area51:~> sudo cat /boot/grub/menu.lst
    danrche's password:
    # Modified by YaST2. Last modification on Mon Mar 21 10:27:19 CDT 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.1-1.2
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.1-1.2-desktop root=/dev/disk/by-id/ata-WDC_WD2500BEVS-08UST0_WD-WXE408HR7922-part2 resume=/dev/disk/by-id/ata-WDC_WD2500BEVS-08UST0_WD-WXE408HR7922-part1 splash=silent quiet showopts vga=0x367
    initrd /boot/initrd-2.6.37.1-1.2-desktop

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.1-1.2
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.1-1.2-desktop root=/dev/disk/by-id/ata-WDC_WD2500BEVS-08UST0_WD-WXE408HR7922-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x367
    initrd /boot/initrd-2.6.37.1-1.2-desktop

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •