Results 1 to 3 of 3

Thread: LibreOffice: space (grey box) inserted before some characters (?"!)

  1. #1

    Default LibreOffice: space (grey box) inserted before some characters (?"!)

    Hello,

    I did not have this problem with OpenOffice in OpenSuse 11.3, it came after upgrading to 11.4.

    When typing some characters (these three: ?"!) a blank space (grey box) in inserted before them. If the next character is a "normal" one, the grey box disappears as soon as such next character is typed. But, if the next character is one of these three, or a space, the box stays there.

    Being a local keyboard, I have to use the Shift key (? = Shift + key next to 0; " = Shift + 2; ! = Shift + 1). But, as you can see, only one of them (?) does differ from the USA keyboard, the other two ("!) are the same as for the USA keyboard. On the other hand, other characters requiring the Shift key ($%&/()=) do not raise the grey box, so I do not think that the point be the local keyboard.

    Any ideas?

    Thank you very much.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,442

    Default Re: LibreOffice: space (grey box) inserted before some characters (?"!)

    I did have the first problem with OpenOffice and it has persisted with LibreOffice. There is a typesetting convention that there is a space before these characters when followed by a space and I assume this has been implemented in OpenOffice. However, it is not a universal convention and should be something you can select in Toolsptions or linked to a particular locale setting.

    The keyboard issues are unlikely to be linked with LibreOffice which respects the keyboard settings of the desktop; I use half a dozen different keyboard layouts and both OpenOffice and LIbreOffice have respected them. The only possibility I can think of is that it does not recognise a user's shortcuts for some reason.

  3. #3

    Default Re: LibreOffice: space (grey box) inserted before some characters (?"!)

    Hi,

    whether or not you get a space inserted depends on the locale you set in LO.

    Some languages require spaces to be inserted before, for exemple, a "?" or a ";" whilst others don't.

    If you change (in tools->options->) the language parameters to the language/locale you're in, this will be set to the way this is to be done in that locale.

    HTH

    Lenwolf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •