Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Lan Card Driver Installation

  1. #1

    Default Lan Card Driver Installation

    Hi everyone, I`m quite new in linux. And I`m trying to install Intel EXPI9402PT PRO/1000 PT Dual Port Server Adapter on my machine. I download the drivers for this card from intel web page, but I can`t make it work. I`m running OpenSuse 11.3 version. When I tried to install it for the first time I got this message:

    Makefile:71: *** Kernel header files not in any of the expected locations.
    Makefile:72: *** Install the appropriate kernel development package, e.g.
    Makefile:73: *** kernel-devel, for building kernel modules and try again. Stop
    Then I install the kernel-source package and I got this one:

    Makefile:107: *** Linux kernel source not configured - missing version header file. Stop.
    I also installed kernel-devel package, but I get the same message. If someone knows something else will be great. Thanks.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Lan Card Driver Installation

    Based on the error messages that you have I suggest this:

    Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:

    Code:
        Development 
    
    [X] Base Development
    [X] Linux Kernel Development
    [X] C/C++ Development
    Then Press the Accept button on the bottom right and allow these applications to install. See if you can then install the Intel network driver.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Lan Card Driver Installation

    Hi thank you for the fast answer, but when I opened Software Management, and selected View button there was no Patterns. The options were:
    Technical Data
    Package Description
    Package Version
    File List
    Dependencies

    And whatever I select nothing happens. I have yast2 by the way, if it`s matter.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Lan Card Driver Installation

    It should look something like this
    http://dl.dropbox.com/u/10573557/Add...ase-devel.jpeg

    A little different if you use Gnome
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Lan Card Driver Installation

    I forgot to mention that I work in command-line. This is what I have:


  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Lan Card Driver Installation

    What do you have from a terminal:

    zypper lr -d
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Lan Card Driver Installation

    This is what I get:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+----------------------------------------------+----------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------+--------
    1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    2 | openSUSE_11.3_OSS | openSUSE_11.3_OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    3 | openSUSE_11.3_Updates | openSUSE_11.3_Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    4 | openSUSE_BuildService_-_devel:languageserl | openSUSE_BuildService_-_devel:languageserl | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/languages:/perl/openSUSE_11.3 |
    5 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    6 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    7 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    8 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    9 | serverhp:extensions_11.3 | serverhp:extensions_11.3 | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/php:/extensions/openSUSE_11.3 |

  8. #8
    Join Date
    Nov 2009
    Location
    USA
    Posts
    14

    Default Re: Lan Card Driver Installation

    Also install kernel-syms and see if it helps

    Cheers

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Lan Card Driver Installation

    When logged in as user, become su

    type: yast

    should look more like:
    http://dl.dropbox.com/u/10573557/kernelfix/4.png
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Lan Card Driver Installation

    Hi caf4926, yes this is the screen which I see when I type yast. Then I choose Software Managment, and I see:
    Starting the Software Manager
    x Initialize the Target System
    => Loading the Configured Repositories
    On the bottom I see loading line and after that load the screen which I post above.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •