Results 1 to 4 of 4

Thread: Apache+PHP - child crashes after authentication

  1. #1

    Default Apache+PHP - child crashes after authentication

    Using OpenSuse 11.4 brand new install. Kernel 2.6.28, Apache 2.2.7 and PHP 5.3.6 latest versions. All custom compiled.

    Apache starts properly and phpinfo() shows that all services up and running. Regular html and php pages load properly.

    Now say I load phpMyAdmin to examine my local MySQL inventory. The challenge page loads fine, I enter in the username and password (using cookies) and press enter. In Konqueror I get a message that the server has disconnected. In Firefox I get a dialog asking if I want to open index.php with Ark or save! Problem occurs in other PHP scripts that call for cookies.

    Err log shows
    [notice] child pid ... exit signal Segmentation fault (11)

    Rollback to Apache httpd 2.2.5 shows same problem, but that version worked fine for me on 11.3. Rollback to earlier kernel same problem. Very puzzled.

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Apache+PHP - child crashes after authentication

    Quote Originally Posted by colbec View Post
    All custom compiled.
    Use distribution default software. Problem solved.

  3. #3

    Default Re: Apache+PHP - child crashes after authentication

    In case anyone is following along, I have a new detail to report.
    The issue is related to POST requests in forms.
    The following code works correctly:

    <?php
    echo "crash test<br />";
    $cont = "<form action='' method='GET'>
    <input type='submit' name='' value='submit' />
    </form>";
    echo $cont;
    echo "ended<br />";
    ?>

    Change the form method to POST and Apache crashes in the sense that it can no longer deal with PHP files in the normal manner.
    Debugging continues.

  4. #4

    Default Re: Apache+PHP - child crashes after authentication

    Still working on this one.
    I have two machines, identical in configuration apart from different hard drives. One has Opensuse 11.3 and this one has 11.4 installed into a fresh / partition.
    If I copy the httpd binary from the 11.3 machine to the 11.4 then the problem with Apache and post method goes away.
    This is clearly not a satisfactory solution but seems to say something about my 11.4.
    Quite what I don't know as yet.

    Apache 2.2.17 compiled on 11.3 machine
    -rwxr-xr-x 1 root root 1980889 Apr 1 08:12 /usr/local/apache2/bin/httpd
    and on 11.4 machine
    -rwxr-xr-x 1 root root 1979645 Apr 1 07:45 /usr/local/apache2/bin/httpd.back

    The precompiled apache from rpm does work. But I have many reasons not to use that version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •