Results 1 to 10 of 10

Thread: Realtek RTL8188S

  1. #1

    Default Realtek RTL8188S

    Hi, i have a post earlier but it got pretty long so i don't think people are looking at it anymore.

    I have relatek RTL8188S chipset and kernel uses rtl8712u driver

    here is link to that forum: WIFI HELP! AWLL6075

    anyways, my wifi card is reckognized using ifup but not on network management nor plasmoid network management

    and i haven't been able to connect to the internet, but under ifup i can scan and everything so i am probably just not able to set the right settings manually...

    Any help on how to get the wifi card working under network management (plasmoid is what i have installed) would be great thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Realtek RTL8188S

    On 03/20/2011 06:36 PM, sportsallstars wrote:
    >
    > Hi, i have a post earlier but it got pretty long so i don't think people
    > are looking at it anymore.
    >
    > I have relatek RTL8188S chipset and kernel uses rtl8712u driver
    >
    > here is link to that forum: 'WIFI HELP! AWLL6075'
    > (http://tinyurl.com/4r4uj9f)
    >
    > anyways, my wifi card is reckognized using ifup but not on network
    > management nor plasmoid network management
    >
    > and i haven't been able to connect to the internet, but under ifup i
    > can scan and everything so i am probably just not able to set the right
    > settings manually...
    >
    > Any help on how to get the wifi card working under network management
    > (plasmoid is what i have installed) would be great thanks!


    If your card can scan with 'sudo /usr/sbin/iwlist scan', then check that the
    plasmoid has wireless enabled, or that you can enable it. If that is not true,
    then install NetworkManager-KDE and dump the plasmoid. It doesn't work for me!

    Once you have the wireless enabled, enter the Manage Connections screen and
    create a connection. When it asks YOU MUST ENABLE the wallet, otherwise it will
    not work. I only use the wallet for networking and I create it with no password.
    In addition, DO NOT use a passphrase for WEP encryption - only the hex key will
    work. Once you have created a connection with the correct secret, then you
    should only have to press Connect.

  3. #3

    Default Re: Realtek RTL8188S

    neither of them work. I have tried. Neither of them reckognize the the wifi card, nor do they allow me to enable wireless.

  4. #4

    Default Re: Realtek RTL8188S

    actually i was able to get network management to reckognize the wifi card! however it shows that it's unavailable and doesn't let me enable it.

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Realtek RTL8188S

    On 03/20/2011 09:36 PM, sportsallstars wrote:
    >
    > actually i was able to get network management to reckognize the wifi
    > card! however it shows that it's unavailable and doesn't let me enable
    > it.


    Using the KDE applet (not plasmoid), What do you see when you click on the
    applet's icon? Are the "enable networking" and "enable wireless" boxes checked?

    In addition, please install the rfkill package with 'sudo zypper in rfkill' and
    post the output of '/usr/sbin/rfkill list'.

  6. #6

    Default Re: Realtek RTL8188S

    shub@Shub:~> /usr/sbin/rfkill list
    0: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    shub@Shub:~>


    and in the kde network manager it has networking enabled, but wireless is disabled and no option to enable it...it's kind of greyed out

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Realtek RTL8188S

    On 03/21/2011 03:06 PM, sportsallstars wrote:
    >
    > shub@Shub:~> /usr/sbin/rfkill list
    > 0: hp-wifi: Wireless LAN
    > Soft blocked: yes
    > Hard blocked: yes
    > shub@Shub:~>
    >
    >
    > and in the kde network manager it has networking enabled, but wireless
    > is disabled and no option to enable it...it's kind of greyed out


    The hard block says that your rfkill switch is in the "off" position. What you
    do from here depends on your brand. If you have a physical switch, turn it on.
    If it uses a Fn key, then you will need the wmi module for your system.

  8. #8

    Default Re: Realtek RTL8188S

    I have an internal atheros wifi chip that does not turn on anymore

    my realtek wifi is a miniusb wifi card and that's what i need working, it does not have any buttons it automatically turns on when cpu reckognizes and loads it.

  9. #9
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Realtek RTL8188S

    On 03/21/2011 07:36 PM, sportsallstars wrote:
    >
    > I have an internal atheros wifi chip that does not turn on anymore
    >
    > my realtek wifi is a miniusb wifi card and that's what i need working,
    > it does not have any buttons it automatically turns on when cpu
    > reckognizes and loads it.


    You need to blacklist, or at least modprobe -r, the driver for that Atheros
    card. If it is built in, it probably is causing the rfkill trouble.

  10. #10

    Default Re: Realtek RTL8188S

    i blacklisted ath5k

    and still have the same situation?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •