Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: External USB HDD not recognized at boot time

  1. #1

    Default External USB HDD not recognized at boot time

    Hello,

    I am actually working again on a problem i had already on opensus 11.3 (never resolved), and now also after the upgrade to 11.4 .

    I do have an external HDD (Samsung STORY Station) usually connected to the linux server. I also have udev rules setup to automount the device on /media/xxx by label.

    I used to have my own rules, now have some more coplete from the internet.

    When I now reboot the server, the "sd*" device for story station is not created, and obviously not mounted.

    If however I do switch of th estory station after reboot, and turn power on again, the device is configured and properly automounted as by udev rules.

    Also during the boot the device is seen as from boot.msg:

    Code:
    <6>[    1.444939] usb 2-2: New USB device found, idVendor=04e8, idProduct=5f06
    <6>[    1.448686] usb 2-2: New USB device strings: Mfr=1, Product=11, SerialNum\
    ber=3
    <6>[    1.452462] usb 2-2: Product: Samsung STORY Station
    <6>[    1.456217] usb 2-2: Manufacturer: JMicron
    Any help woul dbe appreciated.

    P.S.: I used th esearch function and google, but did find many similar articles but nothing matching my scenario. So I hope I did not miss something obvious.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: External USB HDD not recognized at boot time

    If this USB drive is not USB3, then it should be mountable on-the-fly or by use of your fstab file. I can speak more about USB3 drives if this is the case. Otherwise, I normally do not suggest using the /media folder as it is there for auto mounting tasks. Why not plug in the drive and umount it if need be then start YaST / System / Partitioner, elect to edit the partition and enter a new folder name for it to be automounted like /Software, /Data, or /Multimedia for instance. This will create the appropriate fstab entry and create the folder name. If the partition type is NTFS, I normally edit the fstab partition entry and change the parameters to just say default, due to the lack of support for all of the Linux security flags, so most users can write to it. This is at least what I might suggest to you. You might tell us more about the hard drive within this external drive enclosure and the partition types that it contains to be more helpful to you.

    Thank you,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: External USB HDD not recognized at boot time

    Thank you for your reply, and sorry for forgetting to mention that it is a USB 2.0 device using ext3 but the latter does not matter.

    Sorry, to say that, but you are missing the topic. I have no primary problem with the mount of the USB drives but to have the kernel device generate at first. All what you are saying won't work without the device neither. There are reasons why I don't use fstab, but that is another story, and as said of topic.

    This does not only matter for the STORY Station btw , but also trying with a USB-Stick. If they get connected during the runtime (on-the-fly as you say), all works fine, the sd* devices are created and the udev rules for automounting using th elabel name do work correctly.

    The only problem is that if the USB storage device is connected before the boot it won't apear in /dev after the boot until it is disconnected and reconnected again.

    My first guess was that the device is recognized before udev deamon is running, but this should be setteled by the udevadm trigger commands during the udev startup script. Reissuing he trigger commands manually from the prompt does not help either.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: External USB HDD not recognized at boot time

    So there may be an issue with devices you do not mount in your fstab file and leave plugged into your PC when you reboot. My point is that it works fine when added to your fstab file and if it is your intent on hot plugging the device in on-the-fly, you should not keep it plugged in all of the time, particularly not on a reboot. Pick one or the other, fstab or don't leave in plugged in and it works just fine. You can always report this as a bug, but I do wonder if it might be different between KDE, GNOME, XFCE or not loading any desktop at all? So far, it has not been an issue to using openSUSE for me and the topic is not new with openSUSE 11.4.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: External USB HDD not recognized at boot time

    Quote Originally Posted by jdmcdaniel3 View Post
    So there may be an issue with devices you do not mount in your fstab file and leave plugged into your PC when you reboot.
    And I happily repeat, there is primarly no problem with mounting at all

    My point is that it works fine when added to your fstab file
    And my point is that thsi is not the case. For fstab to work a block device need to be created in the first place, and THAT is the issue. I get no block device created when I reboot, but only when I replug.

    and if it is your intent on hot plugging the device in on-the-fly, you should not keep it plugged in all of the time, particularly not on a reboot.
    Sorry to say this, but this is non-sense. If it would work with fstab after a reboot my problem would be gone (even without fstab) and thus this would not matter at all

    Pick one or the other, fstab or don't leave in plugged in and it works just fine.
    But what magic line can be put into fstab to mount an non-existent block device ?

    You can always report this as a bug, but I do wonder if it might be different between KDE, GNOME, XFCE or not loading any desktop at all?
    No desktop is involved.

    So as summary:

    1. My Problem: No block special device is created during but, but only after replug of the USB storage
    2. Your solution: Please tell me which entry to write into fstab to mount an non-existent block device and how fstab


    So now, I believe it should be clear one of us is wrong, appologies if it's me

    Gaston

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: External USB HDD not recognized at boot time

    No desktop is involved.

    So as summary:

    1. My Problem: No block special device is created during but, but only after replug of the USB storage
    2. Your solution: Please tell me which entry to write into fstab to mount an non-existent block device and how fstab


    So now, I believe it should be clear one of us is wrong, apologies if it's me

    Gaston
    Let me get back with you tonight when I have more time. But I do have USB 2/3 drives mounted in my fstab using openSUSE 11.4. Yesterday, I took my Dell E6400 Laptop, loaded openSUSE 11.4 and ALL files on to an External USB 2 hard drive, which added it to my fstab file and it boots up just fine. So any issue with lack of Block devices is either hard ware related problem or a setting in your kernel when it was compiled for a certain hard ware device. The specific USB hardware that does not work, with model number would be great for looking up issues.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: External USB HDD not recognized at boot time

    On 03/21/2011 12:36 PM, jdmcdaniel3 wrote:
    >
    > So any issue with lack of Block devices is either hard
    > ware related problem or a setting in your kernel when it was compiled
    > for a certain hard ware device.


    OR maybe it is a software problem: (from OP's #1 post) "udev rules
    setup to automount the device on /media/xxx by label. I used to have
    my own rules, now have some more coplete from the internet."

    those udev rules were required for some previous version of openSUSE
    (*before* it progressed to the level it is today...which is as you
    described it)....and, i _think_ if those udev rules are removed, and
    those built in to openSUSE 11.4 are allow to operate, it will be as
    you said, either:

    1. plug in the usb after boot (and it will auto-mount--but where might
    vary depending on what else is plugged in)

    -or-

    2. leave it plugged in and adjust fstab to allow mounting with boot

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8

    Default Re: External USB HDD not recognized at boot time

    Quote Originally Posted by DenverD View Post
    On 03/21/2011 12:36 PM, jdmcdaniel3 wrote:[color=blue]
    those udev rules were required for some previous version of openSUSE
    (*before* it progressed to the level it is today...which is as you
    described it)....and, i _think_ if those udev rules are removed, and
    those built in to openSUSE 11.4 are allow to operate, it will be as
    you said, either:

    1. plug in the usb after boot (and it will auto-mount--but where might
    vary depending on what else is plugged in)

    -or-

    2. leave it plugged in and adjust fstab to allow mounting with boot
    Thank you for dropping in.

    First of all I have to say that having to either have it plugin all th etime, or only to be plugged in after boot is not a viable situation for me. Not only is it way away from state of the art, also is it not what I need as both situations can occur, which basically is the reasoin th edrive is an external one.

    Also having for example an USB-Stick connected to a server, requiring it to be replugged each time on ereboot sis not a viable situation.

    Well that about th "ethics". I will now remove my rules files and reboot, but I bet it wont change as my own rules used to be at "99", so I guess any native rule should have dropped in before.

    Also if th erules are th eproblem, it won't work at replug.

    But let's give it a try...

  9. #9

    Default Re: External USB HDD not recognized at boot time

    Well as expected: After the reboot the devices have not been created

    And that is exactely where we should concentrate on. Any "mounting" discussion is of no help as this is not the point, the only problem is that the /dev/sd* (/dev/sdc & /dev/sdd in my case) devices are not created at boot time.

    After I unplugged and replugged the storage devices both devices have been created, but of course not mounted as I removed my rules to do so. My mounting rules are very decent and would mount the device like a marvel undependently on which order they are connected but they depend like fstab on the sd* devices to be created first.

    Also it seems no problem of a particular hardware as I can simulate the problem with an USB stick as well. Other USB devices (non storage) are properly detected at boot.

    While I don't need any USB storage during boot I ask myself if th eproblem is maybe because usb_storage is not included in my initrd. Will chack that path...

  10. #10

    Default Re: External USB HDD not recognized at boot time

    Bingo!

    As the usb-storage module is not included in th einitrd and this in ist init script it is not automatically loaded at boot, and the load only triggered by the USB driver when a storage device is plugged in as the recognition at USB level at boot time is done before the module is available.

    Loading the module manually after boot via insmod does th etrick, so I have added "/sbin/modprobe usb-storage" to boot.local and put my udev rules into place again.

    As result everything works perfectly and both the hardrive (story station) and the USB stick are properly mounted into /media.

    As I said, the whole mounting discussion was not worth it

    Anyway, in some way, nobody having an obvious solution pointed me into the correct direction.

    So thanks for that,
    Gaston

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •