Results 1 to 5 of 5

Thread: openSUSE 11.4: Wrong display size under VMware Server

  1. #1

    Default openSUSE 11.4: Wrong display size under VMware Server

    Is there some better way of getting my display size set to 1280x960 when I launch openSUSE 11.4 under VMware Server? Here's what I've done so far:

    I am running Windows 7 on an AMD Phenom II system (motherboard: Gigabyte 880GMA-UD2H). I installed VMware Server (version 2.0.2) so that I can run openSUSE 11.4.

    The initial install went pretty smoothly. However, the display size was set to 800x500. I attempted to set it to 1280x960 by changing the /etc/X11/xorg.conf.d/50-monitor.conf file as follows:
    Code:
    - ----------------------
      /etc/X11/xorg.conf.d/50-monitor.conf
    - ----------------------
    Section "Monitor"
      Identifier "Default Monitor"
    
      ## If your monitor doesn't support DDC you may override the
      ## defaults here
      #HorizSync 28-85
      #VertRefresh 50-100
    
    HorizSync 1-10000
    VertRefresh 1-10000
    
      ## Add your mode lines here, use e.g the cvt tool
    
    Option "PreferredMode" "1280x960_60.00"
    
    # 1280x960 59.94 Hz (CVT 1.23M3) hsync: 59.70 kHz; pclk: 101.25 MHz
    Modeline "1280x960_60.00"  101.25  1280 1360 1488 1696  960 963 967 996 -hsync +vsync
    This resulted in a display size of 1734x1342 (or something close to that). I noted from the /var/log/Xorg.0.log file that the vmwlegacy driver is being used instead of the vmware svga driver. There is a note that the vmwlegacy driver does not support the "PreferredMode" setting in the monitor section of the xorg.conf files. For the time being, I have set my horizontal and vertical rates to 60kHz and 60Hz, respectively. This does limit the maximum display size to 1280x960, but for all the wrong reasons.

    How do I set up my system to get the correct display size?

    Thanks for any help you can offer,
    Randall Krebs

  2. #2

    Default Re: openSUSE 11.4: Wrong display size under VMware Server

    Correction: Should be "was set to 800x600." (800x500 wouldn't make any sense, now would it?)

    Quote Originally Posted by randomfactor View Post
    Is there some better way of getting my display size [...]

    The initial install went pretty smoothly. However, the display size was set to 800x500. I attempted to set it to 1280x960 by changing the /etc/X11/xorg.conf.d/50-monitor.conf file as follows:

    [...]

    Randall Krebs

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: openSUSE 11.4: Wrong display size under VMware Server

    This resulted in a display size of 1734x1342 (or something close to that). I noted from the /var/log/Xorg.0.log file that the vmwlegacy driver is being used instead of the vmware svga driver. There is a note that the vmwlegacy driver does not support the "PreferredMode" setting in the monitor section of the xorg.conf files. For the time being, I have set my horizontal and vertical rates to 60kHz and 60Hz, respectively. This does limit the maximum display size to 1280x960, but for all the wrong reasons.
    I'm not familiar with graphical environments and vmware, but if it's xrandr compliant then you should be able to get a list of available resolutions with the 'xrandr' command. If the preferred display mode is present, then you can set it with xran using an appropriate line in /etc/X11/xinit/xinitrc

    Code:
    #
    # Uncomment next lines to activate asking for ssh passphrase
    #
    # if test -S "$SSH_AUTH_SOCK" -a -x "$SSH_ASKPASS"; then
    #       ssh-add < /dev/null
    # fi
    
    #
    # Add your own lines here...
    #
    xrandr -s 1280x960
    Last edited by deano_ferrari; 20-Mar-2011 at 22:02.

  4. #4

    Default Re: openSUSE 11.4: Wrong display size under VMware Server

    Thanks for your help.

    It works, but it is a little klunky. The display changes size after I log in.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: openSUSE 11.4: Wrong display size under VMware Server

    It works, but it is a little klunky. The display changes size after I log in.
    I agree. If you don't mind messing with xorg configuration files, you could edit 50-screen.conf like this (with root privileges)

    Code:
    Section "Screen"
      Identifier "Default Screen"
    
      Device "Default Device"
    
      ## Doesn't help for radeon/radeonhd drivers; use magic in
      ## 50-device.conf instead
      Monitor "Default Monitor"
      # Add these lines
      SubSection "Display"
         Depth 24
         Modes "1280x960"
      EndSubSection
    EndSection
    I found that I can make the X-server start in a lower display mode, but that I also had to do the following as well to keep the display resolution after login (when KDE starts).

    System Settings > Display and Monitor, select the 'Size' and click 'Apply'

    When I restarted the X-server with CTRL-ALT-Backspace (twice), the 'preferred display resolution' was then honoured, without the change (you mentioned) after login. (The xrandr approach doesn't kick in until after the X-server has started). It just depends on how pedantic one wants to be

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •