Results 1 to 7 of 7

Thread: Gnome cursor theme - no permanent change

  1. #1
    Join Date
    Jan 2011
    Location
    Serbia
    Posts
    6

    Arrow Gnome cursor theme - no permanent change

    openSUSE 11.4
    gnome
    2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686 athlon i386 GNU/Linux


    Ok, I try to change the cursor theme, but with no success in that.

    When I select cursor theme, it is just a partial change, in some windows it is new theme(firefox), in some is default theme.

    I also found a few threads here on the forum(from the last 2-3 versions of openSUSE) with the same problem and none resolved.

    Is it posible to permanent change the cursor theme?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Gnome cursor theme - no permanent change

    So I went in and changed from DMZ to Whiteglass using the Path:

    Control Center / Look and Feel / Appearance / Customize / Pointer / Whiteglass

    What I notice in openSUSE 11.4 was that in native Gnome programs, the mouse pointer selection would stick, but when in non-native Gnome applications, such as Kaffeine, I did notice a change in the pointer shape in portions of the program. I am not sure who's issue this might be, but one must consider if the application is native Gnome or not. If you have installed KDE, you might even run KDE Personnel Settings and select the same mouse pointer/size as in Gnome to help make this work as you want. I was able to log in and out of Gnome and I did not lose my Whiteglass mouse pointer setting.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jan 2011
    Location
    Serbia
    Posts
    6

    Default Re: Gnome cursor theme - no permanent change

    When I change the cursor theme, the change is visible only in Firefox ...

  4. #4

    Default Re: Gnome cursor theme - no permanent change

    Go To Yast -> etc sysconfig editor
    search for mouse
    in the result of the search, you should find something like mouse-theme. Change the value to the one you want, eg DMZ. The name has to be the same as the name of the themes folder (I believe this can be found in /usr/share/icons)

    If you change gdm or kdm you have to do something similar, but don't understand why this is needed.

  5. #5
    Join Date
    Jan 2011
    Location
    Serbia
    Posts
    6

    Default Re: Gnome cursor theme - no permanent change

    Quote Originally Posted by suskewiet View Post
    Go To Yast -> etc sysconfig editor
    search for mouse
    in the result of the search, you should find something like mouse-theme. Change the value to the one you want, eg DMZ. The name has to be the same as the name of the themes folder (I believe this can be found in /usr/share/icons)

    If you change gdm or kdm you have to do something similar, but don't understand why this is needed.
    Great thanks to you!

    Its like you say, Yast>sysconfig Editor and put the name of the folder theme pointer


    Solved for me...

  6. #6

    Default Re: Gnome cursor theme - no permanent change

    this trick no longer works for gnome 3, atleast not for me

  7. #7

    Default Re: Gnome cursor theme - no permanent change

    Worked great for me in Gnome 3.2, but I have to change it with gnome tweak tool on top of in yast>sys config, so thanks for posting this.

    I first tried using update-alternatives via this example: monkey-poo & linux: HOW-TO: Manually Install Cursor Themes In #!Crunchbang Linux 9.04
    but did not have much luck, and it may have made things worse, at any rate, this post did everything except for needing to change it in tweak tool.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •