Results 1 to 5 of 5

Thread: Verschlsselte Swap-Partition

  1. #1
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default Verschlsselte Swap-Partition

    Moin,

    ich brauche mal einen kleinen Ansto in Sachen Verschlsselung.
    Das Setup von openSUSE 11.4 lsst eine Vollverschlsselung ja nur mit
    LVM zu, LVM mchte ich aber nicht.

    Bei der Installation habe ich dann einfach eine unverschlsselte
    Partition fr /boot und /root angelegt, swap und /home verschlsselt.

    swap und /home werden werden auch automatisch verwendet und eingebunden.

    Allerdings bekomme ich beim Booten bezglich swap eine Fehlermeldung,
    dass das Resume-Device nicht gefunden wurde (/dev/mapper/cr_swap).
    Ruhezustand funktioniert demnach nicht, System fhrt dann wie gewohnt hoch.
    Swap wird wie folgt eingebunden:

    fstab:
    /dev/mapper/cr_swap swap swap defaults 0 0

    crypttab:
    cr_swap /dev/disk/by-id..... /keyfile luks

    menu.lst:
    kernel /vmlinuz... root=/dev/... resume=/dev/mapper/cr_swap

    Fehlt mir etwas in der initrd, dass die Swap nicht schon fr den Resume
    verwendet wird?

    Ich will nachtrglich noch / verschlsseln, das sollte dann mglichst
    ohne Probleme ablaufen (gibt dann einen neuen Thread).
    Die Anleitungen, die ich bisher gefunden habe, waren ziemlich alt und
    bezogen sich teilweise auf eigene Bootskripte.

    --
    openSUSE official member
    LXDE team

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Verschlsselte Swap-Partition

    Ich hab eine hnliche Konfiguration nur auf einem Debian, aber da steht im
    crypttab zustzlich noch die option "swap". Also:
    cr_swap /dev/disk/... /keyfile luks,swap

  3. #3
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default Re: Verschlsselte Swap-Partition

    Am 20.03.2011 12:24, schrieb Fruchtratte:
    > Ich hab eine hnliche Konfiguration nur auf einem Debian, aber da steht im
    > crypttab zustzlich noch die option "swap". Also:
    > cr_swap /dev/disk/... /keyfile luks,swap


    Ok, gendert, mkinitrd neu geschrieben und nun sind auch die ntigen
    Module automatisch in der initrd.
    Dumm nur, wenn fr Swap ein Passwort mit Sonderzeichen verwendet wird.
    Beim Booten wird nmlich nur US Layout untersttzt.
    Wieso greift da nicht mein eingerichtetes Keyfile?

    --
    openSUSE official member
    LXDE team

  4. #4
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Verschlsselte Swap-Partition

    Da bin ich beim ersten mal auch drber gestolpert. Inzwischen hab ich mir
    einfach gemerkt, wo die Sonderzeichen in dem Passwort auf der englischen
    Tastatur sind.

  5. #5
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default Re: Verschlsselte Swap-Partition

    Am 21.03.2011 15:19, schrieb Fruchtratte:
    > Da bin ich beim ersten mal auch drber gestolpert. Inzwischen hab ich mir
    > einfach gemerkt, wo die Sonderzeichen in dem Passwort auf der englischen
    > Tastatur sind.


    Keine Chance, dass ich ein Keyfile aus /root/.keys/ verwenden kann?

    --
    openSUSE official member
    LXDE team

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •