Results 1 to 6 of 6

Thread: How to save Volume settings in 11.4

  1. #1
    Join Date
    Jun 2008
    Posts
    34

    Default How to save Volume settings in 11.4

    Installed 11.4 and found that my sound volume was very low.
    After some Scratching of the head I found the Master Volume in Yast2>Sound and was able to turn up the Volume. However every time I restart, the Volume resets itself and I have to manually do the whole thing again.
    How do I save the Volume setting.

  2. #2
    Join Date
    Mar 2011
    Location
    France
    Posts
    9

    Default Re: How to save Volume settings in 11.4

    Hi

    Do you really setup sound in Yast ? I am on gnome and i setup it in the "control center" panel / "sound" icon. In there you can setup input & output & alert volume. Be carefull > don't valide the "mute" checkbox. You should have also a volume control icon on your toolbar just on the left of the 4 desktop icons. Normally the setup should hold.

    see u

  3. #3
    Join Date
    Jun 2008
    Posts
    34

    Default Re: How to save Volume settings in 11.4

    I am using KDE.
    Kmix appears to be working OK but you can't set the Master Channel or the Volume level from it anymore.
    So I open Yast2 and go to the sound card configuration.
    At the Bottom Right hand corner there is a button with "other" on it from which you can selectl Volume.
    From there there are a number of slide controls where you can set the master Volume.
    Problem is everytime I restart, the Master Volume returns to 0 and I have to do this over again.

    Hope this makes it clearer

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: How to save Volume settings in 11.4

    Quote Originally Posted by jmdl View Post
    I am using KDE.
    Kmix appears to be working OK but you can't set the Master Channel or the Volume level from it anymore.
    So I open Yast2 and go to the sound card configuration.
    At the Bottom Right hand corner there is a button with "other" on it from which you can selectl Volume.
    From there there are a number of slide controls where you can set the master Volume.
    Problem is everytime I restart, the Master Volume returns to 0 and I have to do this over again.

    Hope this makes it clearer
    This could be application specific ? or is this the case for all applications?

    I found installing 'pavucontrol' and then running it to set the volume worked well for me.

  5. #5
    Join Date
    Jun 2008
    Posts
    34

    Default Re: How to save Volume settings in 11.4

    I have installed and run pavucontrol which does the same as Kmix it adjusts the volume of my left and right speakers.
    However it does not adjust the Volume of the Master Channel which is what resets each time I start the PC.

    I am guessing there is a configuration file somewhere that i can adjust settings ??

    Can anyone help

  6. #6
    Join Date
    Jun 2008
    Posts
    34

    Default Re: How to save Volume settings in 11.4

    I have resolved this to my satisfaction - but maybe some some of yours

    Here's how.

    A little clarification first.

    1. The soundcard driver on my PC is detected as snd_HD_intel
    2. The Master Channel is set to PCM
    3. On first install I noticed the sound was very low. I could still set the volume level via Kmix but at full volume it was barely audible - This was for all applications
    4.In Yast>Sound>Other>Volume I found two volume sliders for the Master Volume.
    They are ,PCM, which was set to 97% and Master front set to 0%.
    5. If I manually set the Master volume from this slider to 100% the volume was as I wanted it, again, I could now adjust the volume via Kmix and set it to a level I was happy with. However, as I have noted, when I restarted my PC the volume returned to ****, i.e barely audible at full volume - the Master front slider in Yast reset to 0%.
    6 To overcome this I opened Yast>Sound>Other>PulseAudio Configuration and disabled PulseAudio support and re-booted my machine
    7. This gave me all the sliders and Master channel selection back in Kmix.
    9. In Configure Desktop>Multimedia>Phonon i set the "default" Output preference device as the 1st preferred device for all Audio Output and re-booted my pc
    10. This worked OK
    11. Once I had the volume levels for all sliders and Master Channels set to where I wanted them in Kmix I re-enable PulseAudio Support in Yast and rebooted
    12. After re-boot the sound levels had changed slightly but not greatly and still within my tolerance levels for how I wanted my system set so I have settled on this as my solution.

    I would of course prefer that sound just worked out of the box. Perhaps in 11.5 ??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •