Results 1 to 2 of 2

Thread: Enable Second Adapter

  1. #1

    Default Enable Second Adapter

    I've got 2 nic's. For a while both were working (I could plug my cable into either, and it would work). Then I must have changed a setting somewhere because it stopped working. I've been messing w/ everything so don't remember exactly what I did. I think I remember seeing a setting somewhere about disabling unused network devices, but it wasn't anything that should be active. I think it was the firewall config in yast, but I have the firewall disabled.

    I deleted both adapters in yast. Then I left eth0 (the working one) unconfigured, and configured eth1 for my network. It doesn't work. I can run ifconfig, and see the ip configuration for it, and it says it is up. It doesn't auto start on boot, regardless of the startup option in yast. I can start it manually, but it still doesn't work.

    If I plug in eth0 and give it an ip, it works fine (as it always has). If I boot to my system on a stick, both work, so it's not hardware.

    Any ideas?

    Thanks

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Enable Second Adapter

    I've got 2 nic's. For a while both were working (I could plug my cable into either, and it would work). Then I must have changed a setting somewhere because it stopped working. I've been messing w/ everything so don't remember exactly what I did. I think I remember seeing a setting somewhere about disabling unused network devices, but it wasn't anything that should be active. I think it was the firewall config in yast, but I have the firewall disabled.

    I deleted both adapters in yast. Then I left eth0 (the working one) unconfigured, and configured eth1 for my network. It doesn't work. I can run ifconfig, and see the ip configuration for it, and it says it is up. It doesn't auto start on boot, regardless of the startup option in yast. I can start it manually, but it still doesn't work.

    If I plug in eth0 and give it an ip, it works fine (as it always has). If I boot to my system on a stick, both work, so it's not hardware.

    Any ideas?

    Thanks
    If you have more than one connection and you want automatic selection of the active connection, you need to load the NetworkManager. Without NetworkManager, you are using the Traditional Method with ifup. Go to:

    YaST / Network Devices / Network Settings, You will get a warning Message if NetworkManager is already enabled. To enable the NetworkManage, when not enabled, Go to the Global Options Tab and select User Controlled with NetworkManager. When Traditional Method with ifup is selected, you often must go back here and fiddle with your network settings to switch connections while the NetworkManager is smarter and can switch to the active connection. When you throw in a Wireless connection, you most often must also run KWallet, to keep your wireless network password. Check your setup and see if NetworkManager is loaded.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •