Results 1 to 8 of 8

Thread: 11.4 KPackageKit Re-Downloading

Hybrid View

  1. #1

    Default 11.4 KPackageKit Re-Downloading

    I have downloaded several .rpm on a different machine (racket, bluej, kde-wallpaper, java-jdk) and when I click on them in Dolphin to install, KPackageKit comes up and then attempts to redownload the packages. In 11.3, Yast just installed the packages. Is there a switch that I haven't found to tell KPackageKit to not fetch from the internet but just install the package?

    PS - The packages aren't dependencies, it is trying to download the exact same package.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.4 KPackageKit Re-Downloading

    On 03/18/2011 09:06 PM, bsilvereagle wrote:
    >
    > when I click on them in Dolphin to install,
    > KPackageKit comes up and then attempts to redownload


    seems Kpackagekit is a REAL pain in the back...please log this bug,
    here: http://en.opensuse.org/Submitting_Bug_Reports

    i do not know if it is possible in 11.4, but after you have
    downloaded, instead of left clicking on the package, right click and
    see if there is an "Action" you can select and then (maybe) pick
    "Install with YaST"...if you can do that then try it (we both know
    YaST is 'smart' enough to not download what it can 'see' is already on
    your machine!)

    another thing you might TRY is find the place where you can tell
    Dolphin which files should be serviced by which program, and change
    ..rpm from kpackagekit to yast!!

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: 11.4 KPackageKit Re-Downloading

    "Install with Yast" Is not an Action option and I changed "rpm" to a to open in "Install/Remove" before KPackageKit (File Associations), but KPackageKit opened right up. Aggravating as can be.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.4 KPackageKit Re-Downloading

    On 03/18/2011 10:36 PM, bsilvereagle wrote:
    >
    > Aggravating as can be.


    do not miss the chance to begin or add to a bug,
    http://en.opensuse.org/Submitting_Bug_Reports

    and if there is not a work around already in the bug report, they may
    be one there soon...so, when you know the bug number come back and
    post the link...because that will help all the others that google in
    onto your link..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5

    Default Re: 11.4 KPackageKit Re-Downloading

    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.4 KPackageKit Re-Downloading

    On 03/19/2011 01:06 PM, bsilvereagle wrote:
    >
    > https://bugzilla.novell.com/show_bug.cgi?id=681003


    THANK you!!

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  7. #7

    Default Re: 11.4 KPackageKit Re-Downloading

    DenverD, I ran across someone else with this problem in the forums, have you encountered it/does it happen to you also?
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.4 KPackageKit Re-Downloading

    On 03/25/2011 01:36 AM, bsilvereagle wrote:
    >
    > DenverD, I ran across someone else with this problem in the forums, have
    > you encountered it/does it happen to you also?


    it is a 11.4 thing....i'm not using 11.4
    contact that other person and get them to add to your bug report
    (mentioning their hardware)...the more who report the better and
    sooner the devs have all the info they need to squash..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •