Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Can't Turn Off Halt Noise (GNOME 11.4 x64)

  1. #1
    Join Date
    Apr 2010
    Location
    Chicago, IL
    Posts
    171

    Default Can't Turn Off Halt Noise (GNOME 11.4 x64)

    I recently got a new desktop, and I've been running into a problem that I used to have on my laptop (which had 11.3). When I first tried out openSUSE, shutting down / restarting my laptop would produce a very loud, obnoxious sound that I narrowed down to being the system halt noise. I disabled it by going into alsamixer and muting "PC Beep."

    When I built my new desktop, I put 11.3 on it, and have since upgraded to 11.4. The halt sound didn't play when I first installed 11.3, so I'm not sure if upgrading is what caused this, but now the halt sound plays when I shut down or restart (although thankfully, it's not nearly as obnoxious as the one on my laptop).

    alsamixer doesn't display an option for PC Beep, although I did find an option in YaST's sysconfig that lets you specify halt noise; unfortunately, it seems to be ignoring this option because it's set to "no".

    I've also been having some problems with my sound driver, but I don't think the two are related because the halt noise uses a small speaker inside the computer itself, although I could be wrong.

  2. #2
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    Interesting!

    I had the same issue with 11.4 on a brand new HP Dv6. Only when I shut down would I get this loud annoying sound and buzz. I was not sure what that was.

    I will be watching this post for any aid we can get. I since removed 11.4 and plan on installing it again this weekend. I will post back if happens again on the next try.
    Laptop: openSUSE 13.1 | Gnome 3.2.1 | i3 350m 2.27 GHz | HP Pavilion dv6 | 4GB RAM | Intel HD Integrated Graphics

    Installed openSUSE, never going back!

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    On 2011-03-18 17:06, kog13 wrote:

    > alsamixer doesn't display an option for PC Beep, although I did find an
    > option in YaST's sysconfig that lets you specify halt noise;
    > unfortunately, it seems to be ignoring this option because it's set to
    > "no".


    You might be confusing the system halt "beep" with the gnome/kde exit
    sound. The halt beep is about a second before it power off completely, and
    it is controlled in sysconfig.

    You can check by changing to runlevel 3, then halting.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4
    Join Date
    Apr 2010
    Location
    Chicago, IL
    Posts
    171

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    I'm pretty sure it's the halt beep, since it comes out of the computer and not my speakers, but I'm at work right now and can't check it until I get back home.

  5. #5
    Join Date
    Apr 2010
    Location
    Chicago, IL
    Posts
    171

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    I've confirmed that it's not a logoff sound. I boot into runlevel 3 and then used /sbin/shutdown -r now to reboot; the noise beeps right after sending the command.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    On 2011-03-19 22:36, kog13 wrote:
    >
    > I've confirmed that it's not a logoff sound. I boot into runlevel 3 and
    > then used /sbin/shutdown -r now to reboot; the noise beeps right after
    > sending the command.


    And in "/etc/sysconfig/shutdown" you have:

    HALT_SOUND="no"

    exactly that way, and it still plays a beep?

    Funny, I want mine to play a beep and it doesn't play anything. It may be a
    bug...


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Apr 2010
    Location
    Chicago, IL
    Posts
    171

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    Yep, HALT_SOUND is set to no, and it continues to beep.

    If I can't find a solution soon I'll probably post a bug report on their site.

  8. #8

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    I have the same problem. The sound also occurs when new mail is received in Evolution.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    On 2011-03-28 21:36, maciej kucharski wrote:
    >
    > The sound also occurs when new mail is received
    > in Evolution.


    Not related.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: Can't Turn Off Halt Noise (GNOME 11.4 x64)

    Quote Originally Posted by robin_listas View Post
    On 2011-03-28 21:36, maciej kucharski wrote:
    >
    > The sound also occurs when new mail is received
    > in Evolution.


    Not related.
    Well it is related because I had the notification plugin set to [Beep]... After changing to [Use sound theme] there is no annoying buzz. So maybe the problem is that there is no sound in the theme for system shutdown and the system bell is used?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •