Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issue on friend's laptop.

  1. #1

    Question Long time Fedora user, new to OpenSUSE. Wireless (atheros) issue on friend's laptop.

    Hi, long story short, a friend nuked his hard disk and didnt have a copy of windows, and since I have been hailing linux for years now as the second coming of Jesus, he is interested in checking it out, specifically OpenSUSE.

    I installed 11.4 on it, and aside from an nVIDIA quirk (fixed) I have this weird wireless issue.

    Simply put, the computer sees that there is a card, but I cannot get it to assign a device to it, nor can NetworkManager enable it when the icon is right clicked (the entry under Enable Networking). After a while of googling I noticed that under old revisions of OpenSUSE, the ath5k module was quirky and the resolution was to revert to ath_pci. Unfortunately I get this when attempting to load that module:
    Code:
    nate-compaq:/home/nathan/Desktop # modprobe -v ath_pci
    FATAL: Module ath_pci not found.
    nate-compaq:/home/nathan/Desktop #
    Perhaps a missing rpm is the fix? I am fond of SUSE as a whole, but being more or less addicted to RHEL/Fedora I am much more competent there with these things without some help here and there. And to those that may need it, here are my dmesg and lspci snippets:
    Code:
    ate-compaq:/home/nathan/Desktop # dmesg | grep ath
    [    7.410795] ath5k 0000:07:00.0: PCI INT A -> Link[Z012] -> GSI 23 (level, low) -> IRQ 23
    [    7.410809] ath5k 0000:07:00.0: setting latency timer to 64
    [    7.410889] ath5k 0000:07:00.0: registered as 'phy0'
    [    7.972761] ath: EEPROM regdomain: 0x64
    [    7.972765] ath: EEPROM indicates we should expect a direct regpair map
    [    7.972770] ath: Country alpha2 being used: 00
    [    7.972772] ath: Regpair used: 0x64
    [    8.140316] Registered led device: ath5k-phy0::rx
    [    8.140349] Registered led device: ath5k-phy0::tx
    [    8.140358] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
    [  623.841192] ath5k 0000:07:00.0: PCI INT A disabled
    nate-compaq:/home/nathan/Desktop #
    Code:
    nate-compaq:/home/nathan/Desktop # lspci | grep net
    00:0a.0 Ethernet controller: nVidia Corporation MCP77 Ethernet (rev a2)
    07:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
    nate-compaq:/home/nathan/Desktop #
    Thanks a ton!
    Andrew.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    On 03/18/2011 02:06 PM, schotty wrote:
    > Perhaps a missing rpm is the fix? I am fond of SUSE as a whole, but
    > being more or less addicted to RHEL/Fedora I am much more competent
    > there with these things without some help here and there. And to those
    > that may need it, here are my dmesg and lspci snippets:


    your snippets prove you are on the right track...Atheros AR2425 is a
    key piece of the deal...

    thanks for being willing to help a friend with FOSS....especially to
    even step out of RH/Fedora to do it!

    so please take this in way i intend (quickest way for you to get from
    here to happiness):

    hop over to the wireless sub forum (URL below), and work through the
    three "stickies" at the top of that forum...i expect you will soon
    find the path (that the openSUSE devs cleverly hid from Fedora buffs)
    to smiles (i can't help you, but there are some over there who
    can--especailly if Larry Finger talks to you, listen closely...he knows!

    http://forums.opensuse.org/english/g...here/wireless/

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    On 03/18/2011 08:06 AM, schotty wrote:
    >
    > Hi, long story short, a friend nuked his hard disk and didnt have a copy
    > of windows, and since I have been hailing linux for years now as the
    > second coming of Jesus, he is interested in checking it out,
    > specifically OpenSUSE.
    >
    > I installed 11.4 on it, and aside from an nVIDIA quirk (fixed) I have
    > this weird wireless issue.
    >
    > Simply put, the computer sees that there is a card, but I cannot get it
    > to assign a device to it, nor can NetworkManager enable it when the icon
    > is right clicked (the entry under Enable Networking). After a while of
    > googling I noticed that under old revisions of OpenSUSE, the ath5k
    > module was quirky and the resolution was to revert to ath_pci.
    > Unfortunately I get this when attempting to load that module:
    >
    > Code:
    > --------------------
    >
    > nate-compaq:/home/nathan/Desktop # modprobe -v ath_pci
    > FATAL: Module ath_pci not found.
    > nate-compaq:/home/nathan/Desktop #


    There is no driver by that name.

    > Perhaps a missing rpm is the fix? I am fond of SUSE as a whole, but
    > being more or less addicted to RHEL/Fedora I am much more competent
    > there with these things without some help here and there. And to those
    > that may need it, here are my dmesg and lspci snippets:


    Perhaps. See below.

    > ate-compaq:/home/nathan/Desktop # dmesg | grep ath
    > [ 7.410795] ath5k 0000:07:00.0: PCI INT A -> Link[Z012] -> GSI 23 (level, low) -> IRQ 23
    > [ 7.410809] ath5k 0000:07:00.0: setting latency timer to 64
    > [ 7.410889] ath5k 0000:07:00.0: registered as 'phy0'
    > [ 7.972761] ath: EEPROM regdomain: 0x64
    > [ 7.972765] ath: EEPROM indicates we should expect a direct regpair map
    > [ 7.972770] ath: Country alpha2 being used: 00
    > [ 7.972772] ath: Regpair used: 0x64
    > [ 8.140316] Registered led device: ath5k-phy0::rx
    > [ 8.140349] Registered led device: ath5k-phy0::tx
    > [ 8.140358] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
    > [ 623.841192] ath5k 0000:07:00.0: PCI INT A disabled
    > nate-compaq:/home/nathan/Desktop #


    The driver seems to have given up at this point, but it doesn't say why.

    > Code:
    > --------------------
    >
    > nate-compaq:/home/nathan/Desktop # lspci | grep net
    > 00:0a.0 Ethernet controller: nVidia Corporation MCP77 Ethernet (rev a2)
    > 07:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
    > nate-compaq:/home/nathan/Desktop #


    Please change that last command to 'lspci -nn | grep net". That way we will get
    the PCI ID for that ath5k device. Once that is available, it will be easy to see
    if that device is supported in the latest kernels. If it is, then you will need
    compat-wireless. At the moment, this package does not yet exist in the wireless
    repo at http://download.opensuse.org/reposit...openSUSE_11.4/.


  4. #4

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    Quote Originally Posted by lwfinger View Post

    Please change that last command to 'lspci -nn | grep net". That way we will get
    the PCI ID for that ath5k device. Once that is available, it will be easy to see
    if that device is supported in the latest kernels. If it is, then you will need
    compat-wireless. At the moment, this package does not yet exist in the wireless
    repo at Index of /repositories/driver:/wireless/openSUSE_11.4.
    OK, here is what you have asked for :
    Code:
    nate-compaq:/home/nathan/Desktop # lspci -nn | grep net
    00:0a.0 Ethernet controller [0200]: nVidia Corporation MCP77 Ethernet [10de:0760] (rev a2)
    07:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
    nate-compaq:/home/nathan/Desktop #
    Thanks for the help here.

  5. #5

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    Quote Originally Posted by DenverD View Post
    so please take this in way i intend (quickest way for you to get from
    here to happiness):

    hop over to the wireless sub forum (URL below), and work through the
    three "stickies" at the top of that forum...i expect you will soon
    find the path (that the openSUSE devs cleverly hid from Fedora buffs)
    to smiles (i can't help you, but there are some over there who
    can--especailly if Larry Finger talks to you, listen closely...he knows!

    Wireless

    Took as intended Thanks for the reply nonetheless, as it was useful.

    For completeness, I should add the steps that I didn't do were the iwlist stuff, since I know that lo and eth0 are not wireless devices. But I will say, I love the faqs. Quite nicely done guides on troubleshooting.

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    On 03/18/2011 09:36 PM, schotty wrote:
    >
    > lwfinger;2307616 Wrote:
    >>
    >>
    >> Please change that last command to 'lspci -nn | grep net". That way we
    >> will get
    >> the PCI ID for that ath5k device. Once that is available, it will be
    >> easy to see
    >> if that device is supported in the latest kernels. If it is, then you
    >> will need
    >> compat-wireless. At the moment, this package does not yet exist in the
    >> wireless
    >> repo at 'Index of /repositories/driver:/wireless/openSUSE_11.4'
    >> (http://tinyurl.com/6634m2y).

    >
    > OK, here is what you have asked for :
    >
    > Code:
    > --------------------
    >
    > nate-compaq:/home/nathan/Desktop # lspci -nn | grep net
    > 00:0a.0 Ethernet controller [0200]: nVidia Corporation MCP77 Ethernet [10de:0760] (rev a2)
    > 07:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
    > nate-compaq:/home/nathan/Desktop #


    That device uses the ath5k driver; however, that ID was not added to the kernel
    until Dec. 2, 2010. I think that is too new for kernel 2.6.37. Thus you need to
    use the compat-wireless code. That backports the latest and greatest in wireless
    drivers to earlier kernel.

    As there is not yet a precompiled package for openSUSE 11.4, you would need to
    build those drivers yourself. If that is something you would consider, report
    that fact back and we will give further instructions.

  7. #7

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    Quote Originally Posted by lwfinger View Post

    As there is not yet a precompiled package for openSUSE 11.4, you would need to
    build those drivers yourself. If that is something you would consider, report
    that fact back and we will give further instructions.
    That info would be great. Now, if possible, can I build the rpm in a way so that when an official one from a repo arrives it can easily be updated without any headaches?

    Thanks,
    Andrew

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issueon friend's laptop.

    On 03/19/2011 09:06 AM, schotty wrote:
    >
    > lwfinger;2307959 Wrote:
    >>
    >>
    >> As there is not yet a precompiled package for openSUSE 11.4, you would
    >> need to
    >> build those drivers yourself. If that is something you would consider,
    >> report
    >> that fact back and we will give further instructions.

    >
    > That info would be great. Now, if possible, can I build the rpm in a
    > way so that when an official one from a repo arrives it can easily be
    > updated without any headaches?


    The RPM won't be needed. The compat-wireless build process is finished with a
    'sudo make install' that places the new drivers in the appropriate part of the
    /lib/modules directory tree where the kernel can access them. When the official
    package is available, it will replace those files as part of the installation
    and it will be seamless to you. Your only cleanup will be to delete the
    compat-wireless source files, but you would need to do that anyway.

    To setup the compat-wireless build, use YaST => Software Management. Under View,
    select Pattern, scroll down to Development, and install Base, C/C++ and Linnux
    Kernel Development. The compat-wireless sources are obtained through
    http://wireless.kernel.org/download/...ss-2.6.tar.bz2.
    In your case, the Atheros drivers are under heavy development, thus the
    bleeding-edge variety is recommended. Unpack the downloaded file with a 'tar
    jxvf <file_name>' command. Read the explanatory material included to configure
    the ath5k driver, and build. More info is available on the linux-wireless wiki
    at http://wireless.kernel.org/en/users.



  9. #9

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issue on friend's laptop.

    Thanks bud.

    I will get back to you on this one. And thanks for the correction, yes the rpm will replace the files I drop in manually, duh

    One last question, shall I peg the kernel as a non-updatable item? I dont want my friend to get a kernel updatte that breaks this module at all.

    Thanks again!
    Andrew.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Long time Fedora user, new to OpenSUSE. Wireless (atheros) issue on friend's laptop.

    One last question, shall I peg the kernel as a non-updatable item? I dont want my friend to get a kernel updatte that breaks this module at all.
    That would be a good idea
    In Yast you can select 'Protected Do not Modify'
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •