Results 1 to 9 of 9

Thread: Black screen when switching to any virtual console

  1. #1

    Default Black screen when switching to any virtual console

    Hi all,

    I've a Sony Vaio VPCS12L9E with Nvidia GeForce310M with OpenSuse 11.4 64bit.

    I'm using lastest Nvidia proprietary drivers (x86_64-260.19.44) and everything seems working correctly, virtual consoles apart.

    When I switch to any of virtual console (ALT-CTRL-Fx) I get black screens.

    The console is present because I can login and executing commands (blind login), and by switching ALT-F7 I can return in graphical mode.

    I've tried to use vga=normal as boot option in grub without any result.

    Any suggestion to solve such annoying behavior?

    Davide

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: Black screen when switching to any virtual console

    Hmm... I'm speculating here, so... YMWY (your mileage WILL vary )

    In console the resolution/frequency/bitmode may be different, I think, and whatever driver is controling it (fbdev?) may be getting it wrong.
    If you boot straight into level 3 do you have this problem?
    If your monitor have an auto setting button, did you try it (or is this Vaio a laptop)?
    If you try a liveCD do you have this problem also?

    I have no idea how to change fbdev settings, I think it's part of X, perhaps Xorg.0.log (where it log the various driver tests) will give you a clue.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: Black screen when switching to any virtual console

    I don't suppose there's any BIOS setting that affect this?

  4. #4

    Default Re: Black screen when switching to any virtual console

    You are experiencing a typical problem with Nvidia drivers. I have scourged and scourged and ran across some "solutions" that have never worked for me.
    I think what brunomcl is talking about was one of those "solutions" - it didn't work for me, but feel free to explore it.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  5. #5

    Default Re: Black screen when switching to any virtual console

    Boot with the kernel parameter nomodeset.
    But be sure to use NVidia drivers (not the ones that come with the opensuse 11.4 installer.

    I had the same problem and that's the way I fixed it, but with ATI drivers. I also had to change the KDM RC file for other reasons.

  6. #6

    Default Re: Black screen when switching to any virtual console

    Quote Originally Posted by LRE View Post
    Boot with the kernel parameter nomodeset.
    But be sure to use NVidia drivers (not the ones that come with the opensuse 11.4 installer.

    I had the same problem and that's the way I fixed it, but with ATI drivers. I also had to change the KDM RC file for other reasons.
    Unfortunately your suggestion doesn't help me.

    But I tried to use Nouveau driver and virtual consoles run perfectly. Therefore I suppose it's a Nvidia issue.

  7. #7

    Default Re: Black screen when switching to any virtual console

    Booting into level 3 don't present this problem.
    It's a Vaio laptop.

    I'll try a liveCD, but in the meantime I've discovered the Nouveau driver is not affected by this problem and virtual consoles run perfectly.
    But it has many others.......

  8. #8

    Default Re: Black screen when switching to any virtual console

    Quote Originally Posted by bsilvereagle View Post
    You are experiencing a typical problem with Nvidia drivers.
    *cough*
    As long as you use anything *but* Nvidia you won't experience the problem.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  9. #9

    Default Re: Black screen when switching to any virtual console

    I figured out how to get the virtual consoles back using a Nvidia driver. You have to install uvesafb and let it replace vesa.
    Some Arch instructions: https://wiki.archlinux.org/index.php/Uvesafb that worked for me.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •