Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: alsa: cannot record sound

  1. #1

    Default alsa: cannot record sound

    Hi,

    I've got some audio issues I'm hoping somebody can help me resolve.

    I've got sound - I hear all the system sounds, I can play sound files, CDs, etc. But I have not been able to record and play back anything with success.

    Originally, when I would record (either with arecord or with audacity) I would get extremely low quality sound, with lots of noise and crackling, and my recorded voice was barely audible (even with volume turned up to max). I played with alsamixer for hours without being able to improve matters.

    Things are worse now. I tried installing alsa-firmware, as indicated at SDB:Audio troubleshooting - openSUSE. I also tried updating alsa following instructions given at SDB:Alsa-update - openSUSE. I'm not sure which of these changes did it, but the result is that I can no longer record ANYTHING at all. I get absolutely nothing, not even the low quality noise and crackling I was getting before. It's as if there is no audio input at all.

    Uninstalling alsa-firmware and reverting back to the older alsa version (1.0.20) didn't change a thing.

    I'm running openSUSE 11.2, kernel 2.6.31.14-0.6-desktop, alsa 1.0.20. My sound card is a Creative X-Fi (by the way, yast cannot detect my card, another problem I have never solved).

    Any suggestions?

  2. #2

    Default Re: alsa: cannot record sound

    Weird. In alsamixer, muting the Digital-IO channel fixed my recording issue. I can now record my voice with adequate volume and only a tiny bit of static.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: alsa: cannot record sound

    Quote Originally Posted by dspathis View Post
    I'm running openSUSE 11.2, kernel 2.6.31.14-0.6-desktop, alsa 1.0.20. My sound card is a Creative X-Fi (by the way, yast cannot detect my card, another problem I have never solved).
    Support for the Creative X-Fi has never been good because for the longest time
    1. Creative provided limited to no technical details on the device to the open source community, and
    2. Creative provided a mostly non-functional Linux driver, and
    3. the Linux community were not able to reverse engineer a driver.

    Eventually, Creative released the code for their non-functional driver, and the Linux community were able to take that and patch together a partial driver (but having to do that still without all the information on the Creative X-Fi) and hence its not the greatest driver from what I have read.

    In openSUSE-11.2, YaST definitely does NOT support that driver. If one gets the X-Fi working and then tries to run YaST > hardware > sound , YaST WILL likely break the sound configuration.

    To get it functioning one needs to be certain they do NOT use YaST, and the /etc/modprobe.d/50-sound.conf (or maybe it is sound.conf) needs to be removed. Do NOT leave any backups in the /etc/modprobe.d directory, as older versions of openSUSE would treat all files in that directory (including backups) as operational files.

    One's best bet may be to update alsa per the guide: SDB:Alsa-update - openSUSE which you claim you have, but I would like to do a quality check of that update as it is my experience that many users simply mess up in their efforts to do that.

    So, what is the output of:
    Code:
    rpm -qa *alsa*
    rpm -q libasound2
    uname -a
    and with the PC connected to the Internet what is the output website/url given by running the diagnostic script:
    Code:
    /usr/sbin/alsa-info.sh
    being certain to select the SHARE/UPLOAD option.

    Also, give me a list of all the files in the /etc/modprobe.d/ directory.

    Again, YasT > hardware > sound does NOT support that driver and it likely WILL break any driver configuration that YaST functionality is run.

  4. #4

    Default Re: alsa: cannot record sound

    i have a similar problem.

    i am running opensuse 64 bit - lxde.

    At first , i could not get sound from youtube or from playing mp3s. i tried installing pulseaudio but no go. I finaly got it working by adding the user to the 'audio' group. Now sound (playback ) is working.

    But not for recording.

    i cant record anything. tried selecting all mic1 , mic2 , line in Pulse Volume Control but no luck. Also checked alsa mixer to check the mic levels there as well. but no luck.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: alsa: cannot record sound

    Quote Originally Posted by MarcoMeswara View Post
    i have a similar problem.

    i am running opensuse 64 bit - lxde.

    At first , i could not get sound from youtube or from playing mp3s. i tried installing pulseaudio but no go. I finaly got it working by adding the user to the 'audio' group. Now sound (playback ) is working.

    But not for recording.

    i cant record anything. tried selecting all mic1 , mic2 , line in Pulse Volume Control but no luck. Also checked alsa mixer to check the mic levels there as well. but no luck.
    You could provide the information that I asked user dspathis to provide.

  6. #6

    Default Re: alsa: cannot record sound

    will do. 19,899 posts ? awesome ....

  7. #7

    Default Re: alsa: cannot record sound

    Oldcpu,

    # rpm -qa *alsa*


    alsa-oss-1.0.17-29.2.x86_64
    alsa-plugins-1.0.23-1.9.x86_64
    alsa-1.0.23-2.12.x86_64
    alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
    alsa-oss-32bit-1.0.17-29.2.x86_64
    alsamixergui-0.9.0rc1-746.1.x86_64
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    alsa-utils-1.0.23-1.8.x86_64
    alsa-plugins-32bit-1.0.23-1.9.x86_64

    rpm -qa *pulse*

    libpulse-mainloop-glib0-0.9.21-10.3.1.x86_64
    libpulse-browse0-0.9.21-10.3.1.x86_64
    pulseaudio-utils-0.9.21-10.3.1.x86_64
    pulseaudio-0.9.21-10.3.1.x86_64
    alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
    mpg123-pulse-1.13.2-1.pm.2.1.x86_64
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    libpulse0-32bit-0.9.21-10.3.1.x86_64
    vlc-aout-pulse-1.1.8-1.pm.2.2.x86_64
    libpulse0-0.9.21-10.3.1.x86_64
    audacious-plugins-output-pulse-2.4.4-1.pm.2.5.x86_64


    # rpm -q libasound2

    libasound2-1.0.23-2.12.x86_64

    # uname -a
    Linux localhost 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

  8. #8

    Default Re: alsa: cannot record sound

    Output of
    /usr/sbin/alsa-info.sh has been uploaded/shared.

    It gave loads of info.Its at http://www.alsa-project.org/db/?f=a2...5ca02c2f943c0c

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: alsa: cannot record sound

    Quote Originally Posted by MarcoMeswara View Post
    Output of
    /usr/sbin/alsa-info.sh has been uploaded/shared.

    It gave loads of info.Its at http://www.alsa-project.org/db/?f=a2...5ca02c2f943c0c
    Thanks. The first thing I note is your hardware has a VIA VT1708S hardware audio codec which is almost certainly different from user dspathis's X-Fi and hence it is likely your problem (with similar symptoms) is a different problem. In the case of your PC, I note 1 64-bit openSUSE-11.3 with the 2.6.34.7-0.7-desktop kernel and the 1.0.22.1 (driver) / 1.0.23 (utilities) alsa versions with the VIA VT1708S hardware audio codec.

    In your mixer I note reference to a 'mic' and a 'front mic' suggesting your PC may have more than one mic correction. You need to tell me WHAT mic are you trying to record from ? An internal mic ? (I don't think the case). An external mic (not USB) plugged in to the back of the PC ? The front/side of the PC ? A USB mic ?

    Further, in the mixer I note:

    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [SB]
    
    Card hw:0 'SB'/'HDA ATI SB at 0xfbdf4000 irq 16'
      Mixer name	: 'VIA VT1708S'
    Simple mixer control 'Front Mic Boost',0
      Front Left: Capture 0 [0%] [0.00dB]
      Front Right: Capture 0 [0%] [0.00dB]
    Simple mixer control 'Mic',0
      Front Left: Playback 20 [65%] [-4.50dB] [on]
      Front Right: Playback 20 [65%] [-4.50dB] [on]
    Simple mixer control 'Mic Boost',0
      Front Left: Capture 3 [100%] [30.75dB]
      Front Right: Capture 3 [100%] [30.75dB]
    Simple mixer control 'Capture',0
      Front Left: Capture 31 [100%] [30.00dB] [on]
      Front Right: Capture 31 [100%] [30.00dB] [on]
    Simple mixer control 'Capture',1
      Front Left: Capture 0 [0%] [-16.50dB] [on]
      Front Right: Capture 0 [0%] [-16.50dB] [on]
    Simple mixer control 'Independent HP',0
      Items: 'OFF' 'ON'
      Item0: 'OFF'
    Simple mixer control 'Input Source',0
      Items: 'Stereo Mixer' 'Mic' 'Front Mic' 'Line'
      Item0: 'Mic'
    Simple mixer control 'Smart 5.1',0
      Mono: Playback [on]
    Your mixer has the 'mic' selected (and not front mic) and I note the 'front mic' boost capture at 0%. Have you selected the correct mic ??

    What are you doing for a record test? What app are you using ?

    I recommend something simple, like:
    Code:
    arecord -f cd test.wav
    and then replay test.wav and see if you get sound.

    I also note you have pulse audio running and a large number of alsa rpms installed, suggesting to me that you have a Gnome desktop ? In openSUSE-11.4 I found installing 'pauvcontrol' was useful for pulse (and then running 'pavucontrol' from a terminal) and it may be the same for Gnome in 11.3 (I don't know here - I'm a KDE/LXDE user). Else the program 'alsamixer' may be useful for tuning your mic.

  10. #10

    Default Re: alsa: cannot record sound

    > You need to tell me WHAT mic are you trying to record from ?

    An external mic. I am running opensuse 64 bits lxde , not gnome

    > The front/side of the PC ?

    At the back of the pc. The cound card has only one mic input. It also has a line in 9 i have tried putting the mic in both )

    > Your mixer has the 'mic' selected (and not front mic) and I note the 'front mic' boost capture at 0%. Have you selected the correct mic ??

    i didnt see that. Surprised to see it actually. i have run 'alsamixer ' many times but did not see that. F4 helped.

    > arecord -f cd test.wav

    i will try this.

    Is there any commandline setting ( with amixer ) that i can use to just set my mic and set the recording volume to max?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •