Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Skype installation error

  1. #1
    Join Date
    Apr 2012
    Posts
    27

    Default Skype installation error

    Hey everyone-
    I'm new here and new to linux in general. I will more formally introduce myself at a later time. I am trying to install skype on my laptop with opensuse, but after i click the next button to install, I get a couple windows popping up. One saying: KDEInit could not launch '/usr/bin/apper'.
    And a crash handler window saying that the apper closed unexpectedly. the details at the bottom says: Executable: apper-sentinel PID: 2224 Signal: Segmentation fault (11)

    Do I need to get any packages prior to the installation as a preparation?

  2. #2
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: Skype installation error

    SDB:Skype - openSUSE
    see if work for you
    Welcome to openSUSE

  3. #3
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    Thanks. I saw that page when i posted. I'll let you know what the result is when I get the chance

  4. #4
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    I installed the packages from the command: su -c 'zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2 libpng12-0'
    They downloaded and installed. After that, it told me some of the programs may need to be restarted because the packages deleted some files. Being a n00b, I just restarted the computer and tried to install from the skype rpm file again. It said the same error. Is there a way I can get the information back in the terminal to post here ?

  5. #5
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    After performing online updates through yast, the download doesnt give me an error anymore. Instead, it prompts me for my root pw after it shows me the packages it needs to install. I enter that, and then the installer just idles there saying 'waiting for service to start'

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,841
    Blog Entries
    14

    Default Re: Skype installation error

    First: get rid of Apper. Uninstall it through Yast - Software - Softwaremanagement

    This link should work: http://software.opensuse.org/ymp/hom...12.1/skype.ymp

    Open the link in Firefox, if it asks you, open it with "Install / Remove Software". It will probably tell you that some extra packages have to be installed, accept all and you should be in business., Mind, this is for openSUSE 12.1, nobody asked you about your version, but it does matter. If you're not on 12.1, replace "12.1" by your version number.

    A piece of advice: please post real output, between CODE tags. That makes it easier to detect the problem and find a solution.

    Also: please post output of
    Code:
    zypper lr -d
    uname -a
    cat /etc/SuSE-release
    Last edited by Knurpht; 11-Apr-2012 at 13:17.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    daniel@linux-78s1:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+------------------------------------+------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes | Yes | 99 | rpm-md | Index of /update/12.1 |
    2 | home:zhaobou:demeter | home:zhaobou:demeter | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.1/ |
    3 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208BB_R8F96GKB872206,/dev/sr0 |
    4 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.1/repo/oss |
    5 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.1 |
    6 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
    7 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/oss |
    8 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.1/repo/oss |
    daniel@linux-78s1:~> uname -a
    Linux linux-78s1.site 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux
    daniel@linux-78s1:~> cat /etc/SuSE-release

  8. #8
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    daniel@linux-78s1:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

    1 | Updates-for-openSUSE-12.1-12.1-1.4 | Updates for openSUSE 12.1 12.1-1.4 | Yes | Yes | 99 | rpm-md | Index of /update/12.1 |
    2 | home:zhaobou:demeter | home:zhaobou:demeter | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/zhaobou:/demeter/openSUSE_12.1 |
    3 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208BB_R8F96GKB872206,/dev/sr0 |
    4 | repo-debug | openSUSE-12.1-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.1/repo/oss |
    5 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.1 |
    6 | repo-non-oss | openSUSE-12.1-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
    7 | repo-oss | openSUSE-12.1-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/oss |
    8 | repo-source | openSUSE-12.1-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.1/repo/oss |
    daniel@linux-78s1:~> uname -a
    Linux linux-78s1.site 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux
    daniel@linux-78s1:~> cat /etc/SuSE-release

  9. #9
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    Sorry for the double post. It downloaded and installed a couple packages and then said that skype could not be installed..? I meant to say that I do have 12.1 -forgive me for not mentioning in my first post

  10. #10
    Join Date
    Apr 2012
    Posts
    27

    Default Re: Skype installation error

    What did work, however, was the previous download that I received from the skype website. It is installed and working fine from what I can tell so far.
    So, what's the deal with 'apper'? Is it just a buggy program? Is there anything else I should uninstall?

    Thanks again for your help. Love the community so far

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •