Results 1 to 3 of 3

Thread: klogd spielt verrückt seit Update auf 11.4

  1. #1

    Default klogd spielt verrückt seit Update auf 11.4

    Hallo,

    seitdem ich neulich mittels "zypper dup" auf 11.4 geupdated habe, loggt mein klogd wie irre und andauernd, frisst 80% CPU und loggt Sachen wie:

    Mar 17 23:41:04 pc01 syslog-ng[16468]: syslog-ng starting up; version='3.2.2'
    Mar 17 23:41:09 pc01 kernel: klogd 1.4.1, log source = /proc/kmsg started.
    Mar 17 23:41:09 pc01 kernel: kernel[8124]: [ 2201.540063] kernel[8124]: 416] kernel[8124]: [ 2200.759
    Mar 17 23:41:09 pc01 kernel: [ 2201.606874] kernel[8124]: [ 2201.581918] kernel[8124]: [ 2201.560830] kernel[8124]: [ 2201.540069] kernel[8124]: [ 2201.519211] kernel[8124]: 092] kernel[8124]: [ 2200.737
    Mar 17 23:41:09 pc01 kernel: [ 2246.016091] sr 8:0:0:0: CDB: Test Unit Ready: 00 00 00 00 00 00
    Mar 17 23:41:09 pc01 kernel: [ 2246.016110] ata9.00: status: { DRDY ERR }
    Mar 17 23:41:09 pc01 kernel: [ 2256.063055] ata9: device not ready (errno=-16), forcing hardreset
    Mar 17 23:41:09 pc01 kernel: [ 2256.238430] ipop3d[8228]: Update user=pschess host=pc02.robustsoft.de [192.168.2.12] nmsgs=0 ndele=0 nseen=0
    Mar 17 23:41:09 pc01 kernel: [ 2256.255567] ata9.00: configured for UDMA/33
    Mar 17 23:41:09 pc01 kernel: [ 2256.265974] imapd[8232]: Login user=pschoenb host=pc02.robustsoft.de [192.168.2.12]
    Mar 17 23:41:09 pc01 kernel: [ 2257.442872] imapd[8232]: Logout user=pschoenb host=pc02.robustsoft.de [192.168.2.12]
    Mar 17 23:41:09 pc01 kernel: [ 2284.138822] imapd[8295]: imap service init from 192.168.2.1
    Mar 17 23:41:11 pc01 kernel: .982895] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: .982902] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716623] kernel[16472]: [ 2686.680249] kernel[16472]: .939322] kernel[16472]: .21416
    Mar 17 23:41:11 pc01 kernel: .982910] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716690] kernel[16472]: .960654] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716700] kernel[16472]: [ 2686.680313] kernel[16472]: .939328] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716764] kernel[16472]: [ 2686.680334] kernel[16472]: [ 2686.647333] kernel[16472]: [ 2686.620191] kernel[16472]: 3] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: .982918] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716819] kernel[16472]: .960661] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 kernel: [ 2686.716830] kernel[16472]: [ 2686.680386] kernel[16472]: .939336] kernel[16472]: [ 2685
    Mar 17 23:41:11 pc01 syslog-ng[16468]: Termination requested via signal, terminating;
    Mar 17 23:41:11 pc01 syslog-ng[16468]: syslog-ng shutting down; version='3.2.2'
    Was könnte das sein? Das System läuft ansonsten stabil.

    Gruß,
    Patrick

  2. #2

    Default AW: klogd spielt verrückt seit Update auf 11.4

    Hat niemand eine Idee?

  3. #3

    Default Re: AW: klogd spielt verrückt seit Update auf 11.4

    Quote Originally Posted by pschoenb View Post
    Hat niemand eine Idee?
    Es wird mit beeindruckender Geschwindigkeit die PID des klogd ([ 2686.716623] kernel[16472]) ins log geschrieben.

    Du hast nun zwei Möglichkeiten:
    1. Den klogd abschalten.
    Dazu musst du in /etc/sysconfig/syslog den Parameter KERNEL_LOGLEVEL auf 0 setzen.

    2. Weil der Verzicht auf die kernel Nachrichten eigentlich keine gute Idee ist, kannst du auch den syslog-ng durch den rsyslog ersetzen.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •