Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: YAST installation error

  1. #1
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default YAST installation error

    I get the following error when YAST tries to install the latest updates----
    Subprocess failed. Error: RPM failed: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index----could it be from removing KWALLET? Now I cannot re-install it due to this error.
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: YAST installation error

    What programm do you want to install?

    Try to install it with zypper.
    Open a terminal and write
    Code:
    su
    If it is programm
    Code:
    # zypper install <programm>
    If it is repository
    Code:
    # zypper addrepo -f <repository>
    Code:
    # zypper refresh
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST installation error

    On 03/17/2011 02:36 PM, 2fry wrote:
    >
    > I get the following error when YAST tries to install the latest


    i think you have a jumbled up rpm database (maybe from a failed or
    aborted install attempt)...this might help:

    open a terminal, type the first line below and press enter, then type
    in your root password (you will not see what you type) and enter
    again....then WAIT until all activity has stopped and you are returned
    to the command prompt, and then type the second, wait, repeat

    Code:
    su -
    rpmdb --rebuilddb
    zypper ref
    zypper up
    After that try YaST again.

    and, if at all possible do not abort a YaST operation, doing so almost
    always results in problems following..

    when using the repos, patience IS required because YaST must contact
    servers which are *not* operated by openSUSE or Novell and (as donated
    bandwidth) some throttle down during business (or school) hours in
    their area..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: YAST installation error

    IMO
    You may need to describe your circumstances better... eg
    Are you trying to upgrade?
    Is this a first update after upgrade?
    Have you made any other major changes to your system recently?

    Re specifically your question about Kwallet, at least on my system Kwallet does not store repository authentication keys (I think I've seen them stored elsewhere in zypper). My Kwallet only stores authentication keys related to Forms, Network authentication and simple Username/Passwords.

    HTH,
    Tony

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: YAST installation error

    Quote Originally Posted by 2fry View Post
    I get the following error when YAST tries to install the latest updates----
    Subprocess failed. Error: RPM failed: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index----could it be from removing KWALLET? Now I cannot re-install it due to this error.
    Open Terminal And write
    Code:
    su
    Code:
    # zypper refresh
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default Re: YAST installation error

    Thank you DenverD. That did the trick.

    Do you know whats up with the download.nvidia.com/opensuse/11.3/ repository? It seems to be broken. Is there another repository I can use?
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST installation error

    On 03/18/2011 06:36 AM, 2fry wrote:
    >
    > Thank you DenverD. That did the trick.


    welcome
    ..
    > Do you know whats up with the download.nvidia.com/opensuse/11.3/
    > repository? It seems to be broken.


    it is working fine here..

    try it from http://downforeveryoneorjustme.com/

    oh, how are you trying to get to it? i don't guess it is
    browsable...set it up in YaST..

    maybe one of these will help:
    http://en.opensuse.org/SDB:Configuring_graphics_cards

    http://forums.opensuse.org/informati...ide-users.html

    it was, i think, the second one that got my nvidia card singing and
    dancing..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default Re: YAST installation error

    Spoke to soon. Tried to update the nvidia drivers and got the following error message....Download failed
    Timeout exceeded when accessing 'ftp://download.nvidia.com.opensuse/11.3/x86_64/nvidia-gfxG02-kmp-desktop-260.19.36_k2.6.34.0_12-22.1.x86_64.rpm'.

    I did a manual installed the nvidia driver 260.19.44 which works fine. Now that I look at the file being installed maybe it is a good thing it failed since it is an older driver. Thanks for the help.
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YAST installation error

    On 2011-03-17 15:37, DenverD wrote:
    > and, if at all possible do not abort a YaST operation, doing so almost
    > always results in problems following..


    Aborting should be no problem, killing, yes.

    An application that offers the abort option, should take care of doing so
    cleanly. If it doesn't, it is a bug and should be reported in Bugzilla.

    Even a normal kill should be clean. A kill 9 or a crash, is different.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default Re: YAST installation error

    I finally figured out the Nvidia repository problem. I had the same problem when I update to 11.4. When you install a new version it removes all your old repositories. To avoid re-enter all the repositories when I add the repositories I select Community Repositories. However, whomever programmed that list goofed in 11.3 and carried it over in 11.4. The repository for nvidia should read: "http://download.nvidia.com/opensuse/11.4/" not "ftp://download.nvidia.com/opensuse/11.4/". Someone should change this in 11.5"
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •