Results 1 to 6 of 6

Thread: disable ati/ enable intel problem

  1. #1

    Default disable ati/ enable intel problem

    Hi

    I'm new to opensuse. I have a hybrid ATI/intel laptop. By default opensuse try to load the radeondriver but that doens't work. So i want to use my intel card. I installed intel driver and uninstalled the radeonhd package. But it still try to load the radeon card.

    I googled it but didn't found out how to do it in opensuse. In chakra it works when I uninstall radeon and install the opensource intel driver. Xorg automatically load the intel driver and everything works fine there.

    Somebody a clue
    thanks

  2. #2

    Default Re: disable ati/ enable intel problem

    Okey, the problem is that the opensource radeon and intel (i915) drivers are installed in one rpm called xorg-x11-driver-video. In chakra (arch based distro) they are packaged seperately. So there I just install the intel and uninstall the radeon driver and everything works. in opensuse the ati driver is always trying to load or something and I can't boot up. Blacklisting doesn't help. I'm now stuck on the vesadriver

    Is there a manner to install only the intel driver of the xorg-x11-driver-video rpm package and not the rest or a manner to somehow uninstall the radeondriver?

    any suggestion would be welcome!
    thanks

  3. #3

    Default Re: disable ati/ enable intel problem

    I have the same problem here, add radeon.modeset=0 to kernel line in GRUB

  4. #4

    Default Re: disable ati/ enable intel problem

    That's it!

    thanks a lot!

    ps: hmm, can't find how to mark this as solved. I don't find an edit option in my first post.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: disable ati/ enable intel problem

    Quote Originally Posted by aderius View Post
    That's it!
    thanks a lot!
    Am I correct that adding "radeon.modeset=0 " as a boot code allows the Intel graphic driver to load when you have a hybrid Intel/Radeon graphic hardware configuration?

  6. #6

    Default Re: disable ati/ enable intel problem

    And could you please show us the output of these two commands:
    Code:
    /usr/sbin/hwinfo --gfxcard | grep -i -e model -e driver -e device -e status
    /bin/lsmod | grep radeon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •