Results 1 to 7 of 7

Thread: 11.3 kernel-default update gives conflict for preload-kmp-desktop

  1. #1

    Default 11.3 kernel-default update gives conflict for preload-kmp-desktop

    Hi,

    When I requested an "Update if newer versions available" from within the YaST package manager, I get a dialogue that requires me to make a decision. Dho... And I am not sure how to respond.

    There's a screenshot of the dialogue over here.
    And if I export it to a file, it says this:
    Code:
    #### YaST2 conflicts list - generated 2011-03-17 11:05:42 ####
    preload-kmp-default-1.1_2.6.31.5_0.1-6.8.1.x86_64 requires ksym(default:__alloc_percpu) = 55f2580b, but this requirement cannot be provided
    deleted providers: kernel-default-2.6.31.5-0.1.1.x86_64
        [ ] do not install kernel-default-2.6.34.7-0.7.1.x86_64
        [ ] downgrade of preload-kmp-default-1.1_2.6.31.5_0.1-6.8.1.x86_64 to preload-kmp-default-1.1_k2.6.34.7_0.7-19.1.11.x86_64
        [ ] break preload-kmp-default by ignoring some of its dependencies
    #### YaST2 conflicts list END ###
    I think that this tell me my current kernel:
    Code:
    #uname -a
    Linux gzunder 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux
    And this is the output of zypper lr -d:
    Code:
    #  | Alias                               | Name                                        | Enabled | Refresh | Priority | Type     | URI                                                                             | Service
    ---+-------------------------------------+---------------------------------------------+---------+---------+----------+----------+---------------------------------------------------------------------------------+--------
    1  | ATI_Graphics_Drivers                | ATI Graphics Drivers                        | Yes     | Yes     |   99     | rpm-md   | http://www2.ati.com/suse/11.3                                                   |        
    2  | Canon_MP600_Drivers                 | Canon MP600 Drivers                         | No      | No      |   99     | plaindir | dir:///home/mprowe/Downloads/CanonMP600_270                                     |        
    3  | Misc_drivers_for_Canon_MP600        | Misc drivers for Canon MP600 from 11.2 repo | No      | No      |   99     | rpm-md   | http://download.opensuse.org/distribution/11.2/repo/oss/suse                    |        
    4  | Nvidia_Graphics_Drivers             | Nvidia Graphics Drivers                     | Yes     | Yes     |   99     | rpm-md   | http://download.nvidia.com/opensuse/11.3                                        |        
    5  | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82         | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/11.3/                                       |        
    6  | download.opensuse.org-STABLE        | openSUSE BuildService - OpenOffice.org      | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.3/ |        
    7  | download.opensuse.org-UpdatedApps   | openSUSE BuildService - KDE:UpdatedApps     | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.3/       |        
    8  | download.opensuse.org-mozilla       | openSUSE BuildService - Mozilla             | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/                |        
    9  | download.opensuse.org-packages      | openSUSE BuildService - Java:packages       | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.3/         |        
    10 | download.opensuse.org-standard      | Main Repository (Contrib)                   | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/openSUSE:/11.3:/Contrib/standard/     |        
    11 | ftp.uni-erlangen.de-suse            | Packman Repository                          | Yes     | Yes     |   99     | rpm-md   | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/                       |        
    12 | repo-debug                          | openSUSE-11.3-Debug                         | No      | Yes     |   99     | NONE     | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                  |        
    13 | repo-non-oss                        | openSUSE-11.3-Non-Oss                       | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/11.3/repo/non-oss/                    |        
    14 | repo-oss                            | openSUSE-11.3-Oss                           | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/11.3/repo/oss/                        |        
    15 | repo-source                         | openSUSE-11.3-Source                        | No      | No      |   99     | NONE     | http://download.opensuse.org/source/distribution/11.3/repo/oss/                 |
    I think the first thing I need to understand is; Is YaST trying to upgrade the kernel (I'm already at 2.6.34...) or is it the pre-load file that is being updated? And if it is the pre-load, who/why is it trying to upgrade to 2.6.31...?

    Regards, Martin

  2. #2

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    martinprowe wrote:
    > When I requested an "Update if newer versions available" from within
    > the YaST package manager, I get a dialogue that requires me to make a
    > decision. Dho... And I am not sure how to respond.


    > I think the first thing I need to understand is; Is YaST trying to
    > upgrade the kernel (I'm already at 2.6.34...) or is it the pre-load file
    > that is being updated? And if it is the pre-load, who/why is it trying
    > to upgrade to 2.6.31...?


    To get this thread started, I'll offer the following:

    (1) I believe it is trying to update preload-kmp-default and that the
    correct action is do not install that package

    (2) I don't know much about preload but I'm extremely wary of it because:
    (a) there are a couple of threads here about problems with it in 11.4
    (b) there were questions from Greg-KH (a suse kernel developer) about it
    being broken on the opensuse-kernel list earlier this year
    (c) last time I looked, it was broken in some buildservice kernel packages

    (3) there's a suggestion on another thread to completely remove it. I
    don't know enough to know whether that is possible or sensible, but it's
    something to consider

    Hopefully somebody who knows more will be along soon!

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    On 03/17/2011 12:36 PM, martinprowe wrote:
    >
    > Linux gzunder 2.6.34.7-0.7-desktop #1 SMP PREEMPT
    >
    > And this is the output of zypper lr -d:


    first, i'm not pretending to know more than 'djh' but, i do want you
    to read the paragraph beginning with "IMPORTANT" in this post:
    http://tinyurl.com/33qc9vu, because i have a feeling some (or all) of
    your problems _may_ have begun in that mix of enabled repos you gave..

    for one thing i really doubt you have need for BOTH ATI and nVidia
    graphics driver (or maybe you have two cards (or one card and one
    built-in) in use, do you?)...

    if it were my machine i would disable (and stop updating) these repos:
    1, 4, 6, 7, 8, 9, 10 and also stop updating 12..

    now i'm gonna be real honest with you: i'm not sure what will happen
    to your system...that is it may continue to be kinda shakey, because
    there is not a real easy way to know how much different (and
    conflicting) stuff you may have already introduced to the system..

    but, it MAY happen that it stops trying to do stupid things (like
    replace kernels to load one little bitty thingy)...(or not)...but i
    have a secret plan...but before i reveal that i'd someone who REALLY
    knows to step in and comment, advise..

    and, by the way tell us a little more about what this machine is used
    for....i ask because i see you are using a PREEMPT kernel and i do not
    know why...do you?? are you, maybe composing or recording electronic
    music on your computer? driving a real-time automaton or what??

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    Hi Dave and DevnerD,

    Thank you for taking an interest in my "little" problem. Let me have a little time to think about your last comments DenverD.
    But I popped back to this thread to add an update. I wonder if it is significant?

    While booting, I turned off the GUI to see if I could see anything significant. Very early in the boot cycle (even before anything gets logged to boot.msg), I noted messages to the effect:

    "The file /lib/modules/... lost this because it scrolled past too quick .../systemtap/preloadtrace.ko is missing"

    So I went looking for preload modules. I have a vague recollection that "years" ago (not on this system) I needed disable preload for some reason. Anyway, looking through the installed modules. I find this. I'm sorry that I don't know my zypper commands well enough to get it in plain text, but here's a screen shot.

    Is my solution as simple us un-installing the old preload-kmp-default and installing the newer one?

    Looking forward to any comments.

    Regards, Martin

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    On 03/17/2011 04:36 PM, martinprowe wrote:
    >
    > Is my solution as simple us un-installing the old preload-kmp-default
    > and installing the newer one?


    as far as i can see there is only one preload-kmp-default offered..

    and, one preload-kmp-desktop offered....didn't i see you were using a
    pre-empt *desktop* kernel...

    ah, looks like the kernel numbers for the desktop preload-kmp-desktop
    is a much better match than the numbers for the installed
    preload-kmp-default

    i wonder how the (*apparently*) wrong one got installed..

    but, before you take steps based on what i wonder about, i ask you to
    read my caveat, below..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    One thing for sure is that all your kernel packages should match the running kernel version.

  7. #7

    Default Re: 11.3 kernel-default update gives conflict for preload-kmp-desktop

    Hi all,

    Just an quick update. Over the weekend, bucked-up the courage, and un-installed the older (2.6.31) preload thingy.
    Voila! It all got better! The multiple kernel boot options from menu.lst disappeared. The upgrade conflict messages disappeared.
    And as far as I can tell my system is clean again.

    Thank you all yet again.

    Regards, Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •