Results 1 to 6 of 6

Thread: KMix won't start up in SUSE 11.4

  1. #1

    Default KMix won't start up in SUSE 11.4

    Hi there,
    KMix doesn't start up in OpenSUSE 11.4 (x86) + KDE 4.6.0. So I can't configure my audio channels and so on.

    Error:
    inux-d84p:/home/Willem # kmix
    unnamed app(7652): KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

    unnamed app(7651): KUniqueApplication: Pipe closed unexpectedly.

    Can anybody help me? Or is it a bug in KDE?

    Thanks in advance,
    Willem Franssen

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: KMix won't start up in SUSE 11.4

    Try again, but do not start KMix as root, but as a regular user.

    This will at least give us some informative output.

  3. #3

    Default Re: KMix won't start up in SUSE 11.4

    When I try to start KMix from the terminal console as e regular user nothing happens. There is no output at all. When I try to startup KMix from the KDE Kickoff Programmstarter nothing happens. Further on I don't know in what log-, or config folder I have to look to get some more information.

  4. #4

    Default Re: KMix won't start up in SUSE 11.4

    The same is here...

  5. #5

    Default Re: KMix won't start up in SUSE 11.4

    Try running this command before you run kmix

    eval dbus-launch

    KUniqueApplication reads the environment variables DBUS_SESSION_BUS_ADDRESS & DBUS_SESSION_BUS_PID and sometimes they don't get set, running eval dbus-launch sets them, when you run it you should get something like:

    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Pl3CfmlJNS,guid=blah
    DBUS_SESSION_BUS_PID=[pid-number]

    Then try running kmix, I don't know why they don't get set or how to make it permanent, but if it works you could add a script to .kde4/Autostart containing

    eval dbus-launch
    kmix
    exit 0

    Can't guarantee it'll work in your case, I'm not really all that knowledgeable in these sort of areas, but it's something I came across in the past on googling some other app giving the same errors that worked for me, with any luck it may do the trick for you too ... best of luck

  6. #6
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: KMix won't start up in SUSE 11.4

    if you are still using pulse audio, install 'pavucontrol'. If not solve the problem at least it will give you a way to control the audio.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •