Results 1 to 4 of 4

Thread: YAST2 forgets manual configuration of the wifi card

  1. #1

    Angry YAST2 forgets manual configuration of the wifi card

    Hi all,

    Installed OpenSUSE 11.4 with XFCE on MSI Wind U90.
    Unfortunately my RTL8187se buit-in wi-fi doesn't work.
    Finally found that driver r8180 works. After YAST2 configuration it worked, but after reboot stopped working.
    I've found that YAST2 forgets my manual configuration of the wifi card (forgets all settings).
    I've tried to remove card from YAST2 and configure again from scratch, but it forgets all my settings - mainly the module name - r8180, and without this driver network doesn't work!
    What to do?
    OpenSUSE 12.1 XFCE 4.8 i586

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,663
    Blog Entries
    3

    Default Re: YAST2 forgets manual configuration of the wifi card

    Check my comments here:
    traditional (ifup) and networkmanager problems using KDE 11.4
    I'm not sure whether they are relevant to your problem, but it's a possibility. So experiment with switching to dhclient for handling dhcp.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: YAST2 forgets manual configuration of the wifi card

    Sorry, I was not quite correct, YAST forgets only wi-fi driver settings, others are saved correctly.
    So the question is: where, in which file, settings of the wi-fi card driver (the driver that should be used from the kernel) are stored?
    OpenSUSE 12.1 XFCE 4.8 i586

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: YAST2 forgets manual configuration of the wifi card

    On 03/17/2011 01:36 AM, levne wrote:
    >
    > Sorry, I was not quite correct, YAST forgets only wi-fi driver settings,
    > others are saved correctly.
    > So the question is: *where, in which file, settings of the wi-fi card
    > driver (the driver that should be used from the kernel) are stored?*


    /etc/sysconfig/network/ifcfg-XXXX. Replace the Xs with the name shown in the
    /usr/sbin/iwconfig output.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •