Results 1 to 8 of 8

Thread: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

  1. #1

    Default VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Today I have tried to install VMware Player 3.1.3, and it installed successfully... I think. When I try to start VMware Player, it says "Before you can run VMware, several kernel modules must be installed and compiled into the running kernel," then I select the option to "install," and give the root password to proceed. Afterwards, nothing happens. I am not sure what to do. Will I somehow have to manually compile and install the kernel modules?

    Additional information:
    Version: openSUSE 11.4 GNOME 32-bit

  2. #2

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    I run vmplayer from the terminal, and this is what it displays:

    Code:
    Logging to /tmp/vmware-matthew/setup-10792.log
    ERROR: modinfo: could not find module vmmon
    ERROR: modinfo: could not find module vmnet
    ERROR: modinfo: could not find module vmblock
    ERROR: modinfo: could not find module vmci
    ERROR: modinfo: could not find module vsock
    ERROR: modinfo: could not find module vmmon
    ERROR: modinfo: could not find module vmnet
    ERROR: modinfo: could not find module vmblock
    ERROR: modinfo: could not find module vmci
    ERROR: modinfo: could not find module vsock
    (dialog box appears, asks to install kernel modules)
    ERROR: modinfo: could not find module vmmon
    ERROR: modinfo: could not find module vmnet
    ERROR: modinfo: could not find module vmblock
    ERROR: modinfo: could not find module vmci
    ERROR: modinfo: could not find module vsock
    ERROR: modinfo: could not find module vmmon
    ERROR: modinfo: could not find module vmnet
    ERROR: modinfo: could not find module vmblock
    ERROR: modinfo: could not find module vmci
    ERROR: modinfo: could not find module vsock
    ERROR: modinfo: could not find module vmmon
    ERROR: modinfo: could not find module vmnet
    ERROR: modinfo: could not find module vmblock
    ERROR: modinfo: could not find module vmci
    ERROR: modinfo: could not find module vsock
    No protocol specified
    xprop:  unable to open display ':0.0'
    No protocol specified
    xprop:  unable to open display ':0.0'
    No protocol specified
    
    (vmware-modconfig:10984): Gtk-WARNING **: cannot open display: :0.0

  3. #3

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Use search function. Topic was discussed and solved some days back.

  4. #4
    Join Date
    Jul 2008
    Location
    Angel Fire, NM USA
    Posts
    330

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Quote Originally Posted by Collegate_user12 View Post
    Today I have tried to install VMware Player 3.1.3, and it installed successfully... I think. When I try to start VMware Player, it says "Before you can run VMware, several kernel modules must be installed and compiled into the running kernel," then I select the option to "install," and give the root password to proceed. Afterwards, nothing happens. I am not sure what to do. Will I somehow have to manually compile and install the kernel modules?

    Additional information:
    Version: openSUSE 11.4 GNOME 32-bit
    Try the fpatch scripts referenced in this thread

    11.4 RC1 KDE VMWare Workstation 7.1.2 Fails to Build Modules

    Worked with Workstation 7.1.3 for me.

  5. #5
    Join Date
    Jun 2008
    Location
    Managua
    Posts
    400

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Install kernel-source, kernel-syms, install the base development pattern, install vmplayer and after that apply this openSUSE Lizards

  6. #6

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Quote Originally Posted by Easgs View Post
    Install kernel-source, kernel-syms, install the base development pattern, install vmplayer and after that apply this openSUSE Lizards
    I had everything except for kernel-syms installed before, I installed kernel-syms and the openSUSE Lizards patch and now it is up and running, I am so very grateful. Thank you for your help.

  7. #7
    Join Date
    Mar 2011
    Location
    Oldham - UK
    Posts
    17

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Quote Originally Posted by Easgs View Post
    Install kernel-source, kernel-syms, install the base development pattern, install vmplayer and after that apply this openSUSE Lizards
    I Have the same problem, I've downloaded the patch but how do I apply it? (In step by step instructions as I'm a bit od an ignoramus!!!)

  8. #8

    Default Re: VMware Player 3.1.3 Not Starting (Not Installing Kernel Modules)

    Download Player 3.14. No Patch needed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •