Results 1 to 10 of 10

Thread: Problem in graphical log in

  1. #1
    Join Date
    Mar 2011
    Location
    Dhaka, Bangladesh
    Posts
    42

    Default Problem in graphical log in

    yesterday I was working with a word file in opensue 11.4 & suddenly it got hanged. So I had to shutdown forcely. When I restart the pc & boot in to opensuse, it gave me a CLI option (no kdm) to log in. However I logged in via CLI & tried the startx command. It gave me some error

    Here is the error
    Code:
    xinauth: file /home/jahidul/.serverauth.6753 does not exist
    fatal server error
    could not create lock file in /tmp/.txo-lock
    
    xinit failed: /usr/bin/Xorg is not setuid. May be that's the reason?
    if so, use a display manager or adjust /etc/permission.local
    I think x-server has stopped working. Son What should I do?

    Thanks in advance.

  2. #2
    Join Date
    Dec 2008
    Location
    SE Florida, USA
    Posts
    15

    Default Re: Problem in graphical log in

    I'm seeing a similar problem.

    I upgraded from 11.3 to 11.4 using 'zypper dup' on my HP dv9000z laptop (AMD Turion 64, 2GB memory)

    In the process of troubleshooting this problem, I even switched from the 'nouveau' driver to the 'nvidia' driver,
    following the instructions found elsewhere in this forum. I have a VGA compatible controller: nVidia Corporation C51 [Geforce Go 6150] (rev
    a2), and the 'nvidia' bits are at 260.19.36. Symptoms persisted identically between the two Xorg drivers.

    My system is set up to automatically log me in as a normal user. I end up with black screen; the ONLY indication that I have that the
    X Server (and KDE?) is running is that my JWZ XScreensaver comes up with its notification box. If I then hit 'Ctrl-Alt-F1', I can get
    down to a text user prompt, can verify that the X Server is indeed running, as are two 'startkde' processes, but no other KDE processes ?!?

    If I then su to root, kill the X Server and the two 'startkde' processes, and then do a 'startx' as root, KDE comes up properly and I'm
    logged into my root account, and all of my plasmoids (actually just the "Desktop Folder" is all I use) come up. Bottom tool bar looks
    good, etc., etc. So, I'm thinking there's some sort of obscure permission(s) problem somewhere. /usr/bin/Xorg is set to -rws--x--x .

    So, I don't know what's wrong. I even copied ~root/.nvidia-settings-rc to my /home/foo_user directory, but it didn't help.

    I apologize if it seems like I'm hijacking the thread, but after reading many other posts, hasan65's seems to be identical to my problem.

  3. #3

    Default Re: Problem in graphical log in

    Looks to be a permissions problem, not really sure of the cause but you said on your original thread something about a power failure, could even be some files have gotten corrupted when that happened

    About the best I could suggest you try there would be to boot into your cli and run the console version of yast (just type yast as root in the cli)

    You could then try removing and/or re-installing the nvidia driver

    It may even be possible to startx on the system as it is now if you login as root, might be worth trying that first


    There are people on here can give far better advice on getting out of this kind of situation, given the power failure thing you may need to do thins like fsck your drive, but as I say for that kind of thing you're better getting advice off someone more knowledgeable than I

    I will say though that most knowledgeable people almost always recommend a clean install rather than an upgrade

  4. #4

    Default Re: Problem in graphical log in

    Confirm same issue as original poster after online update from 11.3 to 11.4.
    No power failure etc.
    Installation was smooth.
    startx produces the same error message as in post #1 above.

  5. #5
    Join Date
    Dec 2008
    Location
    SE Florida, USA
    Posts
    15

    Default Re: Problem in graphical log in

    After some fussing around, and booting in 'failsafe' mode with 'nomodeset', and then doing a 'ctrl-alt-f1' to escape the black screen
    and get a CLI prompt, I killed both '/usr/bin/startkde' processes. That didn't work out, so I tried again, and was able to get to a
    login screen (with a solid blue background). Logged in (!) in failsafe mode, and my windows, decorations, buttons and so forth all came up.
    And, there was a warning screen, which stated that 'kwinrc' wasn't writeable - turned out I'd copied it from ~root (since I, the lowly user
    didn't have one), so I had to su to change the owner (and group) to 'foouser.users'.

    Insofar as permission problems go, I did see another post which recommended doing 'zypper in -f rpm' to force re-installation of the rpm rpm,
    which I thought I'd done earlier. I did it again (using the -f switch this time) and in doing so, it ran sysconfig and found and fixed a few problematic
    permissions along the way. The 'failsafe' window also reported a complaint with /dev/nividactl so I did a chmod 666 on it and /dev/nvidia0. If that
    causes a security problem, oh well...

    (I'm still trying to delete the libchipcard4-4.2.9-3.2 rpm, but /etc/init.d/chipcardd has a bug "start-stop-daemon" in it which prevents deletion...)

    I'm now going to try rebooting the system to see if things come up cleanly.

    Thanks for the suggestions!

  6. #6

    Default Re: Problem in graphical log in

    I now have resolved this issue as follows for my nvidia system:

    login as root
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
    rm /etc/X11/xorg.conf

    startx

    Hopefully gui comes up . Reboot the system

    Now it should be running on the nouveau driver

    if you want the nvidia driver
    go to:

    SDB:NVIDIA drivers - openSUSE

  7. #7
    Join Date
    Dec 2008
    Location
    SE Florida, USA
    Posts
    15

    Default Re: Problem in graphical log in

    FWIW, I finally ended up re-installing from scratch; my /home directories were preserved nicely, however, and for the most part, I
    was able to recover everything that I need. I am using the 'nouveau' driver (as installed by default for my GeForce 6150).

    I believe there was/is a conflict between 'xscreensaver' and KDE 4.6.0, but I can't necessarily prove it right now, but I'll try to investigate
    using a scratch installation in the next few weeks, and also try to upgrade to 4.6.1 on the scratch system as well, and perhaps tinker
    with NVIDIA drivers, etc. But, for right now, I need to keep my main system stable.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem in graphical log in

    On 2011-03-16 20:06, hasan65 wrote:
    >
    > yesterday I was working with a word file in opensue 11.4 & suddenly it
    > got hanged. So I had to shutdown forcely. When I restart the pc & boot
    > in to opensuse, it gave me a CLI option (no kdm) to log in. However I
    > logged in via CLI & tried the startx command. It gave me some error


    You should first log in as root (text mode) and issue "init 3". Then you
    can try startx. But before, you should have a look at X log files.

    If permissions are wrong, you could start with "SuSEconfig --module
    permissions".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem in graphical log in

    On 2011-03-16 21:06, Ecky wrote:
    > I will say though that most knowledgeable people almost always
    > recommend a clean install rather than an upgrade


    I don't - and I have about 12 years linux experience.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    Join Date
    Mar 2011
    Location
    Dhaka, Bangladesh
    Posts
    42

    Default Re: Problem in graphical log in

    I have re-installed opensuse 11.4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •