Results 1 to 5 of 5

Thread: can't change permissions

  1. #1

    Default can't change permissions

    Hi
    I'm dual booting with 11.4KDE and W7.
    I have a common partition NTFS that I mount automatically in /mnt/winE.
    I can see the partition and access all files but I can't modify them as normal user.
    the ownership is set as root and I can't change it to a normal username.
    I tried changing it from dolphin (running as su) and from console with

    Code:
    chown francesco /mnt/winE -R
    nothing work. all file and folders are always owned by root...

    when I was running this partition was mounted with the same mount point and it worked flawlessly...

    this is my current fstab

    Code:
    /dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WX71A1055508-part6 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WX71A1055508-part5 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WX71A1055508-part7 /home                ext4       acl,user_xattr        1 2
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    /dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WX71A1055508-part8 /mnt/winE            ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
    thanks
    Ft

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: can't change permissions

    That is rather logical as NTFS (being no native Linux file system) has no ownership. Thus it can not be changed.

    But what you show is nnoot changing anythin on the NTFS file system, but changing the ownership of the mount point. Which could work if you did it proper:
    Code:
    chown francesco /mnt/winE -R
    iswrong, it should be
    Code:
    chown -R francesco /mnt/winE
    (read the man page).
    But the -R option is of no use because that would go down into the file system which will not work.

    Thus try: umount, chown the mountpoint to francesco and mount again.

    Because NTFS has no owner and group and access bits, they are mimiced by the Linux software. Look for the proper option in your fstab going with ntfs-3g setting a normal username as mimiced owner (something like user= instead of users?? Anybode can help here with the exact details?)
    Henk van Velden

  3. #3

    Default Re: can't change permissions

    I think I fixed it!

    I had a backup copy of the fstab I had with 11.3 where I had

    Code:
    /dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WX71A1055508-part8 /mnt/winE            ntfs-3g   defaults 0 0
    It seems to be ok now.
    the strange thing is that all the options I had (users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8) were automatically put there by yast....
    go figure...

    thanks anyway
    FT

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: can't change permissions

    My memory is not what it was I should have remembered that defaults is allways recommended here. But now you found it yourself, that is very good for your ego
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't change permissions

    On 2011-03-16 20:36, ftriscari12 wrote:

    > the strange thing is that all the options I had
    > (users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8) were
    > automatically put there by yast....


    Just add uid=myusername and it would work.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •