Results 1 to 10 of 10

Thread: eID-belgium for openSUSE 11.4

  1. #1
    Join Date
    Mar 2009
    Location
    Belgium
    Posts
    45

    Default eID-belgium for openSUSE 11.4

    I'm writing this from a user perspective.

    eID-belgium and the config module are not (yet) available for openSUSE 11.4. No big deal, I can wait as I'm sure it will be compiled once these days.

    Though, there's one thing that I'm interested in. The packages for pre-11.4 always required hal to be installed and running. With openSUSE 11.4 hal got removed as it is deprecated.
    Is there any chance the eID-belgium packages are going to be delivered without hal support/requirement? I can't think of pulling hal back in just for one app.

    Someone with some develop skills perhaps kan answer this for me?

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: eID-belgium for openSUSE 11.4

    I believe Hal is still in the 11.4 repos but has to be installed, because it is needed by smolt. It was installed by a patch here.

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: eID-belgium for openSUSE 11.4

    Quote Originally Posted by consused View Post
    I believe Hal is still in the 11.4 repos but has to be installed, because it is needed by smolt. It was installed by a patch here.
    My final sentence there was a mistake as I was using an 11.3 system when I posted, i.e it wasn't installed by patch here on 11.4. Anyway, it is installable from 11.4's standard repo.

  4. #4

    Default Re: eID-belgium for openSUSE 11.4

    i see in ubuntu always the newest version but sinds ubuntu few times crashs im using now opensuse. but 11.3 worked the eid belgium indeed but its installable, and the newest version arent up too date... eid of belgium version are now 3.55 on opensuse in 11.3 are 2.6 , i think opensuse havent lots of intention to fill the empty space in short time. opensuse is a platform for de Sled, commercial suse. and i see in the software part there arent much software to choose. you see by ubuntu a lot of thinks with his own app-store. if i choose i mayby back too ubuntu but i see a problem that i frequent have with that. so i will stay.

    i need the eid when comes online? needed for taxes stuff ..

  5. #5

    Default Re: eID-belgium for openSUSE 11.4

    Indeed, tax time in Belgium...

    still no eid middleware package for opensuse 11.4, and the official middleware packages on eid.belgium.be are 32bit only. If you have a 32bit opensuse installation you could give the fedora-package on eid.belgium.be a try, but for the 64bit folks it will be a fustrating experience...

    However, there are next-generation (version 4.0) not-yet-official java-based versions of the middleware available, which were quite easy to install.
    How I did it:

    STEP 1:
    Installation of the card reader drivers: install all packages marked with an "i" with zypper or yast. We'll probably don't need all of them, but I guess this depends on the card reader you have...

    Code:
    # zypper se pcsc
    Gegevens van installatiebron laden...
    Lezen van geïnstalleerde pakketten...
    
    S | Naam                     | Samenvatting                                                              | Type      
    --+--------------------------+---------------------------------------------------------------------------+-----------
    i | libpcsclite1             | PCS Smart Cards Library                                                   | pakket    
    i | libpcsclite1             | pcsc-lite: Fixed runlevels of the smart card daemon pcscd                 | patch     
      | libpcsclite1-32bit       | PCS Smart Cards Library                                                   | pakket    
    i | pcsc-acr38               | PC/SC IFD Handler for the ACR38 Smart Card Reader                         | pakket    
      | pcsc-acr38-devel         | PC/SC IFD Handler for the ACR38 Smart Card Reader                         | pakket    
    i | pcsc-asedriveiiie-serial | ASEDrive IIIe Serial Smartcard Reader Driver                              | pakket    
    i | pcsc-asedriveiiie-usb    | ASEDrive IIIe USB Smart Card Reader Driver                                | pakket    
    i | pcsc-asekey              | ASEKey USB Token Driver                                                   | pakket    
    i | pcsc-ccid                | PCSC Driver for CCID Based Smart Card Readers and GemPC Twin Serial Rea-> | pakket    
    i | pcsc-cyberjack           | PC/SC IFD Handler for the Reiner SCT Cyberjack USB-SmartCard Reader       | pakket    
    i | pcsc-eco5000             | PC/SC IFD Handler for the ECO 5000 Serial Smart Card Reader               | pakket    
    i | pcsc-gempc               | PCSC driver for the Gemplus GemPC 410/430 smartcard readers               | pakket    
    i | pcsc-lite                | PCS Smart Cards Library                                                   | pakket    
      | pcsc-lite                | PCS Smart Cards Library                                                   | bronpakket
      | pcsc-lite-devel          | Development package for the MUSCLE project SmartCards library             | pakket    
      | pcsc-openct              | PC/SC IFD Handler for OpenCT Smart Card Drivers                           | pakket    
    i | pcsc-reflex60            | PCSC driver for Schlumberger Reflex 60 smartcard readers                  | pakket    
    i | pcsc-towitoko            | PCSC driver for Towitoko Smart Card Readers                               | pakket    
      | pcsc-towitoko-devel      | PCSC driver for Towitoko Smart Card Readers                               | pakket
    Make sure "pcsc" runs (as root):
    Code:
    # /etc/init.d/pcscd restart

    STEP 2:
    The middleware version 4.0 can be downloaded from code.google.com/p/eid-mw. This small package contains the middleware and an add-on for firefox. These are the only things you need to login on tax-on-web and other websites requiring the eID. NOT included in this package is a program to view your eID and change the pin code - for this you need another package (step 3)
    The most recent version at this time is 4.0.0-0.925, and I downloaded a rpm for fedora 16 for 64bit . Evidently there is a 32bit version as well. I installed this using zypper (for 64bit):

    Code:
    # zypper in eid-mw-4.0.0-0.925.fc16.x86_64.rpm
    This will complain about a missing dependency "ccid". It's save to break this dependency: I guess in opensuse this package is called "pcsc-ccid", which I installed in step 1.
    After installation, make sure to restart firefox.


    STEP 3:
    There is also a second, optional package, called "eid-viewer", that allows you to view your eID card contents and change the pin code. You don't need this if you just want to login into eID-enabled websites. eid-viewer can be downloaded from code.google.com/p/eid-viewer. At this time the most recent version is 4.0.0.52, and again I chose the fedora 16 rpm. (64bit and 32bit). Install it using zypper:

    Code:
    # zypper in eid-viewer-4.0.0-0.52.fc16.x86_64.rpm
    After this you can invoke "eid-viewer" from the command line (apparently it doesn't come with a fancy entry in the menus, but it's easy to create one yourself)

  6. #6

    Default Re: eID-belgium for openSUSE 11.4

    Selfcomments to the above procedure while doing a clean install of the beID middleware on my netbook (32bit)...
    (too bad I'm not able to edit my previous post)

    additional information for STEP1:
    the essential packages seem to be libpcsclite1, pcsc-lite and pcsc-ccid. If doesn't work for you, check all of them (except pcsc-openct, which breaks things).

    additional information for STEP2:
    after the installation of the middleware and restarting firefox to enable the addon that was installed automagically, you still might have some problems to login into a eID-enabled website. I forgot to mention two things that have to be changed in firefox (because I applied them during a previous attempt to install the middleware):
    • verify if the Belgian root certificates can identify websites, email-users and programmers, as explained in the second part of these documents (NL, FR) - the add-on is allready installed.
    • if you still have problems (error page "ssl_error_renegotiation_not_allowed") surf to "about:config" in firefox, confirm that you won't do silly things and filter for "renego". Two items will show up, and both can be used to solve the problem (but chose only one). Either you set "security.ssl.allow_unrestricted_renego_everywhere__temporarily_available_pref" to TRUE, either you make a comma-separated list of "security.ssl.renego_unrestricted_hosts". The first is clearly depreciated by Mozilla (safety issues), so I opted for the second. This means however that every eID-enabled website needs to be added to the comma-separated list. For tax-on-web, this is "ccff02.minfin.fgov.be".


    And finally: it also works for 32bit opensuse 11.4

  7. #7

    Default Re: eID-belgium for openSUSE 11.4

    I cannot tell you how relieved I am to have found your post.

    I desperately needed to get this working!

    a thousand thanks.

    J.

  8. #8
    Join Date
    Dec 2010
    Location
    Mechelen, Belgium
    Posts
    16

    Default Re: eID-belgium for openSUSE 11.4

    Has someone tried whether this also works under OpenSuse 12.1?

  9. #9
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    45

    Default Re: eID-belgium for openSUSE 11.4

    Quote Originally Posted by thibdb13 View Post
    Has someone tried whether this also works under OpenSuse 12.1?
    i got it working in firefox 13.0 (with beid addon) under opensuse 12.1 using the updated packages you can find in the "security:chipcard" repository

  10. #10
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    45

    Default Re: eID-belgium for openSUSE 11.4

    I did a write-up of what I had to do to get it working under opensuse 12.1 (most of the trouble was getting the broadcom 5880 smartcard reader present on my Dell Precision M4600 laptop to work..)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •