Results 1 to 7 of 7

Thread: 11.4 Display flicker

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default 11.4 Display flicker

    I recently upgraded my desktop to 11.4 and kde 4.6.1

    My desktop has :
    VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]

    This is legacy ATI stuff, radeon driver loaded (as was in 11.3) and seems to be operating.

    I am getting a somewhat periodic (5 secs or so) flicker on the display, fast enough to be annoying but not fast enough to really affect anything.

    I have seen several threads about short freezes, but realize that flicker and freeze might be a matter of speed and memory, etc.

    I tried suspending Desktop Effects, that may have reduced the frequency of the flicker but did not eliminate.

    Any other suggestions?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: 11.4 Display flicker

    Yes, I am seeing that flicker. And that is also with an ATI display (RS250).

    It's not just a flicker. To get the display info, I clicked on the "My Computer" desktop item (in KDE). Then I had to scroll down toward the bottom of the screen to read the display info. At every "flicker", that automatically scrolls back up.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: 11.4 Display flicker

    I have been digging a bit, found the following:
    The current radeon driver comes in the xorg-X11-driver-video package, currently 7.6-52.4 is the standard for 11.4
    From reviewing the Changelog(in YAST), It would appear that xf86-video-ati-6.14.0 is the radeon source for the package.
    There is a xorg-X11-driver-video 7.6.194 in factory, but the changelog shows noting with respect to the ati driver.

    Looking at xorg/driver/xf86-video-ati - ATI video driver, 6.14.0 appears to be the most recent release.

    I note that, in the Changelog (back to YAST for xorg-X11), some of the "fixes" listed require kernel 2.6.38; the 11.4 release is 2.6.37 but I do see 2.6.38 being worked in factory.
    Obviously 6.14.0 works somewhat with kernel 2.6.37.
    I may investigate 2.6.38, but don't really like getting so far off the "standard" path on this machine.

    I see references to the flicker/freeze in other distros, with no confirmed fixes.

    I find it somewhat interesting that both Nvidia and ATI proprietary drivers seem to be solving most peoples issues.
    In the past, the Xorg drivers seemed to be more stable early on in the new releases.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: 11.4 Display flicker

    Thanks. I'll put up with the flicker for now. It is only a minor annoyance, and the machine where it happens is only being used for testing. But perhaps I should consider installing factory on it, and thereby do some real testing.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: 11.4 Display flicker

    Interesting development - for some reason, on reboot yesterday evening, Xorg could no longer start up with a reasonable resolution for my display (native 1680x1050).
    I was able to force a modeline into /etc/X11/xorg.conf.d but someting seemed just plain flaky.

    As an experiment, I switched my output port from VGA to DVI (I share a monitor between a WinP box and my 11.4 box).

    With DVI connection, 11.4 boots up cleanly (radeon driver), determines correct native resolution AND DOES NOT FLICKER.

    I'll leave it this way for a while

  6. #6

    Default Re: 11.4 Display flicker

    Also found this to be true. I have two monitors connected to Radeon X1300 - the flicker follows the VGA connection, DVI no flicker. Interestingly - the vga connection is identified as DVI in the display tool.

    ATI Technologies Inc RV515 [Radeon X1300]
    >xrandr
    Screen 0: minimum 320 x 200, current 3840 x 1200, maximum 8192 x 8192
    DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
    1920x1080 60.0*+
    1680x1050 60.0
    1280x1024 75.0 60.0
    1440x900 75.0 59.9
    1280x960 60.0
    1152x864 75.0
    1280x720 60.0
    1024x768 75.1 70.1 60.0
    832x624 74.6
    800x600 72.2 75.0 60.3 56.2
    640x480 72.8 75.0 66.7 60.0
    720x400 70.1
    S-video disconnected (normal left inverted right x axis y axis)
    DVI-1 connected 1920x1200+1920+0 (normal left inverted right x axis y axis) 518mm x 324mm
    1920x1200 60.0*+
    1600x1200 60.0
    1680x1050 60.0
    1280x1024 75.0 60.0
    1280x960 75.0
    1152x864 75.0 60.0
    1024x768 75.1 70.1 66.0 60.0
    832x624 74.6
    800x600 72.2 75.0 60.3 56.2
    640x480 72.8 75.0 66.7 60.0
    720x400 70.1

  7. #7
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: 11.4 Display flicker

    At the time I concluded it was an issue with the 11.4 radeon (open source) driver. Radeonhd did not work at all.
    I spent $20 on a new ATI card, proprietary fglrx(maintained by the atiupgrade script) works perfectly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •