Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: mysql at runlevel 2 (?)

  1. #1

    Default mysql at runlevel 2 (?)

    I don't know who needs mysql at runlevel 2 (just don't tell me it is KDE!). But that doesn't seem to work (anymore).

    /etc/init.d/mysql (on 11.3 and 11.4)
    Code:
    ### BEGIN INIT INFO
    # Provides:       mysql
    # Required-Start: $network $remote_fs
    # Required-Stop: $network $remote_fs
    # Default-Start:  2 3 5
    # Default-Stop:
    # Short-Description: Start the MySQL database server
    # Description:    Start the MySQL database server
    ### END INIT INFO
    However (11.3) :

    Code:
    # lsb_release -r && grep 'Default-Start' /etc/init.d/network
    Release:        11.3
    # Default-Start:        2 3 5
    
    but (11.4)

    Code:
    # lsb_release -r && grep 'Default-Start' /etc/init.d/network
    Release:        11.4
    # Default-Start:        3 5
    I don't know why network is not started at runlevel 2. Notice that network just configures the interfaces. It doesn't start any network service. So there is nothing weird in having it running at 2 (as in 11.3, 11.1 as far as I can check around here).

    I don't know either why mysql is supposed to be started at runlevel 2 under openSUSE (not the case in Fedora, for example). But unless I missed the point, there is something wrong here, since you cannot enable mysql as it requires network at runlevel 2. The fix is either to add runlevel 2 to /etc/init.d/network or delete it from /etc/init.d/mysql.

    Is that a bug or what did I miss?

  2. #2

    Default Re: mysql at runlevel 2 (?)

    please try again wrote:
    > I don't know either why mysql is supposed to be started at runlevel 2
    > under openSUSE (not the case in Fedora, for example). But unless I
    > missed the point, there is something wrong here, since you cannot enable
    > mysql as it requires network at runlevel 2. The fix is either to add
    > runlevel 2 to /etc/init.d/network or delete it from /etc/init.d/mysql.
    >
    > Is that a bug or what did I miss?


    Why does mysql need network? I thought its default configuration had
    networking disabled for security reasons. I remember having to
    explicitly enable it in the mysql config. But admittedly that was
    sometime in the dim and distant past

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: mysql at runlevel 2 (?)

    Even if you don't have ethernet, the lo interface is still available at level 2. I would say it's an init.d/network bug.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: mysql at runlevel 2 (?)

    On 2011-03-16 12:06, please try again wrote:

    > I don't know why network is not started at runlevel 2.


    By definition. Level 2 means multiuser with no network.

    As mysql needs network, it seems, it had to be removed from level 2.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5

    Default Re: mysql at runlevel 2 (?)

    Quote Originally Posted by robin_listas View Post
    By definition. Level 2 means multiuser with no network.
    Not exactly. It means multiuser without *remote* network.

    Quote Originally Posted by robin_listas View Post
    As mysql needs network, it seems, it had to be removed from level 2.
    IMHO it's either a fix or a bug in init.d/network. But I guess it's a bug.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: mysql at runlevel 2 (?)

    On 2011-03-16 21:36, please try again wrote:

    > IMHO it's either a fix or a bug in init.d/network. But I guess it's a
    > bug.


    Could be. In my 11.2, rcnetwork is enabled in runlevel 2.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: mysql at runlevel 2 (?)

    Quote Originally Posted by robin_listas View Post
    On 2011-03-16 21:36, please try again wrote:

    > IMHO it's either a fix or a bug in init.d/network. But I guess it's a
    > bug.


    Could be. In my 11.2, rcnetwork is enabled in runlevel 2.
    So it is in my 11.1 and 11.3.

  8. #8
    Join Date
    Nov 2009
    Location
    USA
    Posts
    14

    Default Re: mysql at runlevel 2 (?)

    I haven't ran in to this. All I did was install the package, open YaST and go to System, and enabled MySQL in the System Service (Runlevel) applet. Seems to work fine.

    Curious though, did you install in the YaST gui or through zypper at the console?

  9. #9

    Default Re: mysql at runlevel 2 (?)

    Quote Originally Posted by NeoGraven View Post
    I haven't ran in to this. All I did was install the package, open YaST and go to System, and enabled MySQL in the System Service (Runlevel) applet. Seems to work fine.
    Oh yes I believe you.

    Quote Originally Posted by NeoGraven View Post
    Curious though, did you install in the YaST gui or through zypper at the console?
    Correct. I installed pattern and packages through zypper from installation scripts I write for openSUSE - and other distros, then enabled/disabled services with insserv or chkconfig. No doubt that YaST would eat that bug. Although I have already seen YaST complaining in similar situations.

  10. #10

    Default Re: mysql at runlevel 2 (?)

    Carlos E. R. wrote:
    > As mysql needs network, it seems, it had to be removed from level 2.


    Just not true.

    <http://dev.mysql.com/doc/refman/5.5/en/can-not-connect-to-server.html>

    "A MySQL client on Unix can connect to the mysqld server in two
    different ways: By using a Unix socket file to connect through a file in
    the file system (default /tmp/mysql.sock), or by using TCP/IP, which
    connects through a port number. A Unix socket file connection is faster
    than TCP/IP, but can be used only when connecting to a server on the
    same computer. A Unix socket file is used if you don't specify a host
    name or if you specify the special host name localhost."

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •