Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

  1. #1

    Exclamation No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    Friends, I came across an issue, that used to be in one of previous versions of OpenSuse - no keyboard input in OpenOffice (now in LibreOffice) when SCIM is running.

    On Opensuse 11.4 I ran into this problem once again and have no idea what to do.

    On fresh install of Opensuse 11.4 and KDE with English (or Russian) language as primary language and Chinese as additional language SCIM is installed automatically. And in this case it works in every app (both QT and GTK), but LibreOffice.
    As soon as I quit SCIM, everything starts to work OK (but I have no opportunity to input Chinese characters in this case).

    That was difficult, but I managed to install IBus instead of SCIM on fresh install. And - surprise - got right the same behavior. Input works EVERYWHERE, but LibreOffcie. I quit IBus and input starts to work OK there.

    I've tried to switch IM method in qtconfig to IBus, ran "gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules" - all this was recommended in similar threads - nothing worked.

    What could this be? Is there a solution to keep Chinese input enabled in LibreOffice with either SCIM or IBUS?

    Thanks in advance!

    P.S.
    To test the input I've tried the following apps:
    QT - kwrite
    GTK - stardict
    Java - jedit
    Input worked OK everywhere, but LibreOffice.

    And one note: when I say "no input" - it exactly means, that there is no keyboard input. Not only typing, but also navigating menus with arrow keys and using keyboard shortcuts is disabled.

  2. #2

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus


  3. #3

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    Thanks for the reply!

    I came across this thread and it didn't help. I have the global variables set correctly.

    I've tried almost everything I could find on the net.

    I'm going to provide a quick instruction, how to reproduce this bug soon.

  4. #4

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    This bug is easily reproducible:

    I used Opensuse 11.4 KDE live-cd written on USB flash disk.

    1. Run LiveCD with default language settings (English) and make sure LibreOffice works OK.
    2. Connect to the internet
    3. Run software management, don't install all that stuff that it suggests (just to save some time)
    4. Search for "ibus"
    5. Install "ibus-qt", "ibus-gtk", "ibus-m17n". You may add whatever else you want.
    6. Relogin and make sure that IBus has autostarted (it should have icon in system tray)
    7. (optional) open IBus settings from tray and add some input methods there, which you like (note, that some of them are buggy)
    8. Open KWrite and test the input - should be OK.
    9. Open LibreOffice and see no input.
    10. Close LO and quit IBus. Launch LO and see that it works OK again.

    That's it. That's what I have, whatever I try.
    Using SCIM instead of IBus shows exactly the same behavior - you may try it out the same way.

    P.S.
    As I mentioned, this bug used to be in one of previous versions of OOorg with SCIM and the treatment was to use scim-bridge as input method (which really worked). Now with libreoffice and scim-bridge enabled it doesn't work again...

  5. #5
    Join Date
    Dec 2008
    Location
    Baden-Württemberg
    Posts
    14

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    replacing scim with ibus did not help. still no input into libreoffice documents.
    and w/o scim or another input method for japanese my computer is a bit less useful.

  6. #6

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    Exactly. I consider this bug as quite important, as a number of users won't be able to use their native language in office suite.

    Personaly, I can't switch to new Opensuse because of this. Have to keep 11.3, because SCIM works OK there.

  7. #7

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    I'm also experiencing this issue now that I've installed scim because I need Japanese input.

  8. #8

    Thumbs up Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    Solution and a work around found!

    Solution: wait for new version of LibreOffice - it should be fixed there.
    If you don't want to wait, you may try use a custom build of LibreOffice from one of the buildservice users - it's fixed there (see the bugzilla discussion for more info)

    Workaround:
    VERY simple.
    edit /home/[your-profile]/.bashrc
    add the following line:
    Code:
    export OOO_FORCE_DESKTOP=kde
    Relogin or reboot and enjoy - everything should work OK now. That worked for me with SCIM. Probably tomorrow, I will test it with IBus.

  9. #9

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    I'm not sure what I'm doing wrong, but I got this message after I logged back in "bash: export: `000_FORCE_DESKTOP=kde': not a valid identifier"
    Input still does not work for me in Libreoffice. Where did you find out about that work around?

  10. #10

    Default Re: No keyboard input in LibreOffice 3.3.1 with SCIM or IBus

    The problem is that there are 3 letters "O", not zeros (0)

    Before adding this to .bashrc try to input that line in
    terminal - you should get no error and LibreOffcie will work OK.
    Afterwards, add it to .bashrc to make make this variable set each time you login automatically.

    The link to the bugzilla, where you can find this workaround is in my previous post.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •