Results 1 to 3 of 3

Thread: NetworkManager takes 30 seconds trying to connect during boot!

  1. #1

    Default NetworkManager takes 30 seconds trying to connect during boot!

    Hello, I use openSUSE 11.3. Upon first install I was unable to use the wireless in every single machine I have installed openSUSE: 5 in total. The problem was always solved by a (wired) update and installing plasmoid-networkmanagement, but it was nevertheless extremely disappointing. Not to say ridiculous.

    I moved on, but soon realized that when NetworkManager is used to manage connections it tries to connect to some wireless connection at boot time (right when the service is started), taking 30 seconds before it realizes it won't do. I have never ever given, nor can I find where to do it in Yast, any global configuration to NetworkManager, so the only sensible thing for it to do here was not to try to connect, right?

    Anyway, because it did not actually delay KDE startup (which seemed to be able to run in parallel), I had been this past months living with it. But now, this seems to be preventing plasmoid-networkmanagement to connect. I now have to delete and recreate the connection every time I restart the computer - otherwise clickind on it has no effect. So my questions are:

    1) How to stop NetworkManager from trying to connect at startup?

    2) Why am I being forced to reconfigure NM on every startup?

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: NetworkManager takes 30 seconds trying to connect during boot!

    Some ideas:

    - Create/modify the NM system connections in /etc/NetworkManager/system-
    connections so that NM can connection while booting.

    - Modify /etc/sysconfig/network/config (NM_ONLINE_TIMEOUT) to set the
    timeout to something less than 30 seconds.

    - I have figured out that the plasmoid needs some time (especially after
    booting) before it is able to create a connection.
    You can also try to configure a connection with the plasmoid and set it to
    autoconnect. (Tested this with a wireless network at univerity, works great)

  3. #3

    Default Re: NetworkManager takes 30 seconds trying to connect during boot!

    Thank you for the advice. Even though the plasmoid looks great, I gave it up and installed wicd. It works hundreds of times better than NetworkManager.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •