Results 1 to 8 of 8

Thread: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    I have openSUSE 11.4 with standard KDE and two screens attached.

    Here's the question: How do I configure dual monitors when using the proprietary nVidia drivers?

    The openSUSE 11.4 installation put in the "nouveau" drivers for my nVidia card and I was able to configure dual monitors using KDE's Configure Desktop --> Display & Monitors GUI configurator. I could also set up dual monitors using a script based on xrandr (e.g. "xrandr --output VGA-1 --auto --pos 0x0 --output DVI-I-1 --auto --pos 1920x0")

    My screens are detected as VGA-1 and DVI-I-1 by the nouveau drivers.

    OK, today I switched to the proprietary nVidia drivers. Only one of the screens is now detected and displayed in the KDE monitor configurator and that's marked as "default" rather than as a VGA or DVI connection.

    When I run xrandr to configure monitors, I get error messages if I refer to VGA or DVI hardware.

    More info -- RPMs
    nvidia-gfxG02-kmp-desktop-260.19.36_k2.6.37.1_1.2-23.1.x86_64
    x11-video-nvidiaG02-260.19.36-24.1.x86_64

    More info -- from command "hwinfo"
    Model: "nVidia GeForce 8400 GS"
    Driver: "nvidia"
    Driver Modules: "nvidia"
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    Did you install the nvidia-settings program in YaST? If not, search on nvidia-settings and install it.
    I created an icon where I load the program as a root user using the command:

    Code:
    kdesu /usr/bin/nvidia-settings
    I always load the nVIDIA driver the hard way, but as far as I know, you would use this very same program to configure your monitors for Twinview in any case where you had loaded the nVidia driver.

    In the nvidia-settings program I select the "X Server Display Configuration", on the left tree. With both monitors turned on and neither one in power save mode, I press the Detect Displays button. The display not showing anything should then show up in the layout screen as disabled. I select it with my mouse, placing a red rectangle around the monitor and then select the Configure... button and change the new monitor from Disabled to Twinview and press OK. Next, I select the Position Button and place this monitor as being left/right/above/below my main monitor. My main monitor Position would say Absolute, but I suppose you could swap that around if you liked. Now, with the setup as I like I press the Apply button. This should cause your selections to take effect.

    Twinview places the two monitors together as one large single space. If you now go into KDE you will see that you have only one monitor setting, but it is the combined areas of both monitors. Further, you will see two monitors in the Multiple Monitors section, which was blank before. I think all this just means you need to use the nvidia-settings program to deal with two monitors when you install the nVIDIA driver.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    jdmcdaniel3 is running nvidia-settings as root enough to make the settings persistent?

    If it is I'm gonna bang my head against the wall or something cos it'll mean I've wasted hours on end over the past few days ... never even entered my head to just run it as root

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    jdmcdaniel3 is running nvidia-settings as root enough to make the settings persistent?

    If it is I'm gonna bang my head against the wall or something cos it'll mean I've wasted hours on end over the past few days ... never even entered my head to just run it as root
    The answer to that question depends on what you are trying to make stick. If you decide to save your settings using the "Save to X Configuration File", you must have root user privilege to do that. For most things though, I just go to the last "nvidia-settings Configurations" and save it in my home area as the default name and this seems to bring back my miscellaneous settings. Can I ask just what you are trying to save/restore between sessions that is not working?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    Thanks James -- that worked fine. But I also wanted to make the setup persistent, to come back when I reboot. And this will interest Ecky too:

    I ran the GUI as root with (as you advised) "kdesu nvidia-settings". When I was satisfied with the display/s in Twinview, I saved the file in my /home as xorg.conf as a point of reference. It won't do anything in that location, it's just a point of reference. To make the setup permanent, I copied that file into the directory /etc/X11 and it reproduces the configuration thereafter.

    So, thanks once again.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6

    Default Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    There was a bit more to it than that mate, had trouble getting desktop effects and dual monitor setup working with the nvidia driver, saving to xorg.conf from nvidia-settings was causing some of the problems

    What was going on and what I did in the end to get it working is on this thread here: OpenSuse 11.4 Nvidia xcomposite and xdamage error when enabling desktop effects

    Similar to what you did swerdna except I added the entries from the generated xorg.conf to /etc/X11/xorg.conf.d/50-monitor.conf (didn't have to run nvidia-settings as root)

    Last entry in the thread I linked to above gives a link to the page I used to help me work it out, some good info on there

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    Quote Originally Posted by Ecky View Post
    There was a bit more to it than that mate, had trouble getting desktop effects and dual monitor setup working with the nvidia driver, saving to xorg.conf from nvidia-settings was causing some of the problems

    What was going on and what I did in the end to get it working is on this thread here: OpenSuse 11.4 Nvidia xcomposite and xdamage error when enabling desktop effects

    Similar to what you did swerdna except I added the entries from the generated xorg.conf to /etc/X11/xorg.conf.d/50-monitor.conf (didn't have to run nvidia-settings as root)

    Last entry in the thread I linked to above gives a link to the page I used to help me work it out, some good info on there
    Thanks for that. Fortunately for me I don't need to shift it to 50-monitor.conf, maybe because I don't have much fancy desktop effects going. But I'm going to try out what you described just for interest.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8

    Default Re: Cannot run dual monitors with nVidia-gfxG02 proprietary drivers

    I don't know why mate, but using an xorg.conf totally killed all effects, (don't use many myself but those I do use I've gotten used to) yet if I put the exact same entries into 50-monitor.conf the problem with xcomposite and xdamage went away

    Incidentally, there aren't any entries for monitor1, screen1 or device1, just monitor0, screen0 and device0 which surprised me, up until 11.4 on this machine I needed both on the previous versions, though I previously used xinerama so maybe that's why

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •