Results 1 to 9 of 9

Thread: suse 11.4, wrong screensize

  1. #1

    Default suse 11.4, wrong screensize

    Hello
    After a fresh install of Suse 11.4 my X-system comes up with the wrong screensize 1680X1200.
    Instead I need 1600x1200.
    How can i set permanently the screensize I need ?

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: suse 11.4, wrong screensize

    Hello!
    Go to start menu-->system settings.
    And then system settings-->Hardware-->screenshot and screen and you set it here.

    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Απ: suse 11.4, wrong screensize

    Unfortunately at the next boot, the screensize is wrong again.
    Instead of following the advice of stamostolias, one can type the following in a console.
    "xrandr -s 1600x1200" and il will work until the next logout from X.

    Anyone knows how to make it permanent?

  4. #4

    Default Re: Απ: suse 11.4, wrong screensize

    After stumbling across the same problem with SuSE 11.4 and trying to figure it out on a standard DELL hardware, I found there is a "Save as Default" button at the bottom left side of
    "Start -> Applications -> Configure Desktop -> Hardware -> Display and Monitor -> Size and Orientation" dialog.
    Pressing "Apply" button only stores it only for the session.

    :-(

    Cost me a day.

  5. #5

    Default Re: suse 11.4, wrong screensize

    Attempting to "Set Default" in the Monitor window yielded an alert screen "Could not set the default setting for monitors." The problem may be that a monitor is not defined for this system. Clicking on "Detect Monitors" does nothing.

  6. #6

    Default Re: suse 11.4, wrong screensize

    to saffron1313

    Do you refer to KDE ? I am using Xfce graphical environment, due to outdated hardware Kde doesn't come up very quick and with this version of Suse (11.4) at logout it even crashes.
    So I need something thet sets up X from startup, independ of what kind of graphical environment I might use.
    Thanks

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,703
    Blog Entries
    1

    Default Re: suse 11.4, wrong screensize

    @jomajo: You could add your mode-setting xrandr command to /etc/X11/xinit/xinitrc, so that it's executed upon starting the X-server. You'll need root privileges to edit though.

    Code:
    kdesu kwrite  /etc/X11/xinit/xinitrc
    There is a section dedicated to custom lines in that script:

    Code:
    #
    # Add your own lines here...
    #
    If you wish to make it user-specific, you can insert the xrandr command in ~/.kde4/Autostart/ or (~/.xprofile) as discussed here:

    My dual monitor settings won't stick

  8. #8

    Default Re: suse 11.4, wrong screensize

    @deano_ferrari
    Thanks, your solution solved my problem.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,703
    Blog Entries
    1

    Default Re: suse 11.4, wrong screensize

    Glad it worked for you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •