Results 1 to 8 of 8

Thread: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

  1. #1

    Question Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Om bijvoorbeeld het euro-teken te krijgen gebruikte ik in OpenSuse 11.3 of eerdere versies de keyboard instelling us intl.
    Bij OpenSuse 11.4 kan ik alleen kiezen uit o.a. nederlands of engels(us) maar niet meer us intl.
    Misschien kijk ik op de verkeerde plek?
    Kan iemand me vertellen hoe ik de mogeljkheid van accented character en Euro weer ingesteld krijg.

    Ik gbruik een 32-bit versie 11.4 installatie als virtual system in VirtualBox onder Windows 7 Ultimate.
    Hardware: Sony laptop, 4 GB intern, 500 GB HD

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Als je eerst een uitlegde hoe je de € en de enz. maakte, dan kunnen we misschien met je meedenken.
    Henk van Velden

  3. #3

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Tot nu toe werkte dit met [Alt Gr + 5] voor € en [ "+e] voor of [`+a] voor enz.
    Oftewel dezelfde manier als bij Windows.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Quote Originally Posted by joopbrink View Post
    Tot nu toe werkte dit met [Alt Gr + 5] voor € en [ "+e] voor of [`+a] voor enz.
    Oftewel dezelfde manier als bij Windows.
    Ik weet niets van Windows, dus dat zegt mij niets.

    Ik gebruik LinksShift-RechtsCtrl als inleiding tot dode toetsen en kan dan tekens creren met combinaties die logischer zijn dan die van jou, bijv:
    =e voor €
    'a voor
    `A voor (als bij jou +a is voor , hoe maak je dan ?)
    ,c voor
    ,S voor Ş
    ^1 voor
    en nog veel meer voor mij logische combinaties.

    Ik laat dit alleen zien om aan te geven dat het idee dat er slechts n manier is om dit te doen namelijk die van MS niet juist is. Uitleggen wat je doet als je iets aankaart is nooit weg.

    Ik heb in (openSUSE 11.2, KDE 4.3) KDE Systeem Instellingen > Persoonlijk Land/regio en taal en dan Toetsenbordindeling vs us staan. Ik zie geen us intl. Waaa doe jij dat? Of gebruik je geen KDE (heb je ook niet verteld).
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    In de nieuwste KDE's gaat dit als volgt:

    Systeeminstellingen, Invoerapparaten, Toetsenbord, Geavanceerd. Daar "Oude opties herstellen" aanvinken, Samensteltoets op Rechter Alt zetten, Toepassen, ķļȧŗ.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Feb 2012
    Location
    Woerden
    Posts
    36

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Het is mostard na de maaltijd als ik naar de datum kijk maar zelf had ik niet echt het idee dat dit nu de oplossing was, je moet nu extra toets indrukken om een samengesteld teken te krijgen. Ik vond een wat diepere oplossing die voor mij wel werkt op:
    http://sites.google.com/site/computertip/varia

    hierin staat:
    Zet de Option XkbVariant "intl" in het volgende bestand:
    /etc/X11/xorg.conf.d/90-keytable.conf

    Code:
    Section "InputClass"
        Identifier "LocalKeyboard"
        MatchIsKeyboard "on"
        Option    "XkbLayout"    "us"
        Option    "XkbVariant"   "intl"
    EndSection
    Let op: gebruik geen spaties maar de tabtoets! Met spaties werkt het niet.
    Opslaan, sluiten, computer volledig herstarten. Controleer daarna even of de dode toetsen werken, in uw tekstverwerker.
    Let op: als u deze ingreep wil toepassen voor een Brits-Engels toetsenbord, dan moet er bij XkbLayout "gb" komen te staan in plaats van "us".

    Dit werkte voor mij precies zoals ik het wilde, dus ' intoetsen en er gebeurd niets dan de e (bivoorbeeld) en het wordt é.

    Groetjes
    Kees

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Quote Originally Posted by Kevercat View Post
    Het is mostard na de maaltijd als ik naar de datum kijk maar zelf had ik niet echt het idee dat dit nu de oplossing was, je moet nu extra toets indrukken om een samengesteld teken te krijgen. Ik vond een wat diepere oplossing die voor mij wel werkt op:
    http://sites.google.com/site/computertip/varia

    hierin staat:
    Zet de Option XkbVariant "intl" in het volgende bestand:
    /etc/X11/xorg.conf.d/90-keytable.conf

    Code:
    Section "InputClass"
        Identifier "LocalKeyboard"
        MatchIsKeyboard "on"
        Option    "XkbLayout"    "us"
        Option    "XkbVariant"   "intl"
    EndSection
    Let op: gebruik geen spaties maar de tabtoets! Met spaties werkt het niet.
    Opslaan, sluiten, computer volledig herstarten. Controleer daarna even of de dode toetsen werken, in uw tekstverwerker.
    Let op: als u deze ingreep wil toepassen voor een Brits-Engels toetsenbord, dan moet er bij XkbLayout "gb" komen te staan in plaats van "us".

    Dit werkte voor mij precies zoals ik het wilde, dus ' intoetsen en er gebeurd niets dan de e (bivoorbeeld) en het wordt é.

    Groetjes
    Kees
    Ik weet dat 't zo kan, maar je kunt zo niet alle tekens maken die je met de samensteltoets wel kunt maken. Sowieso is met de 12.1 release een eind gekomen aan de internationaal geaccepteerde gedachte dat wij een NL toetsenbord gebruiken (probeer er eens één te kopen ), maar met de hierboven al eerder beschreven methode kun je echt tekencombinaties maken. "Ralt+' e" geeft é, "Ralt+, S" geeft Ş. æ is ook geen probleem.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Feb 2012
    Location
    Woerden
    Posts
    36

    Default Re: Hoe us intl keyboard instellen in OpenSuse 11.4 ?

    Quote Originally Posted by Knurpht View Post
    met de hierboven al eerder beschreven methode kun je echt tekencombinaties maken. "Ralt+' e" geeft é, "Ralt+, S" geeft Ş. æ is ook geen probleem.
    Oké, weer wat bij geleerd . Voor de laptop van mijn vrouw is die diepe voldoende, zelf hou ik de ander in mijn achterhoofd want dat klink ook wel aantrekkenlijk.
    Het verschil is nu wel duidelijk geworden en maakt een keuze mogelijk, bedankt voor de uitleg.

    Groetjes
    Kees

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •