Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

  1. #1
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    154

    Default Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    Hello,

    I have installed 11.4, and it seems (seemed) to work OK so far. I installed Thunderbird via the opensuse "1 click install". the installation ran smoothly, but now a click on the Thunderbird icon does not activate any mail client; the only success is that Thunderbird icon jumps joyfully and then disappears.

    Could anybody kindly suggest what I should look for?

    Thanks and best regards,
    J C Anker

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default AW: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    Not sure why you installed thunderbird via 1-click? Which repository did you use?
    The fact that it shows only a bouncing icon means of course it cannot start. Open a terminal (konsole or xterm or whatever you prefer) and start thunderbird from the command line. You probably will get error messages in the terminal window which tell us more about the problem.
    Post the output here so we can have a look at it.

  3. #3
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    154

    Default Re: AW: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    Hello Martin,

    here we go, the output is

    a) Running as user: --- (i.e. Nothing)
    b) Running as root:
    GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
    I did the one-click-installation from
    An (automatic) error report has been submitted to Mozilla (after running as SU).

    Thanks,
    Jan Christian

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbirddoes not start

    On 03/15/2011 02:36 PM, jc anker wrote:
    >
    > b) Running as root:


    do not run it as su/root..

    [as a general practice, do not run anything that can go out onto the
    internet as root, like a mail client, or browser, IRC,
    whatever...because *if* it picks up a root kit it will be more easily
    installed)

    to fix the TBird problem, i'd suggest you open YaST, go Software
    Management, search on thunderbird and right click to uninstall..and
    "Accept"..

    then open Software Repository and disable all repos except one
    instance of each of these four: oss, non-oss, update and packman

    ["1-Click" installs add repos, and maybe users don't know they should
    almost always disable them after the install is complete, OR answer to
    not keep them, when asked during the install...background: read the
    paragraph here http://tinyurl.com/33qc9vu which begins with "IMPORTANT"..]

    then, go back to Software Management, search on thunderbird and left
    click to uninstall...and "Accept"..

    doing that _should_ clean out whatever is blocking your pathway to
    happiness..

    if so, great...if not, post the new output if run from a _user_ terminal..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default AW: Re: AW: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    Oops, you never should start that as root. This can have nasty side effects for the access rights of some configuration files.
    From your search results I guess you installed the thunderbird from the mozilla repository.

    Ok so starting from command line as user told nothing (it simply returned to the prompt?).
    Can you check in your home folder if there are directories .thunderbird and/or .mozilla-thunderbird (if you use nautilus or dolphin activate that hidden files are shown) and if they are there delete them just in case you have some old or invalid settings . Try again to start thunderbird after deleting the hidden directories.

    Is that a completely fresh 11.4 install or an update from a previous version?

  6. #6
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    154

    Default Re: AW: Re: AW: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    Hello Martin,

    you asked:
    Ok so starting from command line as user told nothing (it simply returned to the prompt?).
    Answer: Yes, that is correct.

    No hidden directories having names starting with ".th" (or "./th") are found.

    You asked:
    Is that a completely fresh 11.4 install or an update from a previous version?
    Answer: Well, that may be true correct. 11.4 was installed as "new installation" without removing existing directories and files.
    See the outcome of ls -l below

    JCA@linux-5u5g:/usr/lib64/thunderbird> ls -l
    total 21012
    -rwxr-xr-x 1 root root 1464 Mar 1 16:24 add-plugins.sh
    -rw-r--r-- 1 root root 1991 Mar 1 16:23 application.ini
    -rw-r--r-- 1 root root 1677 Mar 1 16:23 blocklist.xml
    drwxr-xr-x 3 root root 4096 Mar 15 14:44 chrome
    drwxr-xr-x 2 root root 12288 Mar 15 14:44 components
    -rwxr-xr-x 1 root root 65192 Mar 1 16:25 crashreporter
    -rw-r--r-- 1 root root 3803 Mar 1 16:23 crashreporter.ini
    drwxr-xr-x 6 root root 4096 Mar 1 16:23 defaults
    -rwxrwxrwx 1 root root 52 Jul 5 2010 dependentlibs.list
    drwxr-xr-x 2 root root 4096 Mar 1 16:24 dictionaries
    drwxr-xr-x 3 root root 4096 Mar 1 16:23 extensions
    drwxr-xr-x 2 root root 4096 Mar 15 14:44 greprefs
    drwxr-xr-x 2 root root 4096 Mar 15 14:44 isp
    -rwxr-xr-x 1 root root 225848 Mar 1 16:25 libldap60.so
    -rwxr-xr-x 1 root root 14464 Mar 1 16:25 libldif60.so
    -rwxr-xr-x 1 root root 1201984 Mar 1 16:25 libmozjs.so
    -rwxr-xr-x 1 root root 23072 Mar 1 16:25 libprldap60.so
    -rwxr-xr-x 1 root root 585808 Mar 1 16:25 libsqlite3.so
    -rwxr-xr-x 1 root root 52008 Mar 1 16:25 libssldap60.so
    -rwxr-xr-x 1 root root 807992 Mar 1 16:25 libxpcom_core.so
    -rwxr-xr-x 1 root root 18904 Mar 1 16:25 libxpcom.so
    drwxr-xr-x 4 root root 4096 Mar 15 14:44 modules
    -rwxr-xr-x 1 root root 19128 Mar 1 16:25 mozilla-xremote-client
    -rw-r--r-- 1 root root 46 Mar 1 16:23 platform.ini
    -rw-r--r-- 1 root root 183 Mar 1 16:23 README.txt
    drwxr-xr-x 6 root root 4096 Mar 15 14:44 res
    -rwxr-xr-x 1 root root 10461 Mar 1 16:23 run-mozilla.sh
    -rw-r--r-- 1 root root 825 Mar 1 16:23 Throbber-small.gif
    -rwxr-xr-x 1 root root 18386320 Mar 1 16:26 thunderbird-bin
    -rwxr-xr-x 1 root root 3980 Mar 1 16:24 thunderbird.sh
    JCA@linux-5u5g:/usr/lib64/thunderbird>
    As you see, there are some files left from previous installation ("Ueberbleibsel"). Should I delete them and install Thunderbird anew?

    Thanks for you efforts,
    Jan Christian

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    jc anker wrote:

    >
    > As you see, there are some files left from previous installation
    > ("Ueberbleibsel"). Should I delete them and install Thunderbird anew?


    Ok that looks really like a problem. You have somehow now a mixture of files
    from two versions.
    Do what DenverD suggests first (uninstall with yast), then check that
    thunderbird folder agin to see if there is still somthing there and delete
    that by hand.
    Afterwards install thunderbird with yast again and hopefully this solves the
    problem.
    (Maybe you should logout and login after the reinstall to stop running
    processes)

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbirddoes not start

    On 03/15/2011 04:36 PM, jc anker wrote:
    >
    > You asked:
    >> Is that a completely fresh 11.4 install or an update from a previous
    >> version?

    >
    > Answer: ... 11.4 was installed as "new
    > installation" without removing existing directories and files.
    > See the outcome of ls -l below


    are you saying you used one of the update methods listed here:

    http://en.opensuse.org/SDB:System_upgrade

    or here:

    http://doc.opensuse.org/products/ope...ha.update.html

    or, are you saying you did a "new installation" but did not accept the
    install scripts partitioning suggestion (which would have been to
    format the root directory, at least)??

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbirddoes not start

    On 03/15/2011 05:14 PM, martin_helm wrote:
    > Do what DenverD suggests first (uninstall with yast), then check that
    > thunderbird folder agin to see if there is still somthing there and delete
    > that by hand.


    depending on how those 'extra' files got there (which i hope to learn
    with my just posted question) i may well suggest a completely
    different solution..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Rel. 11.4: Thunderbird Icon Jumping, stops jumping; Thunderbird does not start

    DenverD wrote:
    >
    > depending on how those 'extra' files got there (which i hope to learn
    > with my just posted question) i may well suggest a completely
    > different solution..
    >

    I also have another clean solution in mind which is reinstall with formating
    the root partition and leave the /home partition untouched. Since after
    thinking about this I doubt that thunderbird is the only program which is
    affected. Most likely the whole system is now a mixture of leftover files
    from the previous version + some overwritten by the new 11.4 version files.

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •